Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartLink stopped working ... is the server down?

Flex 6400 w/2.6.4 has been working fine for months. We access it via SmartLink as we are remote to the Flex.

Today, neither of us can access the Flex via the Internet.

However, we can if we connect via SmartSDR on the LAN side or direct. I also know that the Internet link and the router are OK as I can connect to a NUC on the LAN side, then run the Flex using SmartSDR. (NUC is connected to the switch on the LAN side of the router)

My host ham even reloaded 2.6.2 and nothing changed. We can access the radio via SmartSDR on the LAN but no longer via SmartLINK.

I tried logging in to SmartLINK but after entering my E-mail and password, I get a screen that simply says "OK". Nothing else. Can't do anything to as the only way back is to click on "cancel"

  • Internet and router are OK
  • Flex is OK (can access via SmartSDR on LAN side
  • SmartLINK server seems down

Any ideas?


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
  • do4ai
    do4ai Member ✭✭
    SmartSDR for the Mac and for iOS continue to run flawlessly with SmartLink.

    These apps do not seem to be affected by this problem.
  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    Still down (sigh) ... seems like the solution that the alpha testers are looking at will require installing a new client.

    This whole escapade is making me look at either changing radios to one that does not need to "call home", or setting up a hardware VPN at the remote site. The VPN approach should let me and my host ham access the radio on the LAN side, hence not needing SmartLINK.

    I like the Flex but dislike the need to go through their server to use SmartLink. I assume it's for licensing control. If so, there should be other ways to manage the licenses. If it's for "RendezVous" support, then that should be optional. I use DynDNS and have had no issues over a decade working with the other radio at the site (TS-480SAT) and a pair of RemoteRig interfaces. This has been working just fine after ISP changes (now Spectrum) and multiple IP Address changes.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited May 2021

    @W4AFK Bruno There are VPN solutions that work well and are even well documented here in the community.

    You will want to search for SoftEther. We used to use it before SmartLink.

    I, like you, used a TS-480 and RemoteRig. Terrible radio when compared to anything of a 6000 nature, but the solution did get me on the air.

    Since you have run RemoteRig you should have no issue getting SoftEther running if you need a backup to SmartLink.


  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    I can't find anything on SmartETHER VPN, But there is a SoftETHER VPN.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Sorry, my bad if I typed it incorrectly.


    This script might help https://github.com/MarkZither/SoftEther-VPN-config

  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    Sad ... but still no current update or solution for us Windows based SmartLink users. Still can't access my remote FLEX-6400 radio using SmartLink.

    Lucky for me I have a remote TS-480SAT w/RemoteRig that I can use on the same amp/antennas. But I am sure that I am the exception for having two remote HF radios at the same site.

  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    Mike - Thanks for the link. I'll study that. However, as I don't want to mess it up, I'll, aske for help from those who have already done this

  • Ignacy
    Ignacy Member ✭✭

    How is audio lag with SoftETHER VPN? Any different from SmartLink?

    Ignacy NO9E

  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Hi Ignacy, I haven't noticed any difference, but I have not measured it either. I have not operated much with the Softether VPN, but next time I travel where I have cell service, I will give it a better workout. Since I use my cell phone as a hotspot, it is hard to tell whether latency is the cell service or the VPN. I recently used SmartLink and my hot spot from my 5th wheel camper, and it worked really well. I only plan on keeping the Softether link available as a backup once we have the SmartLink upgrade.

  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    IT WORKS ... Had my host ham install SmartSDR 2.7.5 at the remote site in Florida. He had no issue and it went fine. If he wasn't available I would have done it via the NUC as I can also remotely control the AC power outlets.

    I then installed v2.7.5 over here in San Diego and after logging in, I am able to use the Flex 6400 again :-)

    I was also surprised that all of my settings and memorized channels were maintained (I did export everything to csv and saved them on the NUC).

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.