Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

MAC WiFi Performance

Mike-VA3MW
Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
edited August 2020 in SmartSDR for Mac

I have been testing the SmartSDR for MAC on my MacBook pro on WiFi.

The WiFi is a TP-Link M5 Mesh (and, no, you can't tell if you are on 5G or 2.4Ghz) which would help.

I am not impacted by other WiFi networks since the nearest neighbour is over 500M away and they aren't actually home.

I do get significant packet loss (those show up as Horizontal lines) in the waterfall even with the FPS and RATE turned way down.

SmartSDR for MAC is the only app running.

I know nothing about MAC internals and even less on their Network tuning. Are there tools I can use to do some digging to see if I am getting packets losses?

This is NOT a SmartSDR for MAC issue, but an environment issue that I am trying to solve, so I am reaching out to the Guru's on the MAC world.

Thanks, Mike va3mw

Answers

  • Gordon, ve7on
    Gordon, ve7on Member ✭✭

    Hi Mike,

    I do not have an answer to your problem but maybe a solution.

    Apple sells an adapter to connect a LAN cable to a USB port. Not expensive and works very well.

    73 Gordon, ve7on

  • George KF2T
    George KF2T Member ✭✭✭
    edited August 2020

    What are the Network Stats inside SSDR/Mac showing? Anything outside what you'd expect?

    I've got a home mesh, too. Flex is hardwired to one node, my desktop Mac (in another room) also hardwired to another. Does your mesh router have a test facility to look at overall performance and RSL? I'd start there.

    FWIW, I've included the most recent test here. Don't have any significant problems (occasional audio hits).

    Good luck!

  • tparish
    tparish Technology Specialist Member ✭✭
    edited August 2020

    Mike VA3MW, a couple of things to rule out first, just to be sure it's 'all' related to packet lose in the network code.

    Do a clean reboot of the MacbookPro. Exit out of all the apps and any browser tabs. Do not load any other apps with SmartSDR (for the test).

    Is there any difference in the behavior.

    Also, how much RAM do you have in your system?

    Finally, one way to be sure you don't have anything pulling cpu cycles go to SPOTLIGHT and search for Activity Monitor and see what processes are running. Note, browsers can impact performance on older Macs with 4-8GB.


    Tom KB5RF

  • Jon_KF2E
    Jon_KF2E Member ✭✭

    One other tip is to hold down the option key while clicking the wifi fan and you will see a lot more info on your wifi connection.

    Jon...kf2e

  • Ray G6UJB
    Ray G6UJB Member ✭✭

    Just interested to know why is this posted as an announcement ?

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Likely because I did it wrong. I'm sure Tim is going to remind me. :)

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    George, yep... I am clean as I am in a remote area. There is on 2 other APs. :)

    Tom, thanks, I have done that. But, yes something is stilling CPU cycles and cause pauses in WiFi communications.

    Jon, I will have a look

    Gordon, yes that is plan B, but my Mac is my bigger version of my iPad. It is never at my normal operating desk. Hardwiring it is easy enough to do, but I would rather improve the WiFi stuff. It took me months of digging under the covers on Windows to understand it. I see a lot of Terminal digging in my future.


    73 all

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin

    @Mike-VA3MW I won't say anything about making the post an announcement, but...

    In this post, you asked a question where you wanted to get an answer, but the post was designated as a discussion topic. Please see the Message Board post Using New Q&A (Question & Answer) Feature for how to create a Question and Answer (Q&A) post. I went ahead and converted your post to a Q&A. 😎

  • Patrick
    Patrick WH6HI KauaiMember ✭✭✭

    I have experienced the pauses also. The pauses seem to be app driven rather then wifi. The reason I say this is that I run wsjt and SmartSDR FOR Mac on an i7 Mac mini. Each time there is a decode in wsjt the pause happens. So it is most likely internal to the Mac in regards to the apps communicating internally. If I do not run wsjt I see no pauses.

  • Gordon
    Gordon Member
    edited August 2020
    I have experienced audio pauses/drop outs as well. Interesting note- Running Parallels and SmartSDR 3.1.2 on Windows seems to work well as long as no other programs are running. The new SmartSDR for Mac version seems to experience between 9 and 15% error rate with audio dropouts (Parallels and Windows shut down during test). I have not tried transmit audio as of yet. The Maestro runs well on same wifi access point.

    Gordon, KW4EX
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    If you are like me, and want to dig under the covers, this might help.



  • Patrick
    Patrick WH6HI KauaiMember ✭✭✭

    I need to add to my last post. I am not running the Mac/Radio connection via WiFi. It is gigabit Ethernet wired connection and I am still having those dropouts. The problem may be more in the direction of drivers. The place to look would be in the subroutines running at the time of the dropout. If SmartSDR FOR Mac is running all by itself, I don’t see the dropouts.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    This is what I am seeing. The Audio sub system seems to be easily impacted by other applications.

    That is not the same when stream audio (I'm watching a hockey game) and it is seemless. But, that is a different situation when we don't care if the streaming video/audio is delayed.

    You might want to try playing with the buffer sizes too. Larger buffers may give you more latency.


    Mike va3mw


  • snacey0103
    snacey0103 Member ✭✭

    Was there any conclusion to this thread?

    I am a new SmartSDR user with an M1-Mac Macbook Pro. My Flex-6400 is connected via Wifi 2.4 Gig (as hardware connection is prohibitive in my home) and my Mac is also WiFi 5 Gig connected. I have mostly be operating Digital and CW to start, but now am trying SSB. My first SSB contact reported substantial transist audio drop out - but I also have receive drop out regularly.

    I am just starting the debugging adventure with this - I will disable the CAT/DAX loopback, I have already looked at Wifi signal strength and it is good at both ends. I have turned off Location Services.

    @Mike-VA3MW what else did you try / find?

    Thanks all!

    Scott, W1MVY

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Hi Scott

    There isn't much more to really add. Your WiFi mileage may vary as you are finding out.

    I don't think the issue is with the Flex applications, but more with the WiFi part. What else is going on on your WiFi and your neighbours' WiFi since they all share common frequencies and have to leave time for each other to transmit.

    Think of it like WiFi QRM.

  • Jon N4BRJ
    Jon N4BRJ Member
    I know this is an old thread but this may help someone in the future. The application "NetSpot" has a free version available at https://www.netspotapp.com/netspotpro.html (scroll to the free trial version at the bottom). It will display the WiFi node you're connected to (in Red) and all other WiFi signals received by your Mac. You can also see which band (2.4 or 5) you're connected to and the channel number. The channel number is handy to know because you can then set your WiFi AP to an empty channel once you know the channels being broadcast around you.
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭

    Also want to add two things:

    1) Newer Macs, (which you seem to have) have improved their WiFi performance. It used to be pretty bad.

    2) Pairing the WiFi with a really good WiFi access point can help. I use Ubiquity Uni Fi pro APs and my audio studder / dropouts are very rare now.