Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Change Mode using USB Cable

Ron K2RASRon K2RAS Member ✭✭
I am successfully using a USB cable to communicate with an Arduino-based mag loop controller.  The cable passes transmit and frequency comands but will not change the mode to AM for tuning the antenna from the Arduino.  

I presume that any remote tuner connected by USB would need an AM carrier.  I have not had success with DDUtil and would prefer the 'direct' USB cable option.  Has anyone been successful changing modes using the USB cable?

Thanks, Ron K2RAS

Answers

  • MackMack Member ✭✭
    edited March 2019
    Ron,

    The Flex USB cables output three types of data CAT (bi-directional), BCD, and Bit. All you should need to do is press the tune button in SmartSDR to cause the tuner to do its job. The tuner would need to be set to tune automatically. Tune is simply a carrier (CW) similar to an unmodulated AM carrier. If I've missed the point then perhaps you could provide specifics on the tuner you are using so that I can research it on the web.

    73,

    Mack
    W4AX
  • Ron K2RASRon K2RAS Member ✭✭
    edited June 11
    Mack, thanks for replying.  Actually I do not want to use the Flexradio tuner.  My application is a mag loop tuner with a motor driven variable capacitor on the antenna.  The tuner is Arduino-based with both memory capacitor settings and automatic SWR tuning.

    The Arduino tuner is programmed to initiate a tune cycle which sets the mode to AM, drops the power level, tunes the radio, and then resets the radio to its initial settings.  This works fine with an ICOM 7300 radio, so either the commands are incorrect for the Flex (it is using Kenwood TS-2000 commands), or the USB interface on the Flex does not support the mode switch and power level commands.

    As mentioned, the direct USB cable with the FTDI interface does properly initiate a tune and pass frequency data from the Flex.  If I could get the other functions to work I would not need to use DDUtil (which I can not get to work) on the current SmartSDR release.

    I appreciate any advice.
    Ron/K2RAS
  • MackMack Member ✭✭
    edited March 2019
    Ron,

    Sorry for the tardy reply but I've been thinking about your question. The USB ports on the back of the computer, as far as I know, do allow for input of CAT commands. 

    Perhaps a better application would be to have your tuner assert a Tune command via normal CAT running on a PC. CAT on the Flex is handled using software verses hardware to minimize the spaghetti cables that are behind a typical radio.

    73,

    Mack
    W4AX
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited January 2019
    I think Mack said Tune, only to send a carrier, not ATU to have the tuner function.

    I am not sure if there is a CAT command to send TUNE.

    Mike
  • Ron K2RASRon K2RAS Member ✭✭
    edited January 2019
    Mike, would you please confirm if the USB port supports a 'tune' command equivalent to pressing the 'ATU' button to initiate a tune process.  If so, what would be the command string?

    Much appreciated,  this is the final challenge getting the loop controller to function with the Flex.

    Ron / K2RAS
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited January 2019
    Hi Ron

    That CAT user guide is at https://www.flexradio.com/downloads/smartsdr-cat-user-guide-pdf/

    It looks like you can set the TX mode, power and then put the radio into TX  Have a look and see if you can find a solution.  You can then return it to the previous state.

    Mike
  • Ron K2RASRon K2RAS Member ✭✭
    edited January 2019
    Thanks for the hint, I am really close.  The USB CAT Monitor shows the following data when I attempt to tune the radio.  The MD command sets/reads the mode.  2=USB and 5=AM.  Everything is working but the MD5 command is not setting the mode to AM.  Could I get someone to take a quick look and see what is wrong or not working?

    Thanks, Ron / K2RAS

    17:46:03 (RX): PC;
    17:46:03 (TX): PC000;
    17:46:03 (RX): MD;
    17:46:03 (TX): MD2;
    17:46:03 (RX): MD5;
    17:46:03 (TX): ?;
    17:46:03 (RX): PC010;
    17:46:03 (RX): TX0;
    17:46:03 (TX): TX0;
    17:46:06 (RX): RX;
    17:46:06 (TX): RX0;
    17:46:06 (RX): MD2;
    17:46:06 (TX): ?;
    17:46:07 (RX): PC000;


  • Ron K2RASRon K2RAS Member ✭✭
    edited January 2019
    I tried a transmit mode of CW instead of AM (MD3) with no improvement. The delay was also increased to 1 sec in case the radio needed more time to process the command. No luck.

    Thanks, Ron
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited January 2019
    What about using ZZMD?
  • Ron K2RASRon K2RAS Member ✭✭
    edited January 2019
    No change.  The ZZMD command shows a  2-digit '05' for the AM mode while the MD command shows a single digit '5'.  I presume the P1 values are a numeric in either case.  Does the question mark indicate that the Flex is not interpreting the MD command properly?

    Ron

    19:12:30 (TX): IF000140700001000+0000000000020000000;
    19:12:31 (RX): PC;
    19:12:31 (TX): PC000;
    19:12:31 (RX): MD;
    19:12:31 (TX): MD2;
    19:12:31 (RX): ZZMD5;
    19:12:31 (TX): ?;
    19:12:31 (RX): PC010;
    19:12:31 (RX): TX;
    19:12:31 (TX): TX0;
    19:12:34 (RX): RX;
    19:12:34 (TX): RX0;
    19:12:34 (RX): ZZMD2;
    19:12:34 (TX): ?;
    19:12:35 (RX): PC000;
    19:12:35 (RX): IF;
    19:12:35 (TX): IF000140700001000+0000000000020000000;


  • Ron K2RASRon K2RAS Member ✭✭
    edited January 2019
    Should this be elevated to a support ticket?

    Thanks, Ron
  • bobbybobby Member ✭✭
    edited January 2019
    try MD02; you are only providing 1 digit it wants 2 digits for the mode selection.
  • Ron K2RASRon K2RAS Member ✭✭
    edited June 3
    I tried MD05 and ZZMD05 with no improvement, there is still a (TX): ? following the command. 

    Ron
  • Ron K2RASRon K2RAS Member ✭✭
    edited January 2019
    I still cannot get the radio to acknowledge a mode change using the USB connector.  Any help from your end?

    Thanks, Ron
  • Ron K2RASRon K2RAS Member ✭✭
    edited January 2019
    I have confirmed that RMS Express sends an 'MD9' over a CAT port successfully to change modes, and FLDigi successfully sends an 'MD9' over TCP port 5002.  If I try to send an MD9 over the USB cable the radio does not successfully change modes.

    Ron
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited January 2019
    Ron, the CAT manual shows ZZMD06; for AM. Unless the manual has a typo.

    And instead of MD9 for DIGIU try ZZMD07;

    Dave wo2x

  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited January 2019
    Hi Ron

    At this point, I would ask that you summarize your findings and open a support case so we can trace it correctly.  This way it will get engineering visibility.

    Mike
  • bobbybobby Member ✭✭
    edited June 11
    See page 114 or 110 of the last 2 user manuals which list the acceptable commands via cat on the cables, you will not find a command listed which will allow you to change modes on the cable you can get or see which mode is in use in the slice by using the ZZIF command. So you will have to see what mode its in then send an api command via network to change to the mode you want. Its not a bug its the wayit was designed to work according to the documentation. The mode change commands work fine via api and the network.
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited January 2019
    Actually several programs allow you to change modes via serial CAT. WSJT-X and Ham Radio Deluxe are just two examples. As long as Ron's program is sending the proper syntax it should work. Look at my reply further up to Ron. The commands he was sending that didn't work via CAT were different from the latest CAT command reference.

    Dave wo2x

  • bobbybobby Member ✭✭
    edited January 2019
    You can change modes with cat but not through the cable he is trying to use on the usb port.
  • Ron K2RASRon K2RAS Member ✭✭
    edited June 3
    Flex has confirmed that the USB port does not presently support the Mode change command.  The mode can be changed using a standard CAT or serial port. 

    Thanks for all the help that others suggested.

    Ron / K2RAS
  • Steve-N5ACSteve-N5AC Community Manager admin
    edited January 2019
    Mode change over CAT cable has been added in v3.0, FYI
  • FRED  W9TBFRED W9TB Member ✭✭
    edited January 2019
    Steve
    Is the vox and dax not working together going to be fixed before v3.0. ? I hope so I am a vox person. 

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.