Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex Lockup on 1.10.16

2456714

Comments

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    A few times over what time period?  A day?  Several days?  A week?  More?
  • Paul MPaul M Member
    edited March 2017
    Hours
  • ka7gzrka7gzr Member ✭✭
    edited March 2017

    Tim

    Would it be worth while to have a short form for people to fill out when this problem occurs?

    Jim

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Paul. Please open a HelpDesk support ticket. I'd like to talk to you more in detail. If another support representative picks up your ticket before I do, please instruct them to assign it to me. Thanks.
  • Andy M5ZAPAndy M5ZAP Member
    edited March 2017
    On 1.10.16 I have had one lockup. On 1.9.13 I had zero On the beta software I had 3 or 4 before reverting back to 1.9.13
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    It is a reasonable suggestion, but I suspect the form would either be too short or very long to cover the bases ;-)

    This issue is intermittent and does not affect everyone.  In addition, some people have experienced very few incidences, others it happens more frequently.  And because the issue does not generate any user-visible data when it happens, it makes debugging very challenging.  If it was happening reliably to radios under our physical control (in the office), we have a very good chance in determining root cause and fix it.

    We suspect that the issue is partly environmental in nature, meaning that things in your shack connected to the radio either physically or via the network may play a role.  We do believe that using particular features of the radio is a probable triggering mechanism, but there isn't a direct causation (press this button, radio crashes).

    The type of information that is helpful is version of software you are running, radio model, the frequency of the radio faults (radio is not accessible by client software and a long-press of the power button or removing the DC power is needed to recover), the operating mode, what is physically connected to the radio hardware, they type of client and software connected to the radio and what you were doing with the radio at the time of the fault (operating digital modes, contesting, rag chewing, chasing DX, etc..).

    Occasionally we'll ask a few people who are having these types of to open a HelpDesk ticket so we can do more detailed diagnostics in a one-on-one manner if we feel that we can glean some useful information by doing so.  In particular, if someone experiences the issue only once a week or every few days, then that is not as useful as some who experiences the issue several times a day.  We need to have multiple opportunities to catch the issue when it happens so that we have a better probability of getting good diagnostics in order to get to root cause.

    We take these types of issues very seriously and we are working on it.  We completely understand your frustration and want this issue resolved as much or even more that you do.  Thanks for your understanding.
  • Paul MPaul M Member
    edited March 2017
    There is one open and I have given Dudley the same information as posted here.   For me, if I totally power offer the radio when it loses connection then I do not seem to have the freeze.  If I power down the radio after a freeze (the radio does not appear in the chooser window at this point) then I will get a few more loss of connection and then a freeze.  It seems to happen more in Digu mode but I spend most of my time in Digu or CW.  I have had freezes in CW but not in the last week.   I did have loss of connections with 1.9.9 but no hard freeze.  I have not been on Phone enough to give and opinion.   

    I changed the network hub, change from an AMD to an i5 Intel with only the system, WSJT-X 17.0 r7405 and SmartSDR.  I have had shutdowns and freezes occur.   Let me know if you want me to try anything else.  What I have not tried is if it is freezing with my profiles.  This weekend I plan to run with just the standard profiles and see if I have any of the anomalies.  My profiles were previously in a 6300.  
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Did you instruct Dudley to assign the ticket to as requested?  I do not see it in my work queue.
  • Paul MPaul M Member
    edited March 2017
    Just did, those pesky clients got in the way of my hobby.
  • Don, VE2HJDon, VE2HJ Member ✭✭
    edited March 2017

    Hi Tim,

    This morning at exactly 10h00Z i experienced a new lost of connection with the radio. ( the popup message ). At this very moment i was looking at the "Network Diagnostics" window in SSDR.

    The network was excellent and zero paket drop.

    Since it happened at exactly 10h00Z and the fact that we had a time change to daylight saving time; this make me think the lost are time related.

    Many digital modes need time sync. For this i do'nt use the ethernet time. I run a program called "Dimension 4" set to sync my computer time clock to a time server evary 10 minutes. 

    To recover the connection i clic the OK botton and the "Radio Setup" appeared but no radio in the radio chooser. I tryed a quick press of the power botton and no usual arasing of my message and shutting down message. But to my supprise after about a minute the radio tuned off.

    After powering the radio on it came back with only one Pan while i had two open. The setting of tha pan was all good.

    I noted many setting so if you need more info i'll be glad to send you.


    Software : v 1.10.16 174

    Radio : Flex 6500 ; v 1.10.16.91




  • Andy M5ZAPAndy M5ZAP Member
    edited March 2017

    Hi


    I run dimension 4 and I was just preparing a post to say one of my lockups was after a dimension 4 time reset. But only 0.2 second time correction.

    I could tell that they were aligned because the WSJT-X last log was aligned to a time resync, I re-sync every 30 mins, as you I re-sync for digital modes operation.

    I will do a full post later as to the full scenario around my latest Lockup / Lost connection as I went onto to have 4 further lockups / lost connections afterwards.

  • Andy M5ZAPAndy M5ZAP Member
    edited March 2017

    Hi Tim,

    I had a series of lockups today the details are as follows,

    1 - Flex was left switched on over night with nothing connected after I had used  SmartSDR from a laptop on the same network the night before.

    2 - This morning I switched on the main station PC and started the following softeware.

    Dax

    Smart SDR Cat

    Smart SDR (2 panadapters 4 Slice receivers all on 15m Band, exact freq available))

    WSJT-X (Slice C cat comms and dax audio)

    Jt Alert-X

    Dx Lab (Complete Suite of programs Ip comms from commander and audio (Slice A) from Dax for winwarbler )

    Dimension 4 (PC Time Sync)

    3 -System left monitoring 15m

    4 - Returning to sytem 1 hour later the flex was unresponsive and the "Lost connection" error message was displayed.

    5 - Flex needed long button press to reset

    6 - On restart smart sdr had both panadapters on 40m and no slices

    7 - went back to 15m and the system locked up shortly afterwards this happended 3 times. item 6 occurred each time.

    8 - Powered everything down and unplugged power from radio. Rebooted everything and ran ok all day.

    Looking at the last time the WSJT-X decoded before the first lockup this aligned with the time that Dimension 4 time corrected a small correction of 0.2 seconds.

    The other lockups could easily of aligned with time correction but as 15m was closed I couldnt use the last decode to confirm this. After rebooting everything forcing Dimension 4 to do further time corrections and setting to correct every 5 mins (Originally every 30 mins) did not reproduce the problem.

    Tomorrow I will try and reproduce the exact same conditions.

    Regards Andy M5ZAP


  • edited March 2017
    I've noticed strange Flexradio behavior (but not loss of communications) when my Windows 10 screen saver kicks in.  Just out of curiosity, did anything like a screen saver (or sleep mode, of course) occur between your step 3 and step 4?
  • Andy M5ZAPAndy M5ZAP Member
    edited March 2017

    There is no screensaver.

    The loss of communication occurs because the Flex has locked-up/crashed.

    Sorry forgot to add all the software is latest version.

    Smart SDR Version Client software v1.10.16.174


  • Don, VE2HJDon, VE2HJ Member ✭✭
    edited March 2017

    Hi Andy,

    Tel me, do you have the GPSDO board installed ?


    Donald, VE2HJ

  • Andy M5ZAPAndy M5ZAP Member
    edited March 2017
    Hi Donald No I don't. Andy M5ZAP
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited March 2017
    Donald, VE2HJ: Thanks very much for the detailed report.  This is helpful.
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited June 2017
    How many of those that are having these kind of lock-ups are running the Dimension 4 (PC Time Sync) application?
  • Paul MPaul M Member
    edited March 2017
    I do.
  • Andy M5ZAPAndy M5ZAP Member
    edited February 11

    I do, as per my post.

    My be interesting to ask if anybody has lock ups that doesn't run dimension 4. As Dimension 4 is often run if running data mode programs.

  • k0eook0eoo Member ✭✭
    edited February 11
    How do I check if that program is running?  I checked the task manager and didn't see that program.
  • Cal  N3CALCal N3CAL Member ✭✭
    edited March 2017
    Yes,  I have Dimension 4 running on my Windows 10 computer that also runs SSDR,  DDUTIL, WSJT-X, JTALERT, HRD Logbook and HRD Rotor..

    Cal/N3CAL
  • Andy M5ZAPAndy M5ZAP Member
    edited March 2017

    You will see an icon in the system tray, hover your mouse over it and it will tell you the last time sync status. Alternatively look in the Task manager for apps running it is listed as "Dimension 4"

    It will only be running if you installed the program, it is a utility to sync the PC time to a web based time server.

  • Steve Gw0geiSteve Gw0gei Member
    edited March 2017

    I am also using dimension 4 for time checking and syncing. However, although I had the beep lockup for the first time on the first beta version, I had no lockups using the alpha version I was given access to after submitting a help ticket. Since the latest public release came out a few weeks ago I have had no lock ups with that either and have left my 6300running on rx with wsjt-x latest version for 24hrs plus and also had it running all weekend in 80-10m cw contest last weekend with no lockup issues. Although I am not a regular user of wsjt 10 or wsjt-x the one lock up with the beep I did have was running rx only with wsjt-x monitoring on 6m for msk144 mode signals whilst I was out at work. Dimension 4 time checking is always running on both my w7 laptop and the new w10 pc I have just installed. I never use vox - ptt is either footswitch connected to the 6300 in the shack, with everything connected to lan via cat 5 to an old 16 port lan switch in the shack;  or I use mox if running remote from laptop elsewhere in the house on wfifi. I don't have dstar or digivoice waveforms installed.  Not sure if that info helps at all but mainly thought I ought to confirm that dimension 4 is also (always) in use here but I have not had any more lockups with this latest public version.

    73 Steve gw0gei / gw9j

  • k0eook0eoo Member ✭✭
    edited March 2017
    I check and NO Dim 4....
  • Dave-N9CHMDave-N9CHM Member ✭✭
    edited March 2017
    Had my 1st lock up (with audio tone) since updating to v1.10.16.174 on the day it was released.

    Radio: FLEX 6500 Limited (Aug 2013, Inv AB-7300)

    Connection: Radio directly connected to Computer

    Computer: HP EliteDesk 705 AMD A8 PRO-7600B, 8GB RAM, dedicated to only running the FLEX

    OS: Win 7 64-bit, Service Pack 1

    CPU Usage 25%  Physical Memory 36%

    I run no digital modes (only SSB), so I have no applications for such installed, and no Dimension 4 either.

    No other applications were running on the HP, only FLEX. 

    Locked up while rag chewing 7.128 (VOX), power off/on (with front panel button) to re-set. The radio is on ~4-5 hrs per day since updated software was installed.

     

    73, Dave

  • KS0CWKS0CW Member ✭✭
    edited March 2017
    I just had my first lockup, it happened 1 hour after powering up the DC power supply & 6300 (sw 1.10.16.91) along with the windows 10 client. The only applications running were Dimension 4 and SmartSDR 1.10.16 with no radio manipulation/operating or band activity as it was still on the dummy load as i was out  tending to chores. Needless to say i was was welcomed back by a SmartSDR dialog box indicating it lost communications to the radio with the radios power button being  unresponsive. I removed DC power and powered backup and clicking along just fine as if nothing happened.
    Kevin/KS0CW
  • KS0CWKS0CW Member ✭✭
    edited June 2017
    I just had my first lockup, it happened 1 hour after powering up the DC power supply & 6300 (sw 1.10.16.91) along with the windows 10 client. The only applications running were Dimension 4 and SmartSDR 1.10.16 with no radio manipulation/operating or band activity as it was still on the dummy load as i was out  tending to chores. Needless to say i was was welcomed back by a SmartSDR dialog box indicating it lost communications to the radio with the radios power button being  unresponsive. I removed DC power and powered backup and clicking along just fine as if nothing happened.
    Kevin/KS0CW
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited February 11
    To each of you that have had this issue (hard lockup of the radio while running SmartSDR v1.10.16 requiring a long press on the button or a power cycle to correct):
    Could you tell us what your network looks like?  Primarily, we are interested in the path from the DHCP server to your radio.  Most often, a home network will look like a router with everything connected directly to that router.
    What brand/model is your router (if this is your DHCP server)?  
    Do you know what the DHCP lease time is set to?  If you can't look this up in the router, you can open an admin command console and do: ipconfig /release followed by ipconfig /renew.  Then do an ipconfig /all and look at the lease times (origin and expiration).  The delta is the lease length.
  • Chuck - KJ6HTChuck - KJ6HT Member ✭✭
    edited March 2017
    Apple AirPort-Time Capsule V7.6.8
    Connection is hardwired direct from 6500 to Router / DHCP server
    Lease time is 24 hours

    Note: This issue has only occurred once since I upgraded on 2/15

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.