Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex Lockup on 1.10.16



  • Rudy HB9MHBRudy HB9MHB Member
    edited April 2017


    I have my Flex 6700 since about six weeks from a colleague with V 1.10.16 and at least two times a week I lose the connection, normally during the night when I am not active. Flex and Computer (i7/6700, Win10) with fixed IP. Reset with long button press and remove power. Sometimes when I try to connect with my iPhone (Smart SDR App. V. A1.2.8:0.50, Database D1.14 - 27.2.2017) I can hear a click from a relais and then the Flex is lockup.

    Rudy HB9MHB

  • edited April 2017
    Just finished another hour long 80m ssb domestic contest this evening and no problems this time. Radio and pc have been on since the lock up on Sunday evening, so now running on its third 24hr period now without crash or reboot. I haven't heavily used the radio during the three days but its been on rx during the day and have done an 80m cw contest of 90 mins on Monday evening and 60 mins ssb this evening with some 80m morning ssb nets on two of the mornings. Maybe there is a time in tx trigger rather than time period switch on? Dimension 4 still running all the time and I manually synced the time ten minutes before the contest start this evening. 

    73 Steve gw0gei / gw9j
  • NM1WNM1W Member ✭✭
    edited July 2017
    I've had lockups before .16; since upgrading to .16 I can get at least one lockup a week; I've had 3 in the past 3 days... Once mid qso (cw at 5w);  between dax corrupting when using digital modes and the random lockups I'm not feeling much love....
  • Steve Gw0geiSteve Gw0gei Member
    edited June 2017
    Hopefully a more stable version will be released soon. My 6300 has been on without a crash since last Sunday evening so I am leaving it on to see how long it lasts. A version with the performance improvement Gerald referred to, once it's been alpha tested, will be something to look forward to.
  • KS0CWKS0CW Member ✭✭
    edited June 2017
    I had 1 lockup weeks ago then three yesterday inside of  a 60 minute window... 1  was in the middle of a jt65 qso with radio being idle for the other two... Only one of the three produced the continuous tone the others did not...
  • KS0CWKS0CW Member ✭✭
    edited April 2017
    I left mine on for weeks without crash... went back to shutting down nightly & pwring dwn 12vdc source without change... then i get 3 crashes out of the blue within a 60 minute windows after powering backup... It appears it stabilized after i loaded my saved config after the third crash. I noticed i was getting some scrambled representation of what appeared to be one of my configs with setting that didnt fit the intended config it resembled.
  • NM1WNM1W Member ✭✭
    edited July 2017
    I just got another lockup after the rig was on for an hour; was just listening to 40m cw...  4 in 4 days now. 
  • Tony C kc2disTony C kc2dis Member
    edited May 2017
    Still on the beta version here. Afraid to upgrade because of all the problems 
  • dlwarnbergdlwarnberg Member
    edited May 2019
    For the first time I too experienced a lockup this morning, I simply started the radio like I always do, tuned to a local repeater utilizing a 2m transverter and was simply listening, no transmission nothing just listening.. suddenly the SmartSDR software stopped responding, the radio emitted a continuous tone and I could do nothing... only recovery was to hold power button on front of radio until power off.

    I have since recovered everything and am listening once again.. will update if this happens again... radio and computer were freshly started this morning and the lockup occurred after approximately 2 hours after startup.

    Running version:
    Windows 10 pro
    HW version:  v1.10.16.91
    SW version:  v1.10.16.174


  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited April 2017
    Thanks for the report.
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited May 2019
    How many of you that have experienced this problem have one or more XVTRs configured?
  • Jim RungeJim Runge Member ✭✭
    edited April 2017
    Same issue here yesterday.  Using LSB and only thing running besides flex is the WoodBox Radio S-Meter and my SPE AMP.
  • NM1WNM1W Member ✭✭
    edited April 2017
    no transverter here.
  • dlwarnbergdlwarnberg Member
    edited April 2017
    Eric, I have 2 transverters configured, 70cm and 2 meter, both Elecraft..
  • Rob FisselRob Fissel Member
    edited April 2017
    Not sure if this is relative to your question, Eric, but I experience this issue using both ANT1 as well as XVTR for antenna input (magloop RX antenna for HF). 
  • Dave - WB5NHLDave - WB5NHL Member ✭✭
    edited April 2017
    no xvtr here
  • Wayne VK4ACNWayne VK4ACN Member ✭✭
    edited April 2017
    No xvtr here
    I do use dim 4
    I dont use vox
    I was using maestro wired to lan at time Happens when on rx not tx, so far
  • Walt - KZ1FWalt - KZ1F Member
    edited April 2017
    If this just started happening with the GA of 1.10.16 and did not happen prior to the beta of 1.10, what were the diffs? I caught someone was on a Maestro so that might well eliminate SSDRfW.

    How much volatility occurred in the radio SSDR over the last several releases?

    Just in case, you know, it is a place not looked at yet. Its been my experience problems usually show up in the very last place ya look.

     The 2.x work is on a separate branch, right?
  • edited April 2017
    I have a 4m Kuhne TR70H tvtr in line here for 4m, and one of my crashes was on rx only on 4m wsjt version 10. However, the latest crashes have been on antenna 1 to 80m dipole. When not in use the 4m tvtr is always switched off and power removed from it.

    My 6300 has been on for over a week and a half now constant with no crash. I will probably power the pc and 6300 down tonight or tomorrow and then see how it fares after that.  There is a domestic 80m ssb contest here tomorrow night and a 6m contest on Thursday night which I may play in.

    Need to sort this reliability issue out before I commit to my planned upgrade to a 6700 for next winter contest season. Sorting out some rx antennas in the meantime as the weather has improved :-)
    73 Steve gw0gei / gw9j  
  • KA9CFDKA9CFD Member ✭✭
    edited June 2018
    I have had occasional lock ups and drop outs with my Flex 6500 and SmartSDR v1.10.16.174. I am beginning to think the problem is in my router. I have my computer and the Flex hooked up to 2 ethernet ports on the back of my Netgear R6300v2 router. I would like to know what others are using for a router, and if there is some settings in the router that should be looked at. de ka9cfd
  • edited January 2018
    I've had ocassional random lockups since V1.1, so it's nothing new.  The ones with the long tone have happened with the last three or four releases.  The others are random connection drops, and more frequently a total lockup of the computer running SSDR and this laptop, so I'm sure the latter are router related.  It used to be just the main computer that got them, but now somehow, those have been more frequent on the non-radio laptop and only once in a while on the main box.  Saturday morning I came down to the shack and the big box had tried to do the massive new W10 upgrade, which failed, and the radio had shut off.  I tried to turn it back on and it appeared that my power supply had failed simultaneously, but further checking showed that something in the 6500 main power buss had failed, causing any power supply to crowbar off.  Probably coincidence, but the 6500 is now on the way back to Austin for repair.  So if you hear W0FG, it'sjust  my little4-watt  HK1A QRP rig until the 6500 comes home.
  • Steve K9ZWSteve K9ZW Member ✭✭✭
    edited January 2018

    Main Station has been on for over three months solid.

    There seems to be some merit in getting everything not needed to run your Flex-6000 Station off of your PC.

    Win-10, i7 DXer built by Neal just completed yesterday 100 days running without a blip or hiccup, including switching back and forth from SmartSDR for Windows, SmartSDR for iOS and Maestro.

    I did not have this sort of stability with the Win7 machine the purpose built PC replaced.

    Pleased that the video driver issues that disappeared when I swapped from the original card Neal was using have not been an issue (they caused SmartSDR to puke irregularly but frequently.)


    Steve K9ZW

  • edited April 2017
    The lockups here started with the 1.10.15 beta. With lockups I mean only a long power button press brings the 6700 back to life. On the beta I had it almost once/day. Now with the 1.10.16 version it is less frequent, but I cannot really tell you how often because I do not run my 6700 24/7. The problem is identical on two different computers, one brand new, one about 4 years old. Both are running Windows 10. Software updates on Windows 10 do not seem to make a difference. Important: I DID NOT HAVE LOCKUPS with the pre-beta 1.9.xx version. My router is a Netgear R 7500 (my have a different name in the U.S.). I am eagerly awaiting a solution for this, because it really spoils all my remote activities. Thanks a lot and 73, Frederic, HB9CQK
  • edited April 2017
    I know that part of my problem is with the Nvidia GT610 video card that is one of two in my main box.  I really should replace it as it's been troublesome since day one, both in Win7 and now Win10.

  • DaveCDaveC Member ✭✭
    edited April 2017
    Mine is directly connect to my computers network connector. I use a USB wireless for my internet connection.
  • Lionel Lionel Member ✭✭
    edited April 2017
    I experienced my first lockup (6300) a few days ago, just receiving, mode cw.    A S/D of SSDR (not the 6300) and restart and all was back to normal.   I also noticed that on the Radio Setup form only the first two tabs were working.  All of the others did nothing when selected. Another restart was required. 

    At no point did I have to reboot the 6300. I never received a comms lost message. 

    SSDR 1.10.16
    OS Windows 10x64 Creators update, clean install two days before this the only lockup.
    Dimension 4 running in background - also new to the system in the past week. 

    I have seen some other weird, non SSDR, errors in Event Viewer and suspect W10x64 is the likely cause for these. 

    I'll get better data if it locks up again. 
  • James SkalaJames Skala Member
    edited April 2017
    Flex 6300 I also get lockups on 1.10.16.  I have a ticket open with Flex Support.  They are having me run without any peripheral software or USB cables.  We will see what happens

    P.S. glad I am not alone.

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2017
    Thanks to everyone who have been providing data related to this issue.  We appreciate the feedback

    I need to clarify something definitively that will help us a lot in analyzing these types of issues.  Please read the following carefully.

    When the radio and client (SmartSDR and Maestro) are properly communicating, they exchange a "keepalive" packet to ensure the connection is established.  If either the client or the radio does not hear from the other within a prescribed period of time (15s), then the client and the radio will gracefully close the connection.

    For example, if there is a network issue that occurs, but the PC and radio are operating normally, both the radio and the client will properly close the IP connection between them after the prescribed period of time.  In this case, the client pops up a message that there has been a disconnect.  The client does not know the nature of the disconnect, only that it can no longer communicate with the radio.  If the network communication issue resolves itself, then you can simply restart SmartSDR and the radio should appear in the chooser and you can reconnect. This is NOT a lockup or a crash, but a simple communications failure since there was no other mitigating action needed other than restarting SmartSDR.  We do not need these reports.

    Now, if the radio experiences an event where the firmware or other internal software process experiences a serious issue where the radio stops communicating, then as before, the client will display a message that there has been a disconnect.  And as before, the client does not know why.  If you restart SmartSDR and the radio does not show up in the chooser after several seconds, then there are two possibilities; you have a continuing network issue or the radio has experienced a firmware failure of some sort.  If your PC can communicate with other devices on the same network as the radio, then you can for all intents and purposes rule out a network issue.  To rule out anything realted to the PC, you should shut it down and reboot.  If after the the reboot, you can connect to the radio, then the issue has something to do with your PC environment.  If neither of thees actions result in reconnecting with the radio, then, do a normal power off on the radio by pressing and releasing the power button.  Give it a good 15-30 seconds to respond. If it does not power down normally, then press and hold the power button on the radio until it powers down.  This indicates that the SmartSDR firmware did not receive the control signal to shut down and we had to instruct the radio to shut down Linux using the long power button press and hold.  This behavior IS a radio lock up or crash and we do want these reports.  We would like to know what you were doing at the time of the crash, how long the radio had been powered up and any other information of anomalies you observed just prior to the radio disconnecting from the client.

    If the SmartSDR client crashes, in just about all cases there will be an unhandled exception error displayed on the screen.  We always want these errors and we need the error detail to properly debug why the SmartSDR application has crashed.  A screen capture of the error details is sufficient along with a description of what you were doing just prior to the crash.  I'd prefer you open a HelpDesk ticket to provide us this information on the outside chance that I or another FlexRadio employee happens to miss your report.
  • KA9CFDKA9CFD Member ✭✭
    edited April 2017
    I have changed my set up and now have the radio connected directly to the ethernet port on the back of the computer. Then using wifi from the computer to connect to the router. I will have to watch and see if there are any more disconnects. I am thinking about getting a faster wifi router to replace the Netgear R6300v2.
  • Bill W2PKYBill W2PKY Member ✭✭
    edited April 2017
    Perhaps using a 5 port switch to connect the radio, computer and router together might be more stable, rather than using the router as the switch??

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.