Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

3.5.9 didn't work for me

I upgraded as normal complete with cold boots and I still can't see the radio remotely on either SmartSDR for Windows, Maestro or SmartSDR for iOS.

I'm still able to run the new version via Teamviewer as before, just not via Smartlink.

Any suggestions?

«1

Comments

  • Gord-VA7GP
    Gord-VA7GP Member ✭✭
    edited September 13

    I'm in the same boat:

    I downloaded 3.5.9 at home, local to my '6400. It worked fine, found the '6400, and updated it. I've since re-started my '6400 a gazillion times but:

    From my remote-site, I've downloaded 3.5.9 and it won't even connect/auth to SmartLink and therefore it doesn't even display my name and callsign. On this remote computer, I logged-out of SmartLink, then provided my credentials again to log in... but by all appearances I cannot log in. This problematic remote PC has been rebooted also a gazillion times. At least with 3.5.8 I would see my name/callsign, but now with 3.5.9 I don't even get that...

    Shared misery....

    EDIT 1: for completelness and clarity: just like Peter's Teamviewer, I can use Remote Desktop to connect to the PC co-located with my '6400 and they both work great together, version 3.5.9 But this does not involve my Remote PC, nor does it involve SmartLink.

    EDIT 2: after a very long wait, my remote SmartSDR did finally connect to SmartLink, with my user/pass! I can see my Name/Callsign, but only for SmartSDR... both CAT and DAX remain un-connected (no Name/Callsign). Something is trying to work...

  • Peter WB6POT
    Peter WB6POT Member ✭✭

    Yes, I did the same things with logging out and logging back in and see the same results.

    It would be helpful if others chimed in with their success or non-success stories regarding 3.5.9. I did see several hams on Facebook say they also couldn't get it to work.

    I put a Helpdesk ticket in about 15 minutes ago, so hopefully will hear something tomorrow.

  • No joy...my 6400 will not register for Smart Link... switches between 'not connected to internet' or registration failed.

    What a mess for a remote dependent user.

  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Hi Gord, I would submit a help desk ticket.

  • RFord
    RFord Member ✭✭✭

    I’m dealing with the same issue…

  • Dan Trainor
    Dan Trainor Member ✭✭✭

    You mean we have to Re-Register for SmartLink all over again??? They lost the credentials? That was their responsibility.

  • Peter WB6POT
    Peter WB6POT Member ✭✭

    Dan,

    That should not be required. He was talking about logging out and then logging back in.

  • Pete La
    Pete La Member ✭✭

    Flex Radio Systems is out of control! Nothing but one issue after another. A very unstable system! Good concept, great eye-candy, but very poorly controled software/firmware or wherever the continuous problems lie in the FRS system. I can't help but think that using a Windows based piece of hardware was a huge mistake. Go to the Flex User's Group on FaceBook and you will find even more unhappy Flex Owners with the same complaints. Some are offering a swap for an Icom 7610.

    Pete K1OYQ

  • I guess it’s not for everyone, but I enjoy using a Mac, an iPad (great for FT8) and an iPhone in connection with my 6600M.

  • bd6rn
    bd6rn Member ✭✭

    v3.5.9 smartlink still not connect....

  • KH6XX
    KH6XX Member ✭✭

    Same here... using a 6600M with v3.5.9 indicating "No internet connection..." Began receiving the "No internet connection..." when using v3.5.8. Still can not configure SmartLink after the upgrade.

  • W4AFK Bruno
    W4AFK Bruno Member ✭✭
    edited September 14

    My experience with two remote Flex 6400 radios

    My setup: I have two remote 6400 radios. One in Florida and the other in California.

    • The Florida radio was updated to 2.10.1 via my VPN connection
    • The California radio was updated to 3.5.9 via my VPN connection
    • Here is what I saw when I tried to use SmartLink:
    • On both systems, the screen said "There are currently no radios available"
    • After ~10 minutes without doing anything, my callsign and name appeared in the SmartSDR window. This happened for both radios
    • About a minute or two later, the programs started (one Win 11 computer connected to Florida and another Win 11 computer connected to California

    Note that both radios were accessible via the VPN connection I have to both sites

    Could this delay be caused by a LARGE number of users trying to connect using SmartLink at the same time (i.e. overload)? Just wondering as both radios are working fine.

  • AA0KM
    AA0KM Member ✭✭
    edited September 14

    Windows 11 works-MacOS-Ventura works-IpadOS works. Update all computers.

    Make sure to install 3.5.9 and after reboots and ready then shut radio off and power down to make firmware stick.

    I did not have to change any users or passwords.

    New software requires Mic Key click or key key-down for Registration or it did for me.

    TestPorts all-Green

    Thanks Flexradio for 9 years of great service I new you guys could pull it off!.

    73 de AA0KM 4:04 UTC Wednesday Sept 13th CDT.

  • Lionel
    Lionel Member ✭✭✭

    The .9 rev installed fine on local W11. Even though it solves a bad problem, I don’t operate remote and I wish Flex would apply their technical staff to address some other long standing issues. Do this with the same intensity used to resolve the remote trouble.

  • Mike Steventon
    Mike Steventon Member ✭✭✭

    3.5.9 install to 6600M first thing this morning.

    Perfect!!

    Thanks FlexRadio!

    Mike G4GWH

  • RFord
    RFord Member ✭✭✭

    Everything is working fine this morning….

  • Peter WB6POT
    Peter WB6POT Member ✭✭
    edited September 14

    RFord,

    Yes, I found the same thing happening here. I left SmartSDR on my computer screen last night (which showed no radio available message - for over an hour) and to my surprise this morning my radio was up and running on SmartSDR just like it's supposed to. Also checked SmartSDR on my iPhone and Maestro - all is working this morning without doing anything new from last night.

    I guess some ghost must have fixed Smartlink over the night.

  • ntilley905
    ntilley905 Member ✭✭
    edited September 14
    No joy here. Updated to 3.5.9 locally, my remote devices cannot even connect to the SmartLink servers and the radio says the servers are not reachable to register.
  • K9SO
    K9SO Member ✭✭

    Keep trying and you'll probably have success after multiple attempts. But you may have to wait several minutes after you try to log in before there is success.

    Tim says they're aware of the problem so I guess we need to be patient.

    Fred

    K9SO

  • RFord
    RFord Member ✭✭✭

    I was able to log in via my IPhone this morning...but now no luck. I know they are working hard to address this issue...

  • Rich McCabe
    Rich McCabe Member ✭✭✭

    Same issue here. It wont even stay logged in for more than 5 minutes. If you click the Avatar the Callsign, FirstName and Last name fields are flashing.

    Also note in their release it did say...


    "With the SmartLink service functional, our attention has turned to the sluggish response of the SmartLink server. This has caused a fair bit of confusion for folks that updated their software and still experienced timeout errors. Through some investigation, it has become clear that radios running earlier versions of SmartSDR attempting to connect to the SmartLink server are driving most of the server load. "

    Rich

    kd0zv

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    It is going to take some time to reduce the load on the SmartLink Servers. It will eventually clear.


    Thanks for your patience.


    73

  • Gord-VA7GP
    Gord-VA7GP Member ✭✭

    Hey there and Good Friday morning @Mike-VA3MW :

    What about...

    1) what about having multiple, redundant SmartLink servers, with fail-over to the next? Like smartlink.us or smartlink.jp or smartlink.de or smartlink.ca etc?

    2) what about providing (releasing) the SmartLink server-code, so individuals could run their own SmartLink servers? Maybe a virtual-machine / self-hosted, may a cloud-instance, etc?

    Thanks!

  • Mick  W8BE
    Mick W8BE Member ✭✭

    I tried this morning at 10AM and waited for 5 minutes. I re logged back into SmartLink and the account settings variables never showed up. I just now tried again at 11:50AM. Same result. You may want to rethink your remote access paradigm. This coupled with the DAX device driver issue on Win 11 does not leave me with confidence,

  • n1ah
    n1ah Member ✭✭

    This is quite horrible. If I use my routers openvpn profile, I wonder how hard it would be to connect remotely with the smartsdr software on my remote laptop as i do it now...

  • k3avr
    k3avr Member
    Horrible for sure. Installed 3.5.9 on remote radios ,no glitches. Here in Bogota the noise is S9+ most of the time so no local operation. Opening SmartSDR shows eventually shows first two letters of my email address but even after an hour will not show name and callsign. Relogging in is useless. The two remote Flex radios say no internet so guess not reaching Smartlink server even that fiber optic access is very fast at all locations. If server overload is a problem it is time for a server upgrade. HK3AVR
  • Ken AG2K
    Ken AG2K Member ✭✭

    It seems the consensus is just leave Smartlink and the server will catch up. Is there any word on how long that might be. I would imagine Flex could tell how far it is backed up and on average how long it is taking per account to authenticate.

    KM

  • n1ah
    n1ah Member ✭✭

    Would be nice for sure - as my primary operating activity is remote, this smashes my fun time.

  • Ken AG2K
    Ken AG2K Member ✭✭

    OK my smartlink just came back. Took about 6 hours or so.

    KM

  • n1ah
    n1ah Member ✭✭

    same here. better late than never! I missed my net by 6 hours tho :)

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.