Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Network performance with aging routers:

Ken Wells
Ken Wells Community Manager admin

I have been running my ASUS RT-AC66U Router for the past 6 years or so. The past 4 years with a Comcast XFinity Cable internet connection that was giving me a maximum Download Speed of about 120 MBps and MAX Upload of about 10-12 MBps.

Lately, for the past few months, I have been having increasing problems with my radio, and other equipment on the network randomly disconnecting, bogging down, and having intermittent communications issues.

Last night I tested my network speed and only measured about 50-60 MBps.

This morning I replaced the aging ASUS with a new IQ Router IQRV3. It was reasonably priced ($119 plus tax at my favorite online retailer)

It only took about ten minutes to get it installed (Including winding three turns of the power cable through a MIIX-31 Ferrite Snap-on)


My Internet speed, tested with XFinity's SpeedTest jumped from my previous high of about 120 Mbps to 261.4 Mbps!

OOKLA says it is about 264.7

UPLOAD Speed on both is between 8-12, which is not great, but plenty good enough for SmartLink work!

My Buffer Bloat, measured from this website: https://www.waveform.com/tools/bufferbloat

after only about an hour with the IQ Router's automated Traffic Management system, I am getting this:

Heavily used equipment that is exposed to random static discharge via cable, phone or other outside lines DOES experience component and software deterioration, and performance can suffer. I had tried resetting the router, reloading firmware, and other things, which did not help.

If your network is getting "flakey" it may be your network equipment!

I had been contemplating updating my router for a couple of years, off and on.

All I can say now, it: "Why did I wait so long?"


  • KG5PTE
    KG5PTE Member ✭✭
    Hello I am using the ASUS RT-AX82U router and love it.
  • AB8WD
    AB8WD Member ✭✭

    I do not understand I am told by FRS that the radio does not need all that much bandwidth but with 1 gig hub with only the flex equipment on it when changing bands I still get a delay on the radio screen updating especially when switching bands like ft8 sometimes up to 1 minute before it responds at this time I dropped 5 packets out of 9 million.

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    The other thing that people overlook is PC CPU and number of cores. I helped one customer recently that was having similar delays with FT8, CW chopped characters, and such. He was trying to decode four bands of FT8 at once and decodes were still populating when next cycle started populating. He was seeing on average of 12 decodes on a crowded FT8 band. This was on an i5 4550 CPU. That is a 4th gen CPU with four cores. He had 16 GB RAM. He was trying to decode four streams of data at the same time on 4 core CPU.

    He upgraded to an i7 12700 with 32 GB RAM. He called me back to thank me. He said it is a night and day difference.

    While SmartSDR does not need a lot of bandwidth to run or CPU or memory to run, it is sometimes the other ancillary software running on the same PC.

    Dave wo2x

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Also, this morning I replaced my ISP’s fiber gateway/router/WiFi extenders with the Eero Pro 6E mesh system. I had them place the gateway into bridge mode and disable the internal WiFi. Configured the Eero mesh.

    Ran the test Ken referred to while my wife is streaming a 4K movie off HBO MAX. Here are the results. I haven’t tried tweaking anything yet. This was ran from my iPad Pro.

    Reason for upgrade to Eero was ISP gateway did not support DHCP reservations.

    73 Dave wo2x

  • Sergey KN7K
    Sergey KN7K Member ✭✭✭

    I have 8+ years old Netgear router, Comcast 200/5mbps. Works as new.

    Hope your messages not going across that everyone need to upgrade they routers/switches.


  • Ken Wells
    Ken Wells Community Manager admin

    No.... But if they are having increasing instances of random issues, disconnects, and other network performance issues, it may be their network equipment, as it was for me......

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Ken is correct. It depends on several things, any one might not cause an issue but cumulatively can add to a bad user experience.

    Network issues including congestion and buffer bloat is one of the things to check if you are experiencing disconnects.

    Lack of PC resources (CPU cores, RAM, background programs running) would be a good place to start if experiencing radio sluggishness such as chopped/slurred CW, poor WSJT-X decoding, etc.

    Just adding our experiences which may help others troubleshoot if they have issues.

    There are plenty of Flex users who have older and moderate computer and network hardware which do not have problems.


    Dave wo2x

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    And a note about the test site Ken posted. It is in California. I am in NJ. I have **** routing between myself and the test site. So my results are not as good as people in the Midwest or west coast

  • Ignacy
    Ignacy Member ✭✭

    I had a 4-year-old ASUS router. It was reliable but connections across rooms were poor.

    I replaced it with Google Mesh with 3 units. Initial setup by phone app very fast. Range phenomenal - distances up to 600 ft easy. But DHCP and forwarding setups are a nightmare. It is all by phone. You do a static DHCP and nothing changes despite reboots. But 2 hours later it is working. And then port forwarding that sometimes works sometimes not. I went on a 1-month overseas trip hoping to be able to use my station remotely, and the internet power switch would not work despite mesh reboots. It started working magically when I came back.

    Perhaps the trouble is with Google, which wants to do everything by phone app where screen space is limited.

    Ignacy NO9E

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    I just installed the Eero Pro 6e 3 unit system. Covers both levels of house plus deck. I get full speed up and down on wired ports of remote units (300/300 service) and around 280/280 on WiFi.

    They use the 6 GHz channel as backhaul between units.

    reason was my ISP’s fiber gateway does not support DHCP reservations.

    Dave wo2x

  • Lasse SM5GLC
    Lasse SM5GLC Member ✭✭✭

    I have been running Bufferbloat tests for a few years now, and usually I am at A grade when running the test with the computer attached with tp cable, and often B grade or worse when using WiFi. My connection is FTTH (fiber to home) and 100/100 Mb. The router is a Mikrotik RB4011 and I have a fiber from the router down to the incoming "router" that is supplied by the provider. I had to use a TP-cable to fiber converter at the incoming end, as there is only TP option for the user, but my Mikrotik offers a SFP port. This gives me less copper cable (20 meter), and galvanic isolation, and hopefully less RFI :)

    I just set up the router to use a simple queue to see if it would improve the latency. As I usually see 80-100 Mb when testing, I did set the limit to 70 Mb. Tested this using my Dell laptop using WiFi and a congested 2,4 GHz. Surprised to se a substasial improvement, and for the first time I do get A+ grade when testing! The morale is one does not need the "coolest/newest" h/w but need to be able to understand how to configure it :) But honestly I'm not sure I will notice any difference between grad A and A+.

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Now that the Eero 6E Pro has been running a few days the QoS has been adapting to my network. This is taken in the PC that is currently running SmartSDR connected to my radio. 300/300 ftth.

    Dave wo2x

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin


    I use Google Mesh at home. Just make sure you run the Mesh in bridge mode and you don't have to worry about DHCP or port forward issues.

    If you don't do that, then you have to operate in a double NAT'd mode and that is painful.


  • Ignacy
    Ignacy Member ✭✭


    I am using the default. The main unit is in NAT mode, and the **** units are in the bridge mode. Is this OK?

    After coming back on a trip and turning all entries on the power switch manually, the power switch works well. I set it up so that after a power failure it restores its previous state rather than set all devices off.

    Ignacy NO9E

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Default mode is not in Bridge mode. Is the master device also connected to a Router? If so, then you are double NAT'd.

  • KM4CQG
    KM4CQG Member ✭✭

    I take a dabble at this my Router was state of the art 2 years ago.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.