Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Mac side not working

I have the whole shebang so to speak. SSDR for Windows and Mac, DogPark for Mac, and a Maestro.

My SSDR for Mac is not working. I get a : "The connection can not be established (Timeout)".

DogPark will start, but if I try to do anything, it will hang.

Mac is hardwired to the network.

SSDR on the Windows side works perfectly it's on WiFi

Maestro works perfectly - also on Wifi.

Pinging the Radio from my Mac gives around 200 to 400 ms

Pinging the radio from my windows gives an average of 1 ms

Well there's your problem!

The Mac in wireless mode gives me around 5 ms.

Wireshark shows plenty of udp packets coming in as "data" meaning it doesn't know what to do with them, the radio looks the same as some bad guys, even though it isn't. I wish that we could get the radio to ID itself better.

I've reset the radio, rebooted the router, and before I reset the router I was wondering if anyone else had a similar issue.

Comments

  • Michael N3LI
    Michael N3LI Member ✭✭

    Update - by running wireless, Dogpark works okay, but Not SSDR. Something still seems askew between the radio and the Mac though.

  • Michael N3LI
    Michael N3LI Member ✭✭

    Turns out that the problem was invoked by clicking Auto connect on the connect to radio window. Autoconnect in this case means the software looks for the IP address last used, and if it doesn't find it, gives up. And my local network assigns the IP, and it can change. So I turned autoconnect off, and the software went out to look for an appropriate radio, found it and works fine now. All the other stuff was just red herrings - although I did replace an ethernet cable and sped my Mac ping and internet access up FB

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    The AutoConnect connects to the last radio you used. It will do this even if the IP address changes as the AutoConnect looks for the radio by serial number. Why your did that is very strange. Do you know what the 2 IP address were just so we can understand why it didn't work as designed?

    You should be able to find a setting in your router to not change the IP addresses on DHCP renewal.

    You can read more about it in Section 5 of the SmartSDR User Guide.