Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Windows 10 update disabled Virtual Serial Port

Takeshi Yamada
Takeshi Yamada Member ✭✭
edited June 2020 in SmartSDR CAT
I happened updated Windows 10 to ver. 1607 and knew that FlexRadio Virtual Serial Port does not work.   It returns "Code:19.  Registry information is incomplete or broken and can't start device" (description may be different as mine shows message in Japanese). 
Are there any way to fix this other than back to the previous Win10 version?  I need this version to have run Xlaunch (X window system) to connect to Unix system.


  • Cal  N3CAL
    Cal N3CAL Member ✭✭
    edited March 2020
    Hi Takeshi,   under "Programs and Features" find "Flex Radio Systems FlexVSP", highlight, right click and select "Repair".  Then reboot and hopefully your issue will be resolved.  This happened to me today as well and the repair worked for me. 

  • James Kennedy-WU5E
    James Kennedy-WU5E Member ✭✭
    edited June 2020

    I had to revert back to the previous update to get the same problem solved.

    Jim/ WU5E

  • spopiela
    spopiela Member ✭✭
    edited December 2016
    Hi Cal, your solution worked for me after the 10th Anniversary update. No other issues with smart sdr after update except the FlexVSP repair. Stan
  • Takeshi Yamada
    Takeshi Yamada Member ✭✭
    edited August 2016
    Thank you Cal for your information.  Unfortunately, I reverted to 1511 just before reading your information.   I retried to update to 1607 again, but it does not work - cannot update to 1607 as of now.    Anyway, I will try "repair" when I come across to this kind of problem next time.

    Thank you!
  • WX7Y
    WX7Y Member ✭✭✭
    edited June 2020
    Just do a full uninstall and reboot then reinstall smartSDR and reboot again, this worked on 3 different computers I use here that WIN10 update broke. 
    I didn't reset the radio so I didn't loose any of my configuration. took about 5 minutes to do it and no other problems. 

  • Michael Coslo
    Michael Coslo Member ✭✭
    edited August 2016
    Thank goodness Microsoft is not in control of our automobiles. 
  • KC2QMA_John
    KC2QMA_John Member ✭✭
    edited December 2016
    Yes Full Uninstall/Re-Install of SmartSDR has seemed to work each time when these problems pop up.

    I first do a full Export of all of my profiles in SmartSDR then Uninstall SmartSDR and FlexVSP from the windows control panel then I just Re-Install SmartSDR and everything works perfect again.

  • Jay Nation
    Jay Nation Member ✭✭
    edited August 2016
    My thinking regarding which way to solve the problem is, Do I want a repaired SmartSDR installation, or wouldn't I prefer a brand new installation. If I wreck my car, I know which solution I'd prefer.  As long as I'm permitted to clean out the glove box and grab my toolbox out of the trunk, before sending the wreck off to the junkyard I'm ok with starting over with a brand new vehicle.

    If you have backed up your profiles and memories, then you have all your possesions.

    That new car smell will fade away soon enough.

    Full Uninstall/Re-Install takes less time than cleaning out the garage.

    I never felt the need to blame Chrysler for the wreckage either.

    Must have been something "I" did. 

    73, Jay - NO5J
  • Jay Nation
    Jay Nation Member ✭✭
    edited August 2016
    By the way, there is an updated version of the "How to do a Complete uninstall of SmartSDR for Windows from your PC" guide, on the ZenDesk.


    Thanks Tim!

    Re-read it and see if you can spot the changes.

    73, Jay - NO5J
  • Cal  N3CAL
    Cal N3CAL Member ✭✭
    edited November 2016
    Jay,   SmartSDR is not the program getting repaired!  FlexRadio Systems FlexVSP is the program being repaired.  Why touch SmartSDR when the issue is another program? 

    This issue was actually discussed just the other day and Flex's recommended resolution was a simple repair to Flex VSP .  I was just trying to pass on that info since it worked for me.   That thread can be viewed here: 


  • Jay Nation
    Jay Nation Member ✭✭
    edited August 2016
    I'm glad you've got it fixed.
    I've repaired FlexVSP in the past. Using the same method.
    I don't advocate, junking the car, when complete repairs are possible.
    I was mostly trying to point out that Tim has updated his guide, to include recommendations for handling the Win 10 Anniversary upgrade situation.
    The first machine I upgraded had DAX and CAT/VSP issues. I tried replacing/repairing the broken parts, but in the end I did the Full Uninstall/Re-Install.
    The second machine I did the Full Uninstall/Re-Install first. SmartSDR installed perfectly after the upgrade was through.
    The third is doing the anniversary upgrade, right now, and it also got the Full Uninstall/Re-Install treatment first. 

    I didn't see Tim's updated guide, until after I did the first Anniversary upgrade.
    I found it, by clicking on the link on the Zendesk, expecting only the old guide.
    I knew that procedure would likely solve all the problems. If I'd seen that guide first, I'd have reported that the Win 10 upgrade, went perfectly.

    I like the fact that I can get a brand new radio by reinstalling any and all of the released versions.

    Nothing wrong with New.
    Nothing wrong with Fixed just like New either.
    We have a choice between a DIY Fix, and a DIY replacement.
    Choice is good!

    73, Jay - NO5J

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.