Unable to Connect to Flex 6400 Using Certain Remote ISP Providers

  • 1
  • Problem
  • Updated 1 year ago
This concerns the inability to access a Flex 6400 with a Maestro or a PC running Smart SDR for Windows at a remote location depending upon the ISP at the remote location.  In all cases the network test feature of Smartlink gives a green "go" indication at the remote location showing that the connection should work.

While working with several Flex 6400 owners we have found that a remote location served by Century Link, Verizon, or ATT all work and can access our 6400s back home with no problem.  Conversely remote locations served by Cox, Hickory Tech, or Charter all fail. 

Without changing anything at the remote location except logging onto a different model of Flex radio such as the 6700 it has been observed that remote access from any of the remote ISPs, even the ones that fail with the 6400, all work normally. 

In summary; even though Smartlink gives a network "go" light in all cases you can only connect back to a 6400 using some remote ISPs while some remote ISPs fail.  These tests have been repeated several times, the "good" remote ISPs always work, the "bad" ones always fail but only when trying to connect back to a 6400.

The software in use is the latest v 2.4.9
Photo of Rex K0KP

Rex K0KP

  • 44 Posts
  • 3 Reply Likes

Posted 1 year ago

  • 1
Photo of Jim Gilliam

Jim Gilliam

  • 960 Posts
  • 233 Reply Likes

You could set up VPN's at the remote sites using OpenVPN or Softether and test to see if you still experience the same connection problems.

Jim, K6QE
Photo of k0eoo


  • 653 Posts
  • 89 Reply Likes
Rex, I saw this thread down further and was wondering if it has anything to do with the issue you and Tony are dealing with, with regard to Spectrum/Charter anyway?


Photo of Ted  VE3TRQ


  • 609 Posts
  • 212 Reply Likes
If SmartLink were to keep separate information about the radios at a site, it would be possible that SmartLink could be supplying a different IP address for each radio. But then I don't know how SmartLink is implemented, so the statement above is full of "if", "could" and "would" :-)

Perhaps in the above scenario re-registering the radios may produce a different result. My shot-in-the-dark.
Photo of Rex K0KP

Rex K0KP

  • 44 Posts
  • 3 Reply Likes
Dennis and Ted - thanks for the input!  ... I think Smartlink should not show "go green - the network is good" when the "Test" button is clicked if the 6400 were off or otherwise not available due to an IP issue. 

Further it was tested repeatedly by more than one other station at different locations using one of the "good" ISPs at the remote and those tests accessed the 6400's just prior or just after a failed attempt using one of the bad ISP's at the remote end.

I'm stumped.  Just a hunch, but could it be that the 6400 generates some sort of anomaly in it's data stream that other models like the 6700 are not?  Something perhaps that some ISP's are more tolerant than others to allow 6400 data across their networks?   .
Photo of Steven Linley

Steven Linley

  • 431 Posts
  • 75 Reply Likes
I have Charter/Spectrum and I used dyndns to keep track of my ip address.
Photo of Rex K0KP

Rex K0KP

  • 44 Posts
  • 3 Reply Likes
I just had a visit with W0PDN - Ed who is a retired systems design engineer that worked for many years at Hickory Tech, one of the  ISP's that can't access the Century Link based 6400 radios.  Here is what he told me; after explaining the scenarios to Ed he recommends looking at what is the difference between how a 6400 processes data vs a 6700 radio.  He wonders in particular if the 6400 could be out-bounding a larger packet size?  Perhaps a difference in the data processing between the two models of radios accounts for why the 6400 data is being dropped by less forgiving or more tightly filtered ISPs when the 6700 data is not. 

That is what the Hickory Tech engineer had to say.  

What to do now?
Photo of Dave, KY0L

Dave, KY0L

  • 10 Posts
  • 3 Reply Likes
Are you able to change the port numbers required for your remote control? Maybe different port numbers will get through different internet providers. Have to tried running your internet connections through a VPN tunnel? Perhaps if your remote connectivity traffic is being run inside a VPN tunnel, the port traffic that’s required for the Flex radio remote control to function might be able to pass through with that port traffic is inside of a VPN tunnel

Dave KY0L
Photo of Dale LeStourgeon

Dale LeStourgeon

  • 8 Posts
  • 3 Reply Likes
I am new to Flex. Got a 6400M  two months ago and my ISP is Cox. This week I installed Smartsdr for IOS on my phone and ipad. I have been able to use the iphone remotely via T-Mobile and Cox with no problems.

Dale K5AJZ