Dual instances of JTalert

  • 1
  • Question
  • Updated 4 months ago
  • Answered

I have two instances of WSJT-X running on my 6700 under V.2 Smart SD but cant get JTalert to work... does anyone have this set up who can share screen shots???

Tnx, bc

Photo of AH0U

AH0U

  • 256 Posts
  • 30 Reply Likes

Posted 7 months ago

  • 1
Photo of John - AF3K

John - AF3K

  • 115 Posts
  • 29 Reply Likes
Not sure it will tell you much but here is a screenshot.

Photo of AH0U

AH0U

  • 255 Posts
  • 29 Reply Likes
What I was looking for was how you set up to get to this point...I have two WSJT and to get the second running, I must first open the second instance then click on the JTalert again...I can not make any changes in the second instance as the manage settings is greyed out so I cant get to the autostart... any idea??
Photo of John - AF3K

John - AF3K

  • 115 Posts
  • 29 Reply Likes
Maybe see if you can just get going manually first. 

I have one startup shortcut icon for each Slice of WSJT-X and only one startup icon for WSJT-X-JTAlert.

The way I get it to work is to get both instances of WSJT-X going first.  Then click on the WSJT-X-JTAlert shortcut and wait for it to startup. It should attach itself automatically to Slice 1. (it takes a few seconds) 

After that is working, I then click the same WSJT-Alert icon a second time and it starts up and automatically attaches itself to the second WSJTX slice.   

Here are screenshots of my WSJT-X startups. (right click on the WSJT-X shortcut icon, select properties). Note the text in the Target box for slice 1 is

C:\WSJT\wsjtx\bin\wsjtx.exe --rig-name=Slice1  (you will have to point to wherever this file is on your machine, but just make sure that --rig-name=Slice1 is appended for slice 1 and that --rig-name=Slice2 is appended for slice 2) 
 
Slice1


Slice 2


And here is a screenshot of the WSJT-X-JTAlertX startup
Photo of KB4AAA

KB4AAA

  • 41 Posts
  • 19 Reply Likes
This should get you going. You can run one for every band with that 6700 :)
https://community.flexradio.com/flexradio/topics/multiple-wsjt-x
Photo of John - AF3K

John - AF3K

  • 115 Posts
  • 29 Reply Likes
Hadn't seen that thread.  I was just double clicking to get JTAlert started on each instance.  Will have to try those auto-start parameters.
Photo of AH0U

AH0U

  • 255 Posts
  • 29 Reply Likes
I have it running now... Tnx!! However the second instance does not allow access to the settings.... when I click on SETTINGS all but EXIT and one other... is this normal??? How do you set the parameters??
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3541 Posts
  • 1396 Reply Likes
Only the first instance is allowed to control settings. RTFM
Photo of AH0U

AH0U

  • 255 Posts
  • 29 Reply Likes
I would if I could find one
Photo of Rich McCabe

Rich McCabe

  • 984 Posts
  • 213 Reply Likes
To elaborate on what Howard said, make sure you shut down ALL instances of JTalert except the first one started before you make any changes to JTalert settings.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3541 Posts
  • 1396 Reply Likes
The trick is to make sure there are different UDP ports enabled in each instance of WSJT so JTALERT will recognize the. Different WSJT

Photo of Bob

Bob

  • 11 Posts
  • 3 Reply Likes
Howard I'm not able to read you"re configuration on my screen. Could you send the
copies to my email address rwb1636@gmail.com.

I can get two instances of wsjt-x running and the first on JTALERT the second give me an error message 

Unable to communicate with the WSJT-X process.
  UDP Port : 2237
  IP Address : 127.0.0.1
  Values read from WSJT-X config file...
    C:\Users\Bob\AppData\Local\WSJT-X\WSJT-X.ini

WSJT-X Detected Instance...
  Process Window Title : WSJT-X - ig name=Flex2   v1.9.0-rc3   by K1JT
  Process Command Line : "C:\WSJT\wsjtxb\bin\wsjtx.exe" "-rig name=Flex2"

Decode alerts and logging will be unavailable until corrected.
Photo of Jon - KF2E

Jon - KF2E

  • 637 Posts
  • 188 Reply Likes
Did you click on the image? Once it is expanded I can read it just fine.
Photo of Bob

Bob

  • 11 Posts
  • 3 Reply Likes
Thanks  Jon just did that, just need to find the config or ini file will work on later this evening.
Photo of Bob

Bob

  • 11 Posts
  • 3 Reply Likes
Jon Found the ini files verified that each instance of WSJT-X is running with a different UDP port such as 2237 & 2239. I can not get the second instance of JT alert to work as it still comes up with an error saying that it looking for 127.0.0.1 and looks for 2237 instead of 2239.  The JTalert Ini does not show much except the path for exe file.
Not sure what to try next.