Can't get USB Interface for the KPA500 to talk

  • 1
  • Question
  • Updated 3 weeks ago

I bought an FTDI USB cable off of Amazon and a null modem adapter to go between the cable and my KPA500. The radio seems to see the cable ok as it displays the cable serial number. CAT is enabled and the speed is 9600 source TX ant and ANT1. Have logging turned on and whenever I change bands it logs for instance 20:38:32 (TX): FA00010108000;.

Changed the settings on my KPA500 to be as shown in the Flex USB Cables Interface for the FLEX-6000 guide. RADIO"is set to SERIAL, SER POLL is set to ON and baud rate is set to RS232 X 9600.

Have Flexlogger running on my PC and it is talking to the rig but the KPA Amp tab does not see the amp either.

However when I change bands on the rig it does not change it on the amp.

I know that I can use DDUTIL to change the bands automatically but I want to use SSDR on two different PC's.

Any idea what I have wrong with my setup? Any suggestions will be greatly appreciated.

Zack

N8FNR
Photo of Zack Schindler - N8FNR

Zack Schindler - N8FNR

  • 104 Posts
  • 18 Reply Likes

Posted 3 weeks ago

  • 1
Photo of Michael Walker

Michael Walker, Employee

  • 600 Posts
  • 155 Reply Likes
You will need a Null modem adapter which crosses pin 2 and 3 on the 9 pin connector.

Make Sure you are also connected to the transceiver port on the amplifier.
Photo of WX7Y

WX7Y

  • 658 Posts
  • 123 Reply Likes
 I AM PROBABLY WRONG but Flex Logger trys to talk to the AMP direct on the computer and not through the radio so unless the USB cable is connect to the computer DDUTIL or FlexLogger wont talk to it to the AMP directly. 
If it's changing bands when your changing bands on the radio it self then it is working as designed.

73's
Bret
WX7Y


Photo of WH6HI - Pat

WH6HI - Pat

  • 317 Posts
  • 52 Reply Likes
Best way is from the radio usb with proper config of the usb in SmartSDR. I also controlled the KAT500 tuner same way. Flex also monitors the usb com between radio and amp and tuner. This setup eliminated the need for use of DDUtil.
(Edited)
Photo of Michael Walker

Michael Walker, Employee

  • 600 Posts
  • 155 Reply Likes
Required Cables:
● FTDI USB to Serial Cable
● Null Modem Cable (Pins 2 and 3 crossed, pin 5 straight through)

Device Setup:

● Connect the FTDI USB to Serial Cable to the Null Modem cable, and connect the Null Modem cable to the “RS232 (XVCR)” port on the back panel of the KPA500
● Set the baud rate in the “RS232 X” menu entry. All speeds (4800-38400) should work. Set this value to 9600 to match the default value of the FLEX-6000.
● Go to the "RADIO" menu and set the option to "SERIAL"
● Go to the “SER POLL” menu and set polling to “ON”
SmartSDR Setup:
● Set the Cable Type to “CAT”