Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR v3.2.34 installed but still no remote access outside the local network.

SmartSDR v3.2.34 installed with no issues locally but I cannot connect via remote laptop or Maestro. I have a commercial firewall (HA) and was running a fixed IP until the last update when I lost remote (outside the local network) connectivity and... had local issues as well. Changing to a reserved IP allowed local SmartSDR operation but no remote access.

My firewall requires forwarding to a fixed IP and it worked beautifully until v3.2.31. Additionally... it appears I can no longer set a static IP for my 6600M. What is the reasoning for that? It was there because I had to disable it to get to a reserved DHCP address. Now it's gone. Am I missing something here?

I would love to learn it is a knobology issue on my part but I don't think so. Any help would be appreciated.

Comments

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Dave

    Can you confirm the IP address of the radio and then review the settings in your router to see if the UDP and TCP ports are still referencing the correct IP address of the radio.

    If that is a bit foreign for you, can you get the person who set it up for you to give you a hand?

    Commercial firewalls/routers have much stricter rules than our consumer-grade devices. We tend to use these when we want tighter controls on things. In fact, they really tightening things down and it sounds like that is what you are seeing.

    This is why we do recommend that the radio run in DHCP mode and with uPNP running on the router. Then when you reboot the radio it sends the right commands to the router (Skype does similar things). Commercial routers turn of uPNP since you don't normally want that sort of end user control in a commercial environment.

    The only way to set a static IP address in an M model is with a DHCP reservation.

    73

  • Dave KC9EI
    Dave KC9EI Member ✭✭

    I have verified the IP. What everyone at Flex keeps dancing around is this was a working system with a fixed IP before the software update. Are you suggesting I must have "now" enable uPNP on a commercial Firewall in order to operate remotely when I/we have been doing so with no issues previous to these latest updates? If that is the case, then this is a fatal flaw in the software and inexcusable. Fatal in my case at least.

    It means my 6600M will no longer be useable in the remote mode unless I depreciate my system security. I may be one of the few people in this situation but it is indeed a valid case.

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Dave, I have been using port forwarding here and not uPNP. I've helped a half dozen people over the last couple of weeks migrating to DHCP reservation and making sure port forwarding is configured correctly.

    Double check the SmartLink setup ports and radio IP match what you have set in the router. Start with a factory reset of radio then deregister and re-register SmartLink again and set up the SmartLink port forwarding.

    Worth a shot.

    73

    Dave wo2x

  • Dave KC9EI
    Dave KC9EI Member ✭✭

    I'll give it a try Dave and let you know

    thank you

  • Dave KC9EI
    Dave KC9EI Member ✭✭

    Success! I'll do a postmortem and put up the details and what I "think" happened which might answer questions for others as well.

    I'm running with a reserved IP instead of a fixed. It appears the latest update did indeed fix the IP issue.

    Thank you Mike and Dave.. Details coming

    Dave KC9EI


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    @Dave KC9EI

    Hi Dave

    We can help you out and you can use the manual methods to ensure your port forwards are correct. You will also need to make sure your router allows for outbound connections to the Flex servers on non-standard ports. Again, this is normal for commercial routers to make it difficult to do. They generally turn off everything outbound (except for some popular ports like 80, 443, etc) and block all the rest.

    Commercial routers turn off all ports and then the admins turn on what you want.

    Consumer routers open everything and then you block what you need to.

    Turning on uPNP is not as ugly as the world says it is. It isn't really a large attack vector since you still require a 'answering' program on the other side at the right IP address and right port number. The trade off is that if you are concerned about uPNP then you have to manage those requests manually. Just for reference, I have uPNP turned on for my 2 radios and I keep an eye on the Log files and have never had anything else turn on another port. This is what it looks like:


    Do you know if your Router is preventing the radio from communicating to our servers at all?

    Have a look in section 44.9.4 and it goes over the items you will need to address.

    44.9.4 My router doesn’t support UPnP. How can I setup my radio to reliably connect to remote clients?

    For a reliable connection without UPnP you will need to use Manual Port Forwarding. To use Manual Port Forwarding, you will need to pick one TCP port number (e.g. 4994) and one UDP port number (e.g. 4993) for SmartLink to use.

    Referring to section 9.2.2,

    Register the Radio in SmartLink, go to the Network Settings screen.

    Select Manual Port Forwarding then enter the port numbers you have chosen in the TCP and UDP Port fields.

    Click the Save button. The remainder of this procedure is done to the configuration settings of your router.

    Details for setting up port forwarding on a wide variety of routers is beyond the scope of this document, but this document, https://helpdesk.flexradio.com/hc/en-us/articles/115003365503-What-is-Port-Forwarding-and-How-do-you-do-it , should provide a good starting point. In addition to port forwarding, your radio should be assigned a Static DHCP address by the router to avoid occasional breaks in the SmartLink connection caused by changes to the radio’s IP address.

    We are happy to help you out, but we need more details, such as the IP address of the radio, the router and a screen shot of the manual setup screen in SmartSDR.

    This screen tells a very good story. If this is what yours looked like, you would need to port forward WAN (outside) port 21000 TCP to the radio IP of 192.168.110.76 and the same for port 22000 UDP to the radio IP of 192.168.110.76.



    Let Dave or I know what you are seeing.

    73

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.