Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

EasyPal

Charlie, WA3UTCCharlie, WA3UTC Member ✭✭
Has anyone out there configured EasyPal for use with SmartSDR, If so would you mind sharing your configuration? Charlie....WA3UTC

Completed · Last Updated

«1

Answers

  • W4YXUW4YXU Member
    edited April 2016
    Using DAX 1 or 2 usually but frequently I just can't find any combination that puts a TX and RX DAX with the same number! It just occurred to me that perhaps I should just open anther slice on the same frequency and pick another DAX to get a working xmt and rcv. Will try this soon. I use com5 for CAT and com6 for PTT . Some day I will learn how to re-install com5 and com6 when they quit working without going to 7 and 8! Dos this help?
  • Michael N6BRPMichael N6BRP Member
    edited February 2017
    I'm running Windows 7, and use Dax audio RX 1 for RX and Dax Audio Tx 1 for tx I use Cat PTT for ptt and pick Kenwood as the rig. Keying "Tune" seems to work fine, but I've never sent any pics (just rcv) -Mike
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    I have it set up with no problems. Here are two of my setup screens... I hope this helps... Ken - NM9P
  • Charlie, WA3UTCCharlie, WA3UTC Member ✭✭
    edited January 2014
    I also can't find any combination that puts a TX and RX DAX with the same number! But will Try your configuration Ken. I will let you all know how I make out. Thanks for the help folks... Charlie.... WA3UTC
  • Charlie, WA3UTCCharlie, WA3UTC Member ✭✭
    edited January 2014
    Still not Joy. I could not find a matching pair so I created another slice. Receive on DAX_2 on slice 1 and DAX_3 for Slice _2. This should work. I opened the recording devices in windows and can see the levels change on DAX Audio DAX_3 when transmitting, which tells me EasyPal is producing audio when I transmit. Audio input selection on Smart SDR is set to DAX with the slider set mid-range, No +ACC. I can receive images and I can use either PTT/CAT or Com Port PTT rts/dtr and the transmitter transmits. I guess for some reason (most likely my fault in a configuration setting) Smart SDR is not seeing my routed EasyPal audio. Ken, in your configuration you are seeing DAX ports that are RX and TX of the same value. I do not seem to see this either as well as Jim, hence the reason for creating the second slice and setting it as the transmitting slice.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    The setup page lists all of my DAX Channels, but they are almost in random order. You really have to search to find the right one in the list. In fact, I deactivated DAX channels 3-8 because on my 6500 I only have 2 slices at present. It cuts down the clutter. Some programs have a limit of how many audio channels can be used. You might try deactivating your unused DAX channels in the sound control utility in Windows and see if it makes it easier to find your DAX channels. It shouldn't be necessary to work split with this. Make sure you are using the DAX Audio RX 2 for the input channel from the Receiver and Use DAX Audio TX 2 for the output channel to the TX. (Do NOT use the RESERVED audio or the IQ audio channels... those are for other special functions) This is a little different from PowerSDR, where you used line 1 for in and Line 2 for out. You need to use RX 2 for in and TX 2 for out (Or use channel 1 if you want. But for some reason, I have fewer problems if I use Channel 2) Then on the DAX Control panel, you have to make sure that DAX Chanel 2 has both the RX and TX buttons clicked on. And on your receiver slice flag, be sure to select DAX 2. Then on your Transmit panel, select DAX for the mike input. There is a lot of preliminary set up clicks required. Then don't forget that you need to go into Easy PAL and select the input sample rate of 48,000. And in your windows sound setup page you must modify the properties of each Recording and Playback DAX channel to set the sampling rate of 2 Channel, 16 bit, 48000 Hz (DVD Quality) This is found in the sound properties/Advanced tab. This will make sure that Windows doesn't need to do a lot of conversion calculations between different sampling rates. This reduces possible spurs generated by calculations artifacts. Hope this helps. Good luck. BTW...If you don't have the latest version of EasyPAL, be sure to download it before you start any elaborate setup modifications of you may have to do it all over again.
  • Charlie, WA3UTCCharlie, WA3UTC Member ✭✭
    edited January 2014
    Thanks Ken..... I will check my configuration again and see what I can do. Yes I do have the latest version of EasyPal.... No issues in using EasyPal with my 5000 and VAC..... I also have a 6500 and will be sure to let you know how I make out. 73 Charlie....WA3UTC
  • Robert -- N5IKDRobert -- N5IKD Member ✭✭
    edited March 2015
    As Ken suggested, disabling unused DAX channels will reduce the clutter and allow you to choose a matching DAX pair.
  • Charlie, WA3UTCCharlie, WA3UTC Member ✭✭
    edited January 2014
    Thanks Robert.... This has be done.... I still can not seem to get EasyPal to show me the DAX ports in the required sequence RX2 - TX2 etc.: I might just uninstall Smart SDR and re-install. Simple enough and easy to do..... More as I move forward, hehehe
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    They may not be in any particular order. Every time you make a change to any of them with the Windows sound control panel, (i.e. change Sampling rate, etc.), Windows seems to reorder the list. You have to look in the list to find the correct audio device, DAX channel, etc. It is frustrating, but you should only have to do it once! Just keep looking in the list for the proper DAX lines. Unless it didn't install correctly. Then an uninstall/reinstall might help. But then, first thing you should deactivate the unused lines and change sampling rate properties on the ones you will be using. Don't give up. It is worth it when you finally get it going! BTW, don't forget to hit the "Assign button after selecting the audio lines. And some programs may not work if you do not have both the RX and TX lines set to the proper sampling rate, and that rate must match the rate selected in the EasyPAL program, too.
  • Charlie, WA3UTCCharlie, WA3UTC Member ✭✭
    edited January 2014
    Thanks Ken and Team. un-installing Smart SDR, Cat and DAX and re-installing and following through with configuration of each application, I was able to see the ports without issue. Got the little guy up and running now..... It only took about 1/2 hour total. Not real sure why DAX and things went belly up, but we are good to go now. To all of you that provided guidance.... Thanks so much for the help.
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    I realize I am digging up an old thread but instead of starting another I thought  I would ask the question here.

    I installed EasyPal (1 version older than current as I was getting dll conflict issues). Anyway, old version runs OK as far as I can tell. Well it receives fine but when it goes to TX it keys the Flex (6500) but does not seem to have any audio.

    Here are my settings. I do not have a TX1 listed for some reason.

    image
  • DrTeethDrTeeth Member ✭✭
    edited December 2018
    Actual EasyPal support is non-existent. The dev has no direct contact with users and the support group is as much use as a chocolate fireguard as it is as dead as the proverbial parrot. It crashes on my main PC, the one I am going to move my rig to when life gives me enough time to sort out the RFI.

    Follow the advice a few posts up about disabling DAX ports you wull never need. I have a Flex 6300, 2 slices, so DAX 3-8 disabled.

    See https://community.flexradio.com/flexradio/topics/easypal-catch-22 as it mentions stuff about the 6500 too, basically you should disable DAX 5-8.

  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    I am hoping I can make it work. Its actually pretty cool.  Regarding support just in case you are not aware the developer is fighting cancer and is unavailable because of that. I found a message posted part way down on his page that he would not being answering emails because of health issues but heard the rest of story elsewhere.

    One question someone might answer for me. Is the Audio streams related to the number of slices?   As an example on the 6300 can you delete 3 and up and 6500 delete 5 and up or is there an actual use for the streams.
  • Jay NationJay Nation Member
    edited May 2019
    Rich
    You might need 8 DAX channels if you have 8 slices open with 8 Digital apps running.

    You shouldn't need more than that. If you do, you might consider running 2 6500s, that may require another antenna and an extra hand or 2. Personally I prefer to not use Slices F and G unless it's an emergency, so I get by ok with just 2 hands, eyes, and ears. I've considered installing an extra brain, but can't find one that matches. ;0)
    Jay - NO5J
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    Well I was able to get it to transmit. But the real problem (I think) lies in the fact I do not have a channel that has both TX and RX on it except channel 6.

    My channels 5 and above do not seem to work anyway. Or I dont know what I am doing which is likely. I can switch it between 1 and 4 and I can see the audio level on the DAX control panel change. If I change to 5,6,7 or 8 the audio appears to stay on the last (1-4) channel I was on. I have not found anything that will send audio to channels 5-9 on my 4 slice flex.
  • Jay NationJay Nation Member
    edited May 2019
    Did you reinstall SmartSDR and DAX after you upgraded the number of possible slices when you got the 6500?
    Jay - NO5J 
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    Yes I did.
  • DH2IDDH2ID Member ✭✭
    edited December 2016
    Ken, I have installed the newest EasyPal version from 2014-10 on my Win7/64bit system and I get this error when starting the program
    image

    Do you know how to correct this?

    Thanks and 73,

    Alex DH2ID
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    For what its worth I get the same exact error. If you go back to previous version it does not do it.
  • DH2IDDH2ID Member ✭✭
    edited December 2016
    Thanks, Rich. You're absolutely right. Must be some bug in the october version ;-)
    73, Alex DH2ID
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited June 23
    The 6500 only supports 4 DAX Channels..
    The 6300 only supports 2 DAX Channels

    You need a 6700 if you wish to use 8 DAX Channels
  • AA0KMAA0KM Member ✭✭
    edited April 2017

    Places to check. Also you need the October version latest version. The new easypal and the old are not compatible in Hybrid mode.


    imageimageimage
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    Thanks Howard. The Flex Manual could not be more unclear on that :)

    I swear at one time only so many audio streams showed up on my DAX control panel but I am showing all 8 despite them being removed from Windows. Is there a way to shut them off or am I imagining things?
  • Mark ErbaughMark Erbaugh Member
    edited February 2015
    I have a 6300 which only supports two channels. Sometimes when I bring up the DAX control panel, it shows me all 8 channels, but it those instances, DAX doesn't work. If I shut down just DAX and restart it it will usually display just the two channels and usually, but not all the time, work. BTW, I have removed both DAX. And SmartCAT from the Startup folder so that they don't start automatically at boot time.
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    Mark now that you mention it I think when I had my 6300 it would sometimes show 2 and sometimes all 8.  But since I got the 6500 it always shows 8.

    I have pretty much gave up on EasyPal transmit. For some reason it is not seeing all the audio streams and I cant find a TX and  RX on the same channel.
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited February 2015
    You can always go into the SOUND Control Panel and make sure that DX5-8 are disabled .. that will likely eliminate them from the DAX Control Panel
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    Yea in my case that does not work. I have removed 5-8 tx, rx and reserved. Still there. However I dont think I have rebooted since.
  • Rich McCabeRich McCabe Member ✭✭
    edited February 2015
    I did reboot. 5-8 all disabled and still have them in my DAX control panel.

  • DrTeethDrTeeth Member ✭✭
    edited August 2016
    They will still show in the DAX control panel, but they should NOT show in any applications as selectable options. I have disabled 6 DAX streams as I have a 6300, I have all 8 in the DAX CP (I just resize the window to show two) but only have DAX 1 + 2 as selectable present.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.