Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

With a router having UPnP enabled should/can ports still be forwarded?

Options

I have had UPnP disabled in my Cisco router and have been doing port forwarding for 4994 and 4993 which works fine. However, when ever I need to do factory reset on the 6600M I need to manual enter these on the radio replacing the "-1"'s. Trying to eliminate having to enter these ports manually, I turned on UPnP while still keeping ports 4994 and 4993 enabled for port forwarding. When I selected "Auto" in stead of "Manual" to enable the radio connection, it would not pass the test. Before I disable the port forwarding on the router (don't want mess with something that is working), should I have been able to connect the radio using the "Auto" connect even if ports 4994 and 4993 were being forwarded by the router or can't UPnP be enable and ports forwarded at the same time?

Randy KH6XX

Answers

  • Ha Gei
    Ha Gei Member ✭✭✭
    Options

    There is no Problem in doing that, i ran my setup this way long time.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    Options

    I think the bigger problem is why do you have to keep resetting the radio?

    On my contest (home radio) I haven't reset it in years it seems.

    What sort of problem are you seeing that requires a reset?

    BTW, I have been using uPNP on my routers forever. uPNP gets a bad rap for a problem that doesn't yet exist from a cyber security perspective. Yes, it could happen, but there are much easier ways to infiltrate a home computer system. You might find in the long run, using uPNP is safe.

    But, we understand, it is a personal preference. 73

  • Ken Wells
    Ken Wells Community Manager admin
    Options

    1) If you are using MANUAL port forwarding when UPnP is still turned on....Stay away from the standard "Default" UPnP "External Ports" of TCP 21000 and UDP 22000. This will avoid any port conflicts.

    Check your router's UPnP Port Forwarding table. It is has chosen to automatically assign a different set of ports, be sure to avoid using them in any MANUAL port forwarding rules.

    2) If you have more than one radio on the same network, UPnP is certainly the easiest way to go!

    If not, you must manually forward different "External Ports" for each radio.

  • KH6XX
    KH6XX Member ✭✭
    Options

    I would like to use UPnP but can't seem to get it to work. I turned on UPnP in the router and I disabled the port forwarding for 4993 and 4994 and tried to connect with Smartlink using the Auto on the network tab but can not pass the test. I tried numerous times and can not pass it. When I go to the manual mode and select 4993 and 4994 on the radio, when I go to test it fails for the say the first 5-6 times when tested, then it passes. Wonder why I can not get UPnP to work and secondly why will it not pass the test the first time I test using the manual mode but requires several attempts? This has me wondering if I need to attempt testing using the Auto feature more.... for maybe it will eventually pass?

  • Steve KD2OM
    Steve KD2OM Member ✭✭
    edited January 2
    Options

    I am also having trouble with UPnP/port forwarding. Isn't UPnP supposed to make all the connections? I am using an Mikrotik router and so far have not been able to get a pass. I have tried manually forwarding the ports with out success as well.

    73 Steve KD2OM

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    Options

    What does the router show? Look in your uPNP tables or NAT tables.

    You may have to look online on how to find those tables. They will tell the story.

    Or, please open a support ticket and they will get it sorted out.

    73

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.