Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex 6000 Series USB Ports

Mark Griffin
Mark Griffin Member ✭✭

I am confused at the fact that the USB Port under the Ethernet Port works yet the second USB Port does not. I would hope that when Flex does a burn in or runs some sort of program that it would let them know that there is a problem with them. I realize that if you have a USB Port that doesn't work on a computer, they advise you to perhaps go back to the original bios and see if it would work. But then again, with a computer you have the option of being able to activate or deactivate a USB Port. But strange enough Flexradio does not give you that option. And I'm not sure if I did go to a different firmware whether that would help or not. Plus, seeing that I use Smart Control, there is probably no software version of SmartSDR that I can install to work with that. I did try a powered USB Port from amazon on the first USB Port, but it does not recognize the 2 USB Connections attached to it. I welcome any thoughts on this.

Mark Griffin, KB3Z

Comments

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    The 2 ports on the back of the radio are always active awaiting a connection.

    SmartControl is not related to the USB ports at all.

    I think you answered your own question. You will have to use the powered USB Hub in order to get both devices to function correctly. There isn't enough power on the USB port to power both devices with one on each port.

    73

  • VE7ATJ_Don
    VE7ATJ_Don Member ✭✭✭

    hi Mark... it would help us if you could tell what you are trying to plug into the USB ports and what model of Flex you have. As I understand it, the USB ports on the Flex are not 'generic USB ports' as you would find on a laptop as the Flex firmware doesn't provide the same 'plug and play' support that a Windows OS would, for instance.

    The USB ports on the Flex are for specific connections to particular devices (like amplifiers and antenna switches, etc.) I believe. From the 6600/6400 hardware manual -- "The USB 2.0 ports are used for SmartSDR specific functions only. Do not connect unqualified USB devices to the FLEX 6400/FLEX 6600. Refer to the SmartSDR documentation for information about how these work."

    Section 34 of SmartSDR: "The USB Cables feature provides a means to control external devices such as amplifiers, antenna controllers, and tuners via USB to Serial data cables connected to the USB ports on the back panel of the radio. Band data generated by SmartSDR appear on the cable in a form acceptable to the external device."

    I hope this helps....

  • Mark Griffin
    Mark Griffin Member ✭✭

    Mike, Don,

    I have a 6400M with a Bandmaster V and SPE 1.3K-FA amplifier attached. The Bandmaster V USB Cable is not FTDI enabled. Simply because it doesn't need to be. On the back of the Bandmaster V I can attached a Serial port to USB Cable. And I assume that I can purchase a cable that would be FTDI Enabled. The SPE 1.3K-FA Cable was made my Expert Amplifier. If I connect the SPE to the top USB Port the flexradio will read and send the frequency to the SPE Amp. But if I connect the Bandmaster V USB to the USB Port below that it doesn't read the frequency from the Flexradio and send it to the Bandmaster V. For some reason USB Port # 2 is deader than a doornail. And I assume there is no way within the firmware of the 6400M to be able to disable or enable a USB Port. Yes, you can do that on a computer, but on the Flexradio you can't. Trust me guys, I am used to the fact that it doesn't work. And once I get my PGXL Back, I will disconnect the SPE 1.3K-FA amplifier. My workaround for this is as follows, in the SPE 1.3K-FA I set the rig to none, and just press the band button to put it on the band that my Flex 6400M is on. It's not automatic, but it at least works.

    Mark Griffin, KB3Z

  • Al_NN4ZZ
    Al_NN4ZZ Member ✭✭✭

    Mark wrote:

    "If I connect the SPE to the top USB Port the flexradio will read and send the frequency to the SPE Amp."

    What happens if you connect the SPE to the BOTTOM USB port? It if still works then that would indicate the bottom port is working.

    Al / NN4ZZ 

  • Mark Griffin
    Mark Griffin Member ✭✭

    Al,

    No, if I connect anything to the bottom port it does not work.

    Mark

  • Alan
    Alan Member ✭✭✭✭

    Mark

    The SPE1.3K USB port uses an internal (to the SPE) FTDI chip. Any simple USB cable connected from this port to either of the two Flex USB ports will work.

    Your Bandmaster does not have an internal FTDI chip. That is why Flex Radio does not see it. Use a Serial to USB, FTDI cable. Check your Bandmaster doc for a straight-thru or null modem cable. I suspect it needs a null modem cable.

    This is not a Flex Radio problem.

    Alan. WA9WUD

  • Mark Griffin
    Mark Griffin Member ✭✭

    Thanks Alan!

    I will check into that!

    Mark

  • Al_NN4ZZ
    Al_NN4ZZ Member ✭✭✭

    Hi Mark,

    Just found this on FAKE FTDI chips. When your cable is plugged in the FTDI serial number is displayed on the Settings/USB screen. Apparently the one I'm using is FAKE, most of the legit serial number start with FT. My BandMaster V is working with this cable but as I noted I have to power up the BandMaster after the radio is powered up. Apparently the fake chips can work but if I ever have any trouble, I'll swap out the USB cable with one that has a FTxxxxxx serial number.



    Regards, Al / NN4ZZ

    al (at) nn4zz (dot) com

    6600 SSDR V3.5.9

    TGXL 1.1.20

    PGXL 3.7.32

    Win10 Pro V2004

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
This discussion has been closed.