Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Smartlink still not working after 3.5.9 update on 6600M

Jeffrey Kerber, N3VE
Jeffrey Kerber, N3VE Member ✭✭
edited September 2023 in Remote Operation (SmartLink)

Updated the 6600M and still have no internet on the radio? Anyone else? The option to login appears for a few seconds then goes away.

Jeff N3VE


  • Jeffrey Kerber, N3VE
  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Hi Jeff, I would submit a help desk ticket.

  • Jeffrey Kerber, N3VE

    Downgraded to 3.5.8 then upgraded to 3.5.9 and smartlink is working now.

  • Jeffrey Kerber, N3VE

    Still not working, was intermittent, now not working again.

  • ronsmithmd
    Mine is not working on SDR on Windows or SmartSDR on Mac. Wasn't working before updating firmware or after. Have tried downgrading and it's still not working. Says no internet connection (which I obviously have since I'm typing this) and the registration fields on SDR for Windows flashes ever so briefly and so doesn't allow credential entry.
  • KH6XX
    KH6XX Member ✭✭

    Same here... wasn't working before updating the firmware or after. Still can not configure SmartLink with the message "This radio does not have an internet connection". I opened a ticket.

    All of this is very frustrating... just want to be able to sit down, turn the radio on and expect it to work. When it works, it is great, but I have no confidence it will work when I do turn it on. These SmartLink issues are occurring too frequently.

  • k0otc
    k0otc Member, Unconfirmed
    edited September 2023
    I followed the upgrade instructions for 3.5.9 and I'm still not able to connect to my Flex 6500 via SmartSDR on my iPhone or iPad.

    When I try to connect, I receive the following message: "Error connecting to SmartLink Service"

    I'm really hoping this is fixed soon.
  • smumustang
    Similar experience on my 6300 - upgraded to v3.5.9 earlier this afternoon (CDT in US) and it worked for a while, but now it's refusing to connect via SmartLink stating that it cannot find any radios. A larger question to answer is, "Why does this seem to happen every few months?"
  • Tim, VK6EI
    Tim, VK6EI Member ✭✭

    The silence is deafening.

    Plus for me is I am having a blast using the new to me Hermes Lite 2 HF SDR. Got it running a have been getting some great signal and audio reports. Driving SPE amp with 5 watts from the Hermes. Thetis is a bit of a learning curve at first but I just love the interface skins you have to choose from.

    So, whilst annoyed I cannot access the 6400M remotely at the moment I am still getting my daily radio fix.

    I am sure the tech's at Flex will get the issue sorted, eventually. Perhaps they may even learn just how important a RELIABLE smartlink server is. Always, seems to be as soon as contest season starts to roll in there suddenly becomes an issue. A very good reason to not put all of your eggs in the one basket long term.


    Tim, VK6EI.

    Yes am experiencing the same issues with 6400M saying it doesn't have an internet connection, clearly it does but someone mucked up some code along the way.

  • Lars
    Lars Member
    My flex6400 is unable to connect to smartlink. Smartlink has worked before, but when I log in, I get a message that the internet cannot connect and my signal and name do not come up. Can now only run locally. It is also not possible to connect the iPad or iPhone remote via smartlink. I have gotten everything working before both with smartsdr 3.4.23 and 3.5.8 also briefly with 3.5.9. Is there a big problem with the software for the flex radio?
  • K9SO
    K9SO Member ✭✭

    The very first thing you have to do is upgrade to 3.5.9. That will give you access to the SmartLink servers. Unfortunately, radios that have not upgraded will continue to ping the servers and they're currently overloaded. That means even if you have upgraded you may not be able to connect. But if you're persistent, and keep trying, you should be able to. I am currently trying to connect again this morning, but I'm not successful. Flex may have turned off the servers while working on them. Last night I was able to connect intermittently.

    Remember that all three of the main programs must connect (SmartSDR, CAT, and DAX). When everything was working, this usually happened automatically and almost immediately.

    Those who are experiencing SSB "clicking" or motorboating in their audio are likely picking up these constant connection request pings from the computer noise getting into their audio. Some are even reporting noise in their RX audio. Try a different microphone or get better cable separation from your computer until this gets fixed. In the past, I found that balanced microphones like the P40 are particularly susceptible to this computer noise. Usually, it's not a problem since there is little computer traffic.

    One user changed from his P40 back to the OEM hand microphone to solve this computer noise pickup problem and his motorboating went away. Once (if) you connect, the noise should stop.

    It is important to note that even if you're not using SmartLink, your radio will continue trying to connect to it... and even if you've installed 3.5.9. No server connection will show up as a "Radio Internet: NONE!" warning.

    This is quite the mess and thousands of radios are constantly trying to log in every time they're turned on. That doesn't sound like a good design practice in hindsight. But for now this will probably continue until EVERYONE upgrades or until the Flex engineers find a miracle cure on the server end.



  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    It is going to take some time to reduce the load on the SmartLink Servers. It will eventually clear.

    Thanks for your patience and we continue to monitor the server performance.


  • Erik Carling EI4KF

    "It is important to note that even if you're not using SmartLink, your radio will continue trying to connect to it..."

    What is the reasoning behind this behaviour? Why put a demand on SmartLink servers, and elevate the risk of suffering from connection request computer noise, for a service that is not currently being used?


  • n1ah
    n1ah Member ✭✭

    9/15 - As of now (9AM Im sitting here looking at this all morning)

  • John WA7UAR
    John WA7UAR Member ✭✭✭
    edited September 2023

    @Mike-VA3MW I have a suggestion... if it is ever possible... perhaps having TWO root servers would be appropriate. The first for radios and software that are at the current/corrected version levels not to overload SmarkLink servers running the most up-to-date releases -- and the second for those that are not at the most recent release.

    This way, people can be automatically routed to those servers best able to accommodate their version and not overwhelm root CA certificate servers used by still previous/out-of-date/malfunctioning versions.

    Is this a legitimate idea? Could different Root CA certificates be recognized coming from different SmartSDR software/radio firmware installs in order to direct those radios to the most appropriate Root CA certificate server? Versions 3.5.9 and 2.10.1 would communicate with one Root CA certificate server and "all others" would communicate with another... thus assuring that people who update their radios and software are directed to a CA server that is not being overwhelmed by other (out-of-date) users?

  • EA7IXM
    EA7IXM Member, Unconfirmed ✭✭

    How disgusting flex is giving me... every day I am more disappointed, if I could go back I would never have bought 2 flexradio. The service that these unpresentable people are providing to their clients is a shame. If I have paid the high price of 2 flexradios it is for the remote option, if I knew that they were going to be without a remote I would have bought another SunSDR 👎️

  • Mick  W8BE
    Mick W8BE Member ✭✭

    I tried to get in twice today, 9AM and 11AM. Both times SmartLink never showed the radios. I logged out and back in successfully but the radios never came up. Small companies can't afford high publicity mistakes. I will leave it at that.

  • Steve K9ZW
    Steve K9ZW Member ✭✭✭

    Mine started working about 19:00 UTC on Friday September 15th . Fingers crossed it stays solid!




  • KM4CQG
    KM4CQG Member ✭✭

    When I try and Log In via smart link I get a strobing effect on the Apps window.

    If I don't use smartlink all seems normal.



  • RFord
    RFord Member ✭✭✭

    No luck in Raleigh, NC...

  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin

    For the latest update on the SmartLink outage, see https://community.flexradio.com/discussion/comment/20605830/#Comment_20605830.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.