Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Smartlink stopped working with 6400

minorsecond Member, Unconfirmed ✭✭

Smartlink was working on my 6400 but stopped at some time recently. Nothing has changed with my network. I have ports 4994 and 4993 forwarded to the 6400. I've tried connecting to the radio with a Windows laptop and my iPhone off my home network but no dice. I've unregistered and re-registered the radio in Smartlink. I've also rebooted the radio.

The smartlink test in SmartSDR fails.

Is the service down, or is there anything else I can try?


  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Are you using SmartLink locally or remotely?

    It is designed to only work remotely.

    If you are trying to get SmartSDR working locally, don't use SmartLink, just connect directly. This does require that your computer or Maestro be on the same network segment as the radio.

  • minorsecond
    minorsecond Member, Unconfirmed ✭✭
    edited July 16

    Remotely. I tried from a coffee shop and I've tried at home with my Phone as a hotspot, and using the iOS SmartSDR software with Wifi turned off.

  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Ah, OK. You might want to submit a help desk ticket then. The Flex support staff are pretty good at figuring out network issues.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Can you describe what 'fails' means. A bit more details please.

    • Can you see the radio in the radio chooser?
    • If so, can you actually connect to the radio?
    • Or, does it time out connecting to the radio?

    One thing I have discovered is that I turn off IPV6 on the SmartSDR App on my iPhone, I have much better success. My Radio is not on an IPV6 network. I'm not exactly sure how that figures into things, but it does require more investigation.

  • Morning Flex world. I´ve been having issues connecting to my 6400 with Smartlink recently. From a couple of days ago it is impossible for me to connect using smartlink. I´m logged in in Smartlink, I see the radio on my iphone and ipad, but when I select connect it does not.

    I´ve verified my local router and ports 4993 and 4994 are forwarded as it should be (as far as I know) but no connection is achieved. If I click on test smartlink it fails.

    Any feedback will be appreciated.

    Santiago , HI8O

  • Alan
    Alan Member ✭✭✭✭


    I have had the same issue.

    Interesting, I have two Flex radios, and one of the two work just fine on SmartLink.

    Doing a Flex Radio Factory reset fixed the SmartLink problem radio.

    Alan. WA9WUD

  • Thanks Alan. I will consider that option.

    73, Santiago

  • Gord-VA7GP
    Gord-VA7GP Member ✭✭

    For the past few days, I also experience difficulty connecting remotely / Smartlink. On my Win10 PC, I get the forever-circling blue "busy" indicator, but never a connection.

    Fortunately, I have the Flex "Remote On/Off Kit" where I can perform a soft-shutdown, and turn-on. When I do that, every time, Smartlink and remote connection begin working nicely again. Weird, and it never used to be this way...

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin


    What would be very useful would be to know what the settings are in your router when this happens.

    • Are the port forwards the same as the radio is expecting?
    • Is the IP address of the radio still the same matching the port forwards in the router?

    It sounds like the port forwards are 'sleeping' in the router (if that is even possible).

    What happens when you reboot the radio is that the radio then sends the correct commands to the router and that is why the radio starts to work.

    Unfortunately, this problem will likely continue until the root cause is understood. To me, it sounds like an issue with your router. Once we know why, then we can address fixing it.

  • Gord-VA7GP
    Gord-VA7GP Member ✭✭

    I'll keep an eye on things, and see if everything returns to "normal" again. Over this past weekend, I changed-out my decade-old ISP modem for a new, modern one (with clearly "nicer", more-progressive traffic-shaping).

    The Port Forwards on my Ubiquiti UDM-Pro remain as they've always been, but because of the modem-change I rebooted this baby for good measure also. This UDM-Pro is 10Gb/s fiber-connected to my managed switch, thence over to my ham-room. Prior to rebooting the UDM-Pro, 'ifconfig' showed me not a single dropped-packed during the 6 weeks' uptime ... so, I think my side of things remains steady, and solid.

    But my third-party ISP (TekSavvy) uses underlying infrastructure provided by my local cable company (Shaw), which was recently acquired (by Rogers) and they are initiating changes (DOCSIS 3.0 banned by Dec, hence my choice to get on-board with their mandated DOCSIS 3.1 *now*). However, this is good hygiene, and may/may not be connected to my SmartSDR recent "busy" indicator.

    I can only say, for sure, Monday begins well with the usual quick SmartSDR connection to my Flex from office at work.

    "Customer to monitor" :-)

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin


    This isn't a dropped packet issue.

    All the hardware you have can interrupt the communications. If the WAN address changes (an ISP issue), then the radio will not work on SmartLink if for some reason the new WAN IP address is not detected or sent to the FlexRadio servers.

    You might want to keep a watch on the WAN address and see if it changes. If the WAN IP address doesn't change and the port forwards don't change and the forward the inbound connections to the radio correctly, then you'll have to dig deeper.

    I assume you have UPnP turned on. Is that the UDP-Pro that is the router or is the router on the modem? Or, is it just a network switch? It is hard to tell from Ubiquiti's web site.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.