Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

PGXL Utility Reconnecting...

Hello, I'm using as normal my 6600 with SmartSDR v3.4.23 and my PGXL with PGXL Utility FW3.7.32 up to yesterday all operating normally.

This morning I started both my 6600 PGXL and I usually operate my PGXL with the Utility but apparently is not connecting and I only get the Utility with a message Reconnecting...

I already power off and re-started my PC but still the same, Reconnecting...

6600 PGXL working OK (RX/TX).

Any ideas why apparently is not connecting with the Utility ?

Thank You



  • John WA7UAR
    John WA7UAR Member ✭✭✭
    edited May 18

    Hello @Juan TG9AJR -- I have been experiencing this same exact issue recently. Under the previous firmware and now again on the latest. Last time I reset the PGXL back to factory defaults and wrestled to get the static IP reconnected. I don't want to do that again. I have placed a video of what is happening on my WeTransfer service (20Mb .mov file can not be attached on this discussion thread apparently.)

    One thing I have noted is that I can still access the PGXL from SmartSDR for Windows and Mac. I can set it to standby or operate... I just can't see it with the Utility anymore.

    Any ideas from the community? I will submit a follow up ticket to support. We are two people reporting this now... so I'm guessing it is being seen by others too?

    Thank you.

  • Alan
    Alan Member ✭✭✭✭

    The Genius devices, PG-XL included, only allow three TCP-connected devices.

    You mention other connections....perhaps you have reached the three limit.

    Be sure to count the Flex radio as one of the three connections.

    Alan. WA9WUD

  • Juan TG9AJR
    Juan TG9AJR Member ✭✭

    Hello @John WA7UAR thanks for your reply and for the information as well, that it is interesting that is happening to you as well and I'm sure too others as well.

    As you mentioned it both the PGXL and 6600 work OK but the PGXL Utility is useless and yes I also like to see my transmit display on the Utility but under the Reconnecting... it does not work at all.

    This is the very first time it happens to me, never before even with previous FW versions.

    All do I have to say that yesterday after several hours of both the 6600 and PGXL to be ON and transmitting, suddenly out of the blue and without doing anything the PGXL it did connect (finally) to the Utility and seem as normal...will see how it goes today.

    @Alan as far as TCP-connected devices I only have my 6600 the PGXL to a network switch and nothing else (in my case).

    Juan TG9AJR

  • Juan TG9AJR
    Juan TG9AJR Member ✭✭

    Update and without a clue but as mentioned before yesterday after several hours of been Reconnecting... suddenly it did connect and today just as normal no issues connecting the PGXL with the PGXL Utility.

    [FYI] Not necessarily means solved or answered.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Hi All

    Can you all make sure you reach out to 4O3A about this? You can email them at [email protected]

    They need to be aware of it and they are the ones that do the software. They don't monitor this forum.


  • John WA7UAR
    John WA7UAR Member ✭✭✭

    Here is an update...

    Today I learned that the static IP address of my PGXL had been inadvertintly assigned by my network administrator to another device on the network that I use. It eventually came to light when other administrators "higher up the food change" tracked down the issue.

    As soon as I was given a new IP address then the "Reconnecting..." error went away and I am now able to access my PGXL using its utility program.

    Here is the ticket that I reported to Flex support that is now closed:

    Request #58721

    So... lesson learned... if the PGXL or TGXL are constantly "Reconnecting..." then look for a duplicate IP assignment somewhere on your network. This would also explain why the issue came and went... the "other device" was sometimes turned off and so would not cause the problem until it came back on again.

  • Juan TG9AJR
    Juan TG9AJR Member ✭✭

    BTW I did sent a couple of emails (the same) 4O3A support about that issue, so far I had never heard back from them.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    The Reconnecting message means that the Application is not able to communicate with the PGXL

    Some of the root causes are:

    • Different IP address
    • Network issues resulting in a loss of communications
    • Bad LAN cable resulting in a loss of communications (yes, this does happen)

    In your case, you must be on a work (commercial) setup. That is not the situation for most home operators since we are usually our own admin.

    For others at home, this is why running DHCP all the time is much more reliable. The DHCP server will not reassign an IP address if it is in use. As well, for home networks, the PGXL application can 'hear' the PGXL broadcasting its location when you first start the application. If it doesn't they you have a communications loss assuming the PGXL is actually turned on.


  • Dewey WØYWW
    Dewey WØYWW Member ✭✭

    I had this same problem for a very long time -- it was easy to ignor, because the PGXL reconnect only lasted for a couple of seconds and then reconnected. Experimenting (I have a lot of different network switch types and brands), I found that all of my network switches caused the problem, some made it a lot worse. I ended up changing the network switch, where my Flex-6600, -6700, TGXL, PGXL, PC (dedicated to Flex station), and 2x8 Antenna Genius are all connected, to a 16-port version of the network switch that Mike uses (tp-link TL-SG1016DE)... (Mike uses same switch only 24-port version). I've had this network switch in use for about 2 months, and have yet to see the "reconnecting" PGXL app screen notification...YMMV. Switch cost me $85 + tax on Amazon.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.