Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can't connect to AG...HELP!!

Hi, I have a Flex 6600M, PGXL and TGXL all working through a ethernet switch with a 80 foot Cat8 cable run to my Windows 10 PC. I installed the Antenna Genius app on the PC and plugged the Antenna Genius into the switch. The PC sees the radio, amp and tuner fine. When running the Antenna Genius App, there is nothing displayed to connect to. I have done the Dip Switch 7 & 8 resets with no change. I also tried running the Antenna Genius and PC to another switch with nothing else connected. I did the Dip Switch 7 & 8 resets again, but nothing shows up on the Antenna Genius App to connect to.  HELP !!!

Thanks and 73


  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Hi Dan

    where are the dip switches currently? For a Flex transceiver they should all be off.

    Next, do you see the network connector LEF indicating it is talking to your network?

    Download the manual from 4O3A.com and read how to reset the network settings (not reset the switch).

    73 Dave wo2x

  • Daniel  AA4HV
    Daniel AA4HV Member ✭✭
    edited March 5

    Thanks David,

    I found the info for a bricked device after I posted. I have all the switches off and I do have the blinking LEDs at the jack. I can still connect to everything else through the switch. I tried the bricked device procedure. No change though. When I click UPGRADE in step 9 of the procedure, nothing happens for a second then I get a pop up message "Device not found on". This thing is a dead brick.

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Where did you buy it? From Flex? How old is it?

    If from Flex, open a Help Desk ticket. https://helpdesk.flexradio.com/hc/en-us/requests/new

    If you bought it from 4O3A or another vendor open a support ticket with 4O3A https://4o3a.com/new-ticket

    There is a procedure to force the AG into bootloader mode where you can install new firmware. I do not know if offhand but 4O3A support does. It requires getting the AG into bootloader mode then connecting a PC and setting the PC IP to and then upgrading the firmware.


    Dave wo2x

  • Daniel  AA4HV
    Daniel AA4HV Member ✭✭

    Thanks David, you have been great help.

    I bought it from Flex. New, just got here 2 days ago. I have searched Flex and 4O3A sites for answers. I submitted a ticket to both.

  • Rich M5RIC
    Rich M5RIC Member ✭✭✭

    Sounds smilar to my issue when I first got mine. See my thread.

    Do you have internet going through your switch? My AG only worked when I had internet connected, in the end I bought a cheap router so then it supplied a DHCP address to the AG.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.