Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

New 6400 problem using SmartLINK w/2.8.1

For an unknown reason, I can no longer remotely connect to my 6400. I uninstalled and reinstalled 2.8.1 with the same results. This started a couple of days ago.

When I try to access the radio, SmartLINK sees it then I get a "Connection Lost", "SmartSDR for Windows has lost connection to the radio. Please reconnect". I also see a small box pop-up on the right side that says: "SmartSDR Client connected from IP xx.xx.xx.xx" (mine).

  • Ham radio computer rebooted several times (Windows 11 Home, up to date, 1 Gbps wired LAN, on one subnet at home)
  • Tried on my main computer over here ... same problem (Windows 11 Home, up to date, 1 Gbps wired LAN, on another subnet at home)
  • Tried on a 3rd computer running Windows 10 (Microsoft Surface Pro 4) and on WiFi on 802.11ac, which I use when traveling, same problem
  • IP addresses have not changed (i.e., local and remote)
  • The local Fiber Gateway and Routers have not changed
  • The remote router and modem haven't changed
  • I have a NUC on the remote LAN side and I can access the 6400 from that side via "RemotePC".
  • No changes to my Firewalls
  • I uninstalled and reinstalled 2.8.1, rebooted and have the same results. Did this on both computers

As I am seeing this on three computers, I assume it's something over here OR SmartLINK. On Tuesday, I'll try to connect from a Starbucks and from the office. I'll report back

In the meantime, any ideas?


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    @W4AFK Bruno

    You didn't mention what the ports on the Router are configured for. Have you logged into the Router to check that the 2 required port forwards are actually there and pointing to the IP address of the radio?

    Uninstalling the software won't make any difference, however, walking through the steps in Chapter 9 of the SmartSDR manual again with the NUC on the LAN side might tell you a few things.

    It sounds like your router has dropped the uPNP settings for the radio. A simple reboot of the radio might solve it. You didn't mention if you had done that or not.

    If you can't do that remotely, run FRStack on the local NUC and see if that helps. FRStack3 is easily found by googling.

    See if that helps.

  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    I tunnelled to the 6400 via the NUC which is on the LAN side.

    • Remote Router: Linksys WRT1200AC
    • Remote Router: UPnP is enabled
    • Remote Router: Port forwarding: UDP 4991 to 4991, 4992 to 4992, TCP 4993 to 4993
    • Installed STACKS3 on the NUC (have it on my remote computer)
    • Rebooted the Flex via Stacks3
    • Ran the Flex on the NUC ... all OK
    • Started SmartLINK on my home computer ... got the same error message! Says it lost connection
    • Rebooted the remote router ...


    Something must have gone awry with the router and rebooting it solved the problem. It must have been that as I did not make any changes to the remote router.

    Moral: Sometimes the solution is right in front of you but we tend to "over analyze" the problem and "over engineer" the solution :-)

    Thanks for you help as it made me think more clearly

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    You need to delete the 4992 port forwarding. This is not ever required.

    Opening that up to the outside world provides a non-secure direct connection to your radio. That is very risky and is highly recommended by FlexRadio to never do that. I can't stress how important this is.

    Usually, the first thing we tell people is to reboot the radio and the router and it fixes everything. I thought you had tried that.

    Glad you got it working!


  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    Hmm ... I did that based on the following info: What is Port Forwarding and How do you do it? – FlexRadio. and this from your guide: "41.9.4 My router doesn’t support UPnP. How can I setup my radio to reliably connect to remote clients?"

    I did this as it wasn't working using UPnP. SInce we solved the problem, it's working fine using UPnP once again.

    As for the "first things", we did reboot the radio and I agree that the router should have been #2. What happened is that we both "thought" that the other had rebooted the router (call it "egg on our face" LOL).

    Bottom line, it's been working fine and all is well

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    It is ports 4993 UDP and 4994 TCP. Each needs to be port forwarded to the radio’s IP.


    Dave wo2x

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.