Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FLEX-6400 keeps on locking up

W4AFK Bruno
W4AFK Bruno Member ✭✭
edited February 2023 in FLEX-6000 Signature Series

Flex-6400 running 2.8.1, Expert 1.3KFA amp, broadband antennas.

The FLEX-6400 keeps on locking up even in "tune" (~10W). We have to factory reset the Flex, and then it works for a while ... then it locks up again.

  • DC power cords, LAN cable, Cable Modem cables, Router cables, USB, Amp control cables all have ferrite chokes.
  • Rack and equipment are all grounded (not the best ground though as the outside rod is around 20 feet away).
  • We tried different PSUs, moving equipment around, etc.
  • We tried connecting a laptop directly to the Flex and we see the same problem after a few tries.
  • Very frustrating as a second radio, a TS-480SAT, which is remote controlled via a RemoteRig interface NEVER locks up and has been rock solid for years. It uses the same router, cable modem (for me), amplifier and antennas (amp has two inputs and 4 antenna outputs).

Help!!! Any suggestions? :-)

We are getting to the point of replacing the Flex-6400 with a Yaesu HF radio and manage it via software (as we do with SmartSDR).

I operate remote from California while my ham host operates remote from inside his home (the system, is in his garage). We both use SmartSDR. He connects via the LAN and router while I connect via a WAN, cable modem and the same router. We both have the same problem with the Flex. When it works, it's great!

We suspected the cable modem and/or router BUT they never lock up and when we use the TS-480SAT (control head is in California, radio is in Florida), we NEVER see this problem. So, it's not RF that's affecting the cable modem or router. It has to be with the Flex and its connections. The frustrating part is that these lockups can even be triggered in TUNE mode using ~10W. So it's not "high RF power".

By the way we set the "TUNE" to generate ~10W. It's only used when we need to tweak one of the antennas using the tuner that's built into the Expert 1.3K-FA amp. The broadband antennas all have VSWR below 2:1 and the amp's tuner is always on-line when the amp is turned ON and is either in OPERATE or STANDBY mode. We only use the amp when needed and more often on 40m and 75m.

We really love the FLEX and we both know that there are MANY stations that have similar setups and remote control the radio without any problem. We know that it MUST be something we are missing. So, this message is to seek some constructive suggestions and NOT a Flex-bashing exercise. We really do NOT want to change radios but although I can use the TS-480SAT he cannot (he doesn't have a RemoteRig or TS-480SAT control head). So although I can enjoy ham radio he cannot, which is unfair.


  • KP4IP
    KP4IP Member ✭✭
    edited February 2023

    What about if the Flex is in Rx only for a multiple days? do it present the same issue?

  • W4AFK Bruno
    W4AFK Bruno Member ✭✭
    edited February 2023

    OK ... only the FLEX-6400 connected to a laptop and to a dummy load. Start SmardSDR, click on "tune" and the radio works a couple of times, then the next time it locks-up. Reset the radio, start again, and a similar pattern. Can't say that it happens every time, every 2 tries, etc.

    Voltage to the radio is 13.8V measured at the connector but we will measure the voltage while in TX mode. Wanting to see if there is a voltage drop. Could be something with the cable or connector. I saw this at my home with an IC-7300. 13.8V in RX then drops to 12.6V in TX @ 10W. Voltage dropped into the red on the radio with higher power, but Alinco DM-430T PSU shows 13.8V on its display. For me, it was not the DC cable, but the PowerPole connectors I used with the PSU,

    This kind of tells me that ...

    • ... the SD Card is corrupt.
    • ... the Radio has a problem.
    • ... the DC input has an issue.

    We ordered a replacement card and waiting for it to arrive.

    Any other suggestions?

  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    KP4IP - Haven't tried this. We will leave the radio in RX into the dummy load (too many thunderstorms in Florida to leave it 24/7 on the antenna :-)

  • K9YK
    K9YK Member ✭✭

    What if you switch the RF output to use the transverse port instead? That should take the PA out of the equation.

  • W4AFK Bruno
    W4AFK Bruno Member ✭✭

    K9YK - I did not know that we could use the transverter port as it can't drive the Expert amp. Alos, isn't the transverter port very low power? (I need to look this up LOL)

    We ordered a new SD-Card from Flex and my host ham will be checking the DC voltage at the radio. I would LOVE to tackle this challenge myself but unfortunately, my remote is 2682 miles away :-(

    My gut tells me that it's either the SD-Card or the DC input at the radio. After all, a laptop connected to the Flex, the amp disconnected, the Flex connected to a non-radiating dummy load ... and ~10W will lock it up.

    Unless I am missing something very obvious, that is NOT an RF related problem.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    I created a support ticket for this.

    Let them know it does it with a dummy load as well.


  • W4AFK Bruno
    W4AFK Bruno Member ✭✭


    At Flex Radio's suggestion, we installed FR-Stack and found out that when in TX, the reported DC voltage dropped CONSIDERABLY. The PSU continued to provide 13.8Vdc (as measured at the fuse) but on the radio, it dropped WAY below that.

    We then checked the external in-line fuse and found out that on the radio side of the fuse, a connection had become corroded and intermittently became very resistive.

    We changed the fuse cable, and all is working fine now.

    So, THANK YOU Flex for suggesting FR-Stack as it made us think outside the box. It was a DC problem after all, but we were measuring on the PSU side of the in-line fuse and not on the radio side. Goes to show that even experienced OF's like us can sometimes fall down a rabbit hole :-)

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.