Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Problem with 6700

I have already put in a ticket for this issue but I am wondering if anyone has had a similar issue. I have a 6700 that was purchased many years ago and still has the original SD card. I was operating the 160 cw contest this weekend and a couple of times, the radio acted strange. I was using CWX to transmit and one time I hit the F1 key to send my call and nothing happened. Then, about a minute later, the radio keyed and sent my call. I ended up shutting down the computer and radio to reboot everything. However, the radio wouldn't boot. It would get past the calibration screen and then show my callsign. It boots about 80% and then clicks twice and then gets into a loop of showing my callsign and then clicking, then callsign disappears then comes back and clicks twice. After several times of trying to reboot the radio, it finally booted up.

I had a second incident where I tried using CWX and nothing would send. I tried clicking on several items in SSDR and nothing would happen, but the radio was still receiving. All of a sudden the radio keyed and sent my callsign about 10 times before I powered off the radio. I ended up rebooting and it took several tries to get the radio to come back on. I was able to finish the contest and shutdown the radio for the night.

This morning I can't get the radio to boot. I have tried 10+ times and it gets stuck at my callsign and clicks twice. I did try the reset (holding the OK button while powering on) but it still gets stuck at the same place.

Has anyone ever had this issue? I am hoping it's just an old chip as I still have the original and my 6700 was purchased many years ago.




  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    The support team will sort this out for you.

  • Butch
    Butch Member ✭✭✭

    I've ever seen my 6700 do that. Just curious. When you were experiencing this, did you try doing a factory reset on your 6700?

    Butch, KF4HR

  • K4QXX
    K4QXX Member ✭✭

    Yes, I mentioned that I did the reset after the 2nd time the radio wouldn't boot. Still won't boot up this morning. Gets stuck at my callsign and clicks twice and gets into a loop.

    Hopefully I will hear from the helpdesk today.



Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.