Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex 6700 powers on but most controls are not responsive. Cannot import profiles. Anyone seen this?

Radio: Flex 6700 S/N 2017-5331-6700-1033

GPS Option

SmartSDR version: 3.3.32

PC: Windows 7

Yesterday evening, I powered on my Flex 6700 and instead of coming up with the 4 slices and all the usual settings, it came up with what I guess is a default screen, 40 meters. There was no received audio.

- I am unable to adjust transmit power. The sliders snap all the way back to zero.

- Received audio does not work at all (i.e., no output)

- If I try to right-click and "Create Slice", that selection is grayed out.

- I am not able to create a new slice, nor can I enable the transmit slice

  • Profiles do not import. It goes through the motions, but clearly nothing is actually imported

- Normally I can double click on the display to bring that frequency into focus, but that now has no effect

- The network diagnostics say the network status is Excellent

I tried a master reset of the radio, including the wait times after powering down and removing the 12v. No change.  I have not made any changes whatsoever to the 6700 or my PC in quite some time. I tried to adjust the frequency step and I received a large, ominous "tombstone" window with lots of what I suspect is JavaScript goop. See below.

Any help you can offer would be greatly appreciated. The radio right now is in an unusable state. This certainly, in my view, smells like a hardware issue. I always disconnect the antenna when I'm not using the rig, and touch the center antenna connector and shield to ground before plugging it into the 6700 antenna port (paranoid old coot). Checking now to see if Amazon sells chicken bones and VooDoo handbooks.

Thanks in advance.



  • John WA7UAR
    John WA7UAR Member ✭✭✭
    edited November 2022

    Hello Bob,

    The symptom of not being able to create a slice is exactly the problem that impacted many of the legacy Flex radios (like my 6700 too, but apparently not the 6400 nor the 6600) — and the reason why 3.3.33 was recently released. I see that you are on 3.3.32.

    Likely you have already done it but I would start with a shutdown and power removal and then boot to check if the problem is still there.

    After that I urge you to consider an upgrade to 3.3.33.

    Good hunting!

    Cheers, John

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Yes, you need to upgrade to 3.3.33.

  • WA4FOM
    WA4FOM Member ✭✭

    You were dead right. **** peculiar how it ran for so long with no problems.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.