Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR not reporting RF power from PGXL

JimStuder Member ✭✭
edited January 2023 in Power Genius XL Amplifier

I updated the SDR software to 3.3.32, the PGXL to 3.6.24, and the TGXL to 1.1.8. Everything works fine but when I transmit using the 6600 to excite the PGXL the Power Genius XL window in SmartSDR does not reflect power going out. It shows in the PGXL app, the PGXL, and the TGXL. SmartSDR is running on Windows 10, fully updated. Has anyone else run into this?

Best Answer

  • DL4RCE
    DL4RCE Member ✭✭✭
    edited September 2022 Answer ✓

    Hi Jim, same problem here. Sometimes this happens, after restart the PGXL it does work again.


  • JimStuder
    JimStuder Member ✭✭

    I turned the PGXL off and on and the problem went away. It had been on 24 hours. Maybe that was too long.

  • JimStuder
    JimStuder Member ✭✭

    This never happened before I updated the software/firmware. Oh well, a minor issue.


  • With the latest FW for PGXL it has now failed every time. I confirm that it's transmitting by looking at the current drain for the whole house... So it generates power but it's not seen in SmartSDR.

    With previous FW it worked now and then... But now it's at a 100% loss...

    All my operation is done remote.

    Adde, SM0SHG

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    @Adde Tjernberg Please open a support case for this.

    Not all of us are seeing the same failure, so it would good for them to work with you on this.


  • Dave K5OZ
    Dave K5OZ Member ✭✭

    This sometimes happens to me if I lose internet connectivity. When I turn the PGXL off and then back on the meters start working again.

  • bahillen
    bahillen Member ✭✭✭

    I have seen this happen on my SmartSDR now and then. I reboot things and it goes back to normal.

    6600, PGXL, Tuner Genius. PGXL utility reads fine. Just not the applet in the rig window.


    Bill W9JJB

  • fpmacko
    fpmacko Member ✭✭

    Me, too. PGXL app always works. PGXL display in SSDR is sometimes off-scale low.

    73.....Frank / WA3NHK

  • JimStuder
    JimStuder Member ✭✭

    Guys and Gals, the problem is solved. I really appreciate the assistance but please stop solving an issue that's been solved for months. I've posted twice saying as much.


    Jim AK4I

  • DonS
    DonS Member ✭✭✭

    So what was the solution as I am know experiencing the same issue on a random basis?

    Don - kx9q

  • Sergey KN7K
    Sergey KN7K Member ✭✭✭

    Same here - SSDR ver3.4.21

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    If you are having an issue with meters with SmartSDR 3.4.21 and PGXL 3.7.29 please open a support ticket.


  • JimStuder
    JimStuder Member ✭✭

    Mike, I am good. I keep getting help for a problem I've already fixed.

    Jim Studer

  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Hi Jim, I think that Mike is responding to the other people on this thread who have indicated that they are having problems.

  • JimStuder
    JimStuder Member ✭✭

    Got it. I just keep getting emails noting that someone has responded to my email and I didn't review the whole thread.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.