Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6600M Display - Very Disappointed

w1smc
w1smc Member ✭✭

I've had my 6600M for almost 9 months now and the display is a real disappointment ... Things started out okay ... Now, most times it comes up trash and can barely read it ... Thankfully the radio is behind a wall in my shack so I don't see it ... But for the price point you'd think it would have lasted a bit longer??? ... Lesson learned ... I should have bought the non-M model and saved myself a bunch of money ...

Steve / W1SMC

Comments

  • Neil D Friedman N3DF
    Neil D Friedman N3DF Dayton, OHMember ✭✭✭

    Have you opened a help desk ticket with Flex? After 4.5 years of almost daily use, my 6600M display still looks great.

  • Mike Steventon
    Mike Steventon Member ✭✭✭

    Also 6600M. No complaints here, either. Great screen👌

  • Joe N3HEE
    Joe N3HEE Member ✭✭

    I've had my 6600M for almost 4 years of daily use with no display panel issues.

  • VE7ATJ_Don
    VE7ATJ_Don British ColumbiaMember ✭✭✭

    Hi Steve... as Neil said, I would HIGHLY recommend opening up a Help Desk ticket. Flex are very responsive. While they do have reps that regularly check this Community, your best bet is the HD ticket route.

    As others have said, a wonky display on an M model is not normal behaviour.

    When you say '... it comes up trash...' can you provide more detail? Is the screen blank, unreadable? Can you take a picture with your phone and post it? Most of us won't have the tech background to help you with this, but it will sure help the techs @ Flex.

  • w1smc
    w1smc Member ✭✭

    The display comes up cloudy with many white horizontal lines and some vertical on the left side. Also, sometimes after 15 or 20 minutes things do clear up some ... Currently the rig has been running over 6 hours and the left side of the display has some vertical white lines and they are blinking ... When I first start the radio though the display looks like a mess ... And it's not because I have yet to take the plastic covering off ... Hi Hi ...


  • Trucker
    Trucker Member ✭✭

    I would contact the Help Desk and get an RMA ticket started. This definitely not normal.

    Like the others here, I have had my 6600M since they were first available. And I have never had an issue like this.

    James

    WD5GWY

  • VE7ATJ_Don
    VE7ATJ_Don British ColumbiaMember ✭✭✭

    I agree.. I see multiple 'hardware' problems here. There is definitely a fault in the screen and/or its drivers/connection.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    This is a hardware issue and needs to be resolved by our support team.

    Please open a support ticket.

This discussion has been closed.