Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Problem With USB Devices Connected to FLEX 6600M after 3.3.29 Upgrade

Yesterday I updated to 3.3.29 on my Flex 6600M. All seemed to go OK until I noticed that the USB devices connected to my FLEX were no longer working.

I have 5 USB devices connected (i.e. 2 WX0B band decoders, 2 Elecraft KAT-500 tuners, and 1 Elecraft KPA 500 amp). One is connected to USB Port #1 on the Flex, and the other 4 our connected to USB Port #2 using a hub.

Using SmartSDR, I can see the 5 USB Cable entries listed but they are greyed out. If I unplug all 5 devices, wait a minute or two, and then plug them back in one at a time, they show up in the summary and they now work. However, the next time I turned the radio off and back on again, the USB devices did not work and all entries in the USB list were greyed again.

I did try a factory reset (after saving my profiles) and re-entered the info for the 5 USB devices again in SmartSDR. It did not help.

Any ideas about what may be causing this problem? I thought about downgrading back to 3.2 but really don't want to do that.

Al Dewey, K0AD



  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Hi Al

    I opened a support ticket for you. This is not normal.

  • Al Dewey
    Al Dewey Member ✭✭

    For anyone following this thread, I thought I would let you know that my problem is solved. It turned out that I really DID need a POWERED USB hub for the 5 USB devices I have connected. I'm not sure why it worked before (i.e. with previous Flex SW version) without using a powered hub but I am happy that all is working well now that I have a POWERED USB hub.

    Thanks to Ken from the FLEX Help Disk for his assistance.


    😀Al, K0AD

  • KD0RC
    KD0RC Member, Super Elmer Moderator

    Thanks for the update Al.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    A powered USB hub is a must as the power available from the back of the radio is minimal.

    Glad it worked out for you.

  • Randy KN4YBA
    Randy KN4YBA Member ✭✭

    Boy, this was a home run for me. I also upgraded to 3.3.29 and really didn't test transmit function. After traveling and trying to catch up with my Home/Mother in Law House/ and Beach condo duties I figured it was a good time for my newest remote antenna relay system checkout. I ran into the same issue, I kept dropping my USB connection to my USB relay. I thought it was my design and went back to my MFJ Ameritron RCS-10 but quickly figured out I was having a similar issue. I looked into everything and finally figured to check the Flex community. Sure enough there it was. I quickly installed a powered USB hub and everything works as I expected. It is weird in the software upgrade I noticed there were improvements to the USB but never considered this was to be the issue. I remembered when I first installed my 6400 that the documentation recommended a powered USB but in the earlier version of software I did not have an issue without the hub.

    Thanks Al & Flex!


    Randy KN4YBA

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.