Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

V3.3.29 update unsuccessful on Flex 6500

I attempted to update from 3.2.39 to 3.3.29. The process began normally. After about ten minutes, the update progress bar stayed yellow and progressed from left to right and never changed state and the red light on the 6500 flashes and TIMEOUT is displayed on the 6500.

Bob, KN4HH

Comments

  • Bob  KN4HH
    Bob KN4HH Bob Member ✭✭

    Additional information. I shut down the radio and re powered radio and now it will not complete the calibration cycle.

  • Wayne VK4ACN
    Wayne VK4ACN Member ✭✭

    I had the same problem with my 6500 and they're sending me a new sd card.. So looks like the 7610 will get an outing until its fixed

  • Bob  KN4HH
    Bob KN4HH Bob Member ✭✭

    Thanks for the info. I am awaiting a reply from my Help Desk Ticket.

  • Bernard John
    Bernard John Member
    Bernard G0AJZ ,Flex 6500.
    Also have the same problem after download attempt,
    Rig Shows three red flashing lights and display says timeout.
  • Just opened myself a ticket. Lost my 6300 to the update.

    Now, it's just a matter of hoping and waiting.

    Santiago, HI8O

  • 1JR RSM
    1JR RSM Member ✭✭

    I have the same experience as did Bernard. Radio is 6300.

    Mike, KB4HIN

  • kg5eiu
    kg5eiu Member ✭✭

    I just tried to do my 6600 - everything seemed to update just fine - I powered down the radio and cold booted - now I am unable to connect to it from Windows or Mac - it connects for about 1second and then disconnects and I get red flashing power button. Going to open a ticket.

  • W5XZ - dan
    W5XZ - dan Member ✭✭

    my 6500 is bricked with this 'update'....k5lc tells me his 6700 is also....same thing

    'timeout' and red led blinks 3 times....1st time an update has ever killed my radio...

    totally unimpressive....w5xz, dan

  • kg5eiu
    kg5eiu Member ✭✭

    So I was able to revive my 6600 - after several crashes/reboots - I hard reset the radio - rebooted the PC and was able to attached and get back online. Its working great now. (it was the 2nd hard reset I did)

  • DF1LON Lars
    DF1LON Lars Member ✭✭

    I have the same issue with my Flex. It shows "Timeout" after "Calibrating...". Reboot did not help. I already opened a tickt. It is the first time I have issues with a SW upgrade.

  • W5XZ - dan
    W5XZ - dan Member ✭✭

    None of the beta testers had this problem??

  • KM4CQG
    KM4CQG Member ✭✭

    How is it possible that so many of you are experiencing update issues.

    Nobody from so called Alfa Team has had this issue?

    Is this an issue with the 6300, 6500, & 6700 or are the newer 6400 and 6600 also effected?

    This certainly isn't the 1st time Flex has update issues.

    Please Posts any fixes either from Flex Radio or User discovered.

  • Trucker
    Trucker Member ✭✭

    It depends on the age of the radio and whether or not it has the original SD card in it. If the SD card has been replaced at some point, it looks like there won't be any problems updating except for the ATU problem. That isn't related to the SD card corruption issue.

    I would suggest that people hold off on this update even if they have a newer SD card in their radio. More so, if they use the internal ATU. It seems like someone dropped the ball and didn't test this update enough. ( regarding the ATU problem) SD card failures, Flex Radio has known about for a long time now. But, instead of being proactive and replacing them BEFORE something like this happens, they decided to wait and replace them with more durable SD cards as they failed. They brought this on themselves by not being proactive. Not a good thing.

    James

    WD5GWY

  • WX7Y
    WX7Y Member ✭✭✭

    Remember the ALPHA and BETA testers get MANY updates to try before they send it out to us lowly users in a release version and may or may not have gotten a NEW SDCard to use before in their checking and fixing features.

    I think this all depends if your radio ran a earlier version of SmartSDR that had the SDCard corruption in it and it is a hold over from those even though you had no issues with 3.2.39.

    This is a NEW animal now that I think actually re-writes the SDCard and not just replace the necessary files and somethings going on with the older radios SDCard's that ran earlier BROKEN versions of SmartSDR won't let the full update run.

    With the 6700 and 6500 that have a RADIO display it shows a "Timeout" error, On the OLDER 6300 it shows a Blinking RED LED, On the 6600M it shows that there is NO network connectivity on the Bottom Left of the Maestro front display and continues tries to reboot.

    After Watching this very closely on my 6700 and 6300 and my Friends 6600M I think what happens to crash the update is on one of the Reboots it doesn't let the Network connection come back on and establish the Computer OR Maestro control head connection to totally finish the Update.

    That's my opinion anyway.

  • Alan
    Alan Member ✭✭✭

    In my case, I found one way to "fix" a corrupted SD card is to write a new version of the firmware to the card. I have done this by downgrading and then upgrading the firmware.

    This technique does not work if the corruption is so bad that the Flex will not boot up. I first noticed problems with profiles and unexplained Flex shutting down. Doing a downgrade/upgrade always fixed the problem, before it progressed to a failure to boot (three red flashing lights).

    Since Beta testers re-write the SD Card OS, with each beta version, their SD cards are "repaired" if there is any corruption on each beta test SD card OS re-write.

    Just my theory.

    Alan. WA9WUD

  • John R
    John R Member
    Update went well on my 6400m, but, My Icom PW 1 does not like it when I touch the tune button on the radio.
    Sometimes ok next time Red amp protect light lights.
    No rhyme nor reason when it will happen?
    Overshoot on drive power?
    Still set well below limit?

    Reinstalled previous version and appears ok now?

    John/W8JER
  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator

    Hi John, That doesn't sound normal. I would submit a helpdesk ticket.

  • robbinsdw
    robbinsdw Member
    Same problem with my 6300. Update from 3.2.39 to 3.3.29 failed; radio flashes three red lights and repeats.
    73,
    Dave, KC2MB
  • Mike VE3CKO
    Mike VE3CKO Member ✭✭✭

    My 6700 has been flawless until this update so my SD card was an original. I opened a ticket shortly after getting the Timeout- 3 red flashes, and was very promptly attended to. Hats off to the support team, Ken and Tim who quickly determined the issue and sent me a new SD card to Canada and I received it yesterday morning and did the swap out last night. All is fine again in my Flex universe. I decided not to import the old profiles and start a new.

  • AA0KM
    AA0KM Member ✭✭

    WX7Y

    Quote== ""After Watching this very closely on my 6700 and 6300 and my Friends 6600M I think what happens to crash the update is on one of the Reboots it doesn't let the Network connection come back on and establish the Computer OR Maestro control head connection to totally finish the Update."""


    On to something maybe turn off Static before the update in radio setup.


  • WA4FOM
    WA4FOM Member ✭✭

    My 6700 just self-detonated after the 3.3.29 update with the "TIMEOUT" error. This is the second time an update

    has crippled my radio. Way to go Flex!

  • ka9ees
    ka9ees Fithian IL USAMember ✭✭✭

    Another one bites the dust. Open a help desk ticket. You're gonna need a new SD card.

  • AA0KM
    AA0KM Member ✭✭

    6500- Successfully upgraded from 2.7.6 direct to 3.3.29 less than 8 minutes.

    Using windows 11 and I turned off Malwarebytes made sure computer was all up to date.

    I did not un-install anything just went right to the 3.3.29 install.

    Still had all my settings from 2.7.6

    Oct-2014 6500 model...

    ======================================VVVVVVVVVVVVVV====================

    I missed this one. Explains it all. I vaguely remember the processor issue.

    https://community.flexradio.com/discussion/8026416/notice-to-our-customers-regarding-smartsdr-v3-3-29-release-steve-hicks-cto-n5ac


    I am now new user of multiflex. Ipad works great as well as desktop at the same time.

    Only a few hours but haven't noticed anything bad.


  • Ernie
    Ernie Member ✭✭

    Just curious if anyone else has had this problem with v3.3.29 and a 6500 when updating from v3.2.39.

    The firmware load stalls with yellow bar all the way accross the display. Powering off the radio and doing a cold boot and then starting SmartSDR v3.3.29 connects to radio okay with radio and ATU appear to be working, but DAX and CAT cannot find radio without a dropdown selection available to select a radio.

    Downgrading to v3.2.39 also stalls at the end of upgrade, but all works.

    There is a ticket in work, but has not been solved yet. Just checking if I am the only one with this problem.

  • KF5NXR
    KF5NXR Member
    Just bricked my Flex 6300 going to 3.3.29 Wasn't aware of the problem until after it happened and I was googling for a resolution and found this discussion. I've opened a help desk ticket as per instructions above, I'll let ya'll know the outcome. I would think Flex would email out a warning as this has been going on for several months based on dates of comments.
  • KM4CQG
    KM4CQG Member ✭✭

    All that comes to mind is this.......

    https://www.youtube.com/watch?v=rY0WxgSXdEE

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.