Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Radio disappeared from SDR

PaulB
PaulB Member ✭✭
edited April 5 in Networking
So I get my brand new 6600. Set it up with Ethernet to my switch, install Smart SDR on a new windows machine (connected to the same switch, with the same subnet.) It finds the radio, no problem. Set up SmartLink. Key the mic. Checked a remote computer, all works. Then about 5 minutes later, the radio disappears. "There are no radios available" from the local machine (and the remote machine obviously). Have tried uninstaliing/reinstalling the software, reboot, router, switch, etc. I can't reboot the radio because I am remote (I am accessing the desktop through VNC remote desktop). I will be able to have someone go reset the radio, but is there anyone here who might now what caused it to begin with? It had the latest version because it didnt ask for an update. I could ping the IP address of the radio, so I know it has power.

Comments

  • Bill NE1B
    Bill NE1B Member ✭✭✭

    Power glitch? Is your power supply backed up by UPS?

  • PaulB
    PaulB Member ✭✭
    Its on batteries connected to a rig runner. My shack is off grid and has solar panels, charge controllers, etc.
  • PaulB
    PaulB Member ✭✭
    So I was able to get it back, kind of...reset the radio. But version 3.2.x has more bugs in it than an Alabama trailer park. Locks up on start, tries to launch multiple windows, says it can't connect, when it shows a radio right there on the screen, etc. Its a miracle if I ever get a log in without 10 splash windows with lines of errors that won't even fit on a dialog window....Looks like its a version 2 for me.
  • John KB4DU
    John KB4DU Member ✭✭✭

    This is a help desk issue. These are not common errors. My 6400, same basic radio and software starts reliably and runs for days.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Something in your network is preventing the radio from communicating with the rest of the network. It can be the radio, the cable or the switch.

    Normally, I would change the cable, try another network switch port and then do some testing with the NIC card on the radio.

    Or, for some reason, the radio is 100% offline.

  • PaulB
    PaulB Member ✭✭
    edited April 4
    Its not offline. Smart SDR can see it. It shows the radio, but then when you try to connect, the software locks up. Its definitely a software issue. I have to force close with task manager, reboot, etc. I'm dealing with support at this time.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    No, actually, that is a network issue most likely.

    When there is not full data communication it is due to a loss of packets between the radio and the computer.

    It can be in no order as each thing is involved:

    • the radio
    • LAN cables
    • the Switch
    • NIC card in the PC
    • Windows
    • SmartSDR

    I have created this sort of failure with a bad LAN cable and to test it, all I did was swap a cable without doing anything else and it all worked.

    It could be related to the radio, in which case, the simple test is to connect a PC directly to the radio with a LAN cable (called a Link Local test). If it doesn't fail at this point, then you look at the network switch as not all switches are created equal.

    All of this will have to be tested when you are back at the radio. When you can, open a support ticket so they can logically take you through the debugging steps.

  • PaulB
    PaulB Member ✭✭
    Switched Lan Cable. Switched port on switch. NIC is doubful bad because I am accessing it fully through VNC, and its a new computer. Windows...well..it's windows (wish Flex was on linux haha). The switch is performing many other functions (an enterprise quality switch and is passing traffic across subnets and vlans no problem, so the switch is fine). The computer and Radio are on the same subnet..no Vlans involved. No firewall rules preventing any traffic on this subnet (it's my main admin protected subnet so it has no restrictions). I do have a support ticket open and we have been debugging everything and there has been no resolution.
  • PaulB
    PaulB Member ✭✭
    The software takes as long as a minute to start up (which isn't normal obviously as I have seen it work and it takes a half a second) and then starts kicking errors. Even if it were a network problem, it shouldn't lock up the software as a result. It should just "not connect". Obviously some need for failsafe improvements in the software if it doesn't get a connection. Locking up and opening multiple dialog boxes saying it can't connect (and pushing the CPU to limit) at that point is an obvious bug. Happens in both version 2 and 3 in this case, even with a clean install of windows.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Hi Paul

    This doesn't sound like a bug at all as it was, everyone would be experiencing it, or a least most people. We have to look beyond the symptons.

    What it does sound like is that for some reason, the computer is resource or i/o bound, which means that there are bottlenecks somewhere. It should take, on an average computer, about 5-10 seconds to bring up SmartSDR locally (for me, it is under 5 seconds).

    If SmartSDR bogs down or just fails, it is due to a loss of data from the radio. If it can't connect and run 'as it should' there is no reason to attempt to keep it running if it is providing audio HF that is buffered by more than 400ms or so. Buffering is ok for a movie, not good in real-time communications.

    Slowdowns can be related to lack of memory, slow or corrupted hard drives as they are in a state of constant repair (I/O bound), or just 'too many things' going on (CPU bound). Antivirus can be the worst thing going a lot of AV programs can slow computers by 50% due to the amount of file inspection they are doing.

    Running some DPC tests to show DPC latency will help show some of the root causes. https://www.sweetwater.com/sweetcare/articles/solving-dpc-latency-issues/#How-to-check-DPC-latency-on-Windows

    You can test network performance with tools like iPerf or a bunch of others mentioned here: https://www.geckoandfly.com/33225/lan-network-benchmark-test-speed/. They really help to show bottle necks in your network. You may think you have a 100mb/sec network (or a 1G network), but when you test it, it can be much worse.

    You seem to have ruled out Windows, so that is a good data point. Next, I would make sure the NIC card drivers on your PC are up to date or that it could be something like a hard drive that is not as fast as it should be. My guess is that you have a high DPC rate, but since I don't have the computer in front of me, I can't really guess beyond that. You haven't mentioned much on the specs of the PC hardware you have, but that would help as well.

    You may want to open a support ticket at this time as well to have them work through any possible radio issues. You can do that here

  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin

    What is the IP address of the radio and the local PC that is connecting to it? I suspect they are on separate subnets which would result in exactly the behavior you are describing (it shows up on the radio selection screen, but then fails to connect).

  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin

    Eric is correct. If the radio and the network interface you are using on the PC is not on the same subnet, then you will experience the symptoms you describe.

    Here is how you determine the IP address of the radio and local PC.

    For the radio, hover your mouse over the entry in the SmartSDR radio picker dialog:


    For the PC:

    If you are connected using WiFi:

    Select Start > Settings > Network & internet > Wi-Fi and then select the Wi-Fi network you're connected to.

    Under Properties, look for your IP address listed next to IPv4 address.


    If you are connected using an Ethernet cable:

    Select Start > Settings > Network & internet > Ethernet and then select the adapter you are using

    Under Properties, look for your IP address listed next to IPv4 address.


  • PaulB
    PaulB Member ✭✭
    edited April 5
    They are both on the same subnet. My main admin subnet that has no firewall restrictions. 10.93.10.x for both computer and radio.
  • PaulB
    PaulB Member ✭✭
    How can you run iperf without access to the back end of the radio?
  • PaulB
    PaulB Member ✭✭
    Also I should know that ping times are perfect. <1ms with zero packet loss from the client machine to the radio.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Ping is a good tool, but it doesn’t test all layers of communication. It is good for telling you there is a basic path or no path. It is sort of a go/no go tool.

    It sounds like something is dropping or throttling your Layer 2 streams.

    What I would do with iPerf is disconnect the radio and put some sort of computer at the end of the same cable and then do a client server test. It can be a PC, RPI or anything. Doing that helps to tell the story. iPerf (or jPerf) really help to stress the network. If you search back in the community you can find tests with graphs that I posted of 100mb networks that were barely moving 1kb/sec.

    BTW, WiFi is terrible for streaming applications where the data is time sensitive such as radio data. If you do setup iPerf, so some WiFi tests just for fun. You’ll be surprised how bad it is.

    And, if we rewind to the beginning we should do this test to show if it is a Radio or PC issue:

    • Ensure both the PC and radio are set to DHCP (no hard coded IPs)
    • Power off the radio
    • Power off the PC
    • Connects the PC to the Radio with a known good commercially built CAT5e cable or better.
    • Turn on both devices
    • After everything has all booted up, start SmartSDR on the PC
    • Try to operate the radio

    If it works as it should, you have a network issue someplace.

    If it fails it is the radio or the PC - Try a 2nd PC

    If it fails still while on the 2nd PC, the problem is the radio and follow up with a helpdesk ticket

    Now, could it be the Radio, not impossible but based on metrics we have all all support tickets, about 99% are related to the customers network environment. The easiest test is the one above and that is to move the radio to another very basic environment and test. That will be another clue.

    You still haven’t mentioned what the PC is doing at the time. What do the DPC tests look like? All this is helpful information to narrow down your issue.

    73

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    At the request of our support team, I have created support ticket for this.

  • PaulB
    PaulB Member ✭✭

    No need. Already had one and Ken helped me.

    Well the problem has been identified. Another device on the network had the same IP address.  

    Sorry for the trouble. But for your future diagnostics, you may want to put that in your bag of tricks of questions to ask. Have them run a network mapper. I had done a MAC Address reservation (because I think somewhere I read you guys like to keep DHCP enabled) because I like to map everything to a static (or run static from the device) so I can keep my network managed well, and its easy for diagnostics) and I had a virtual machine that wasn't being used that was running on that IP. So..in the end it was my network fault :)  

    Regarding the lockups, however, I still think it is buggy because it keeps trying to connect and creating multiple diaglog boxes and that slows down and could potentially crash a computer. If there is a confiict, it should give up and just have one halt function. 

    Thanks for the support..I'll go off in my corner and hide now.

  • PaulB
    PaulB Member ✭✭

    So if someone else makes a **** blunder like I have, it might be worth asking the question if there is a chance that they have another device with the same IP on the network. I know better than that, but it was staring me in the face the whole time and I didn’t see it because my IP tracker was off.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Glad you got it resolved. Eric's questions were headed down that path as well since the symptom is the same.

    The IP Stack management is actually handled by Windows, not SmartSDR.

    We actually watch the network reported issues pretty closely, and what we find, those that just let the router handle everything, no reservations and uPNP turned it, it really does work as it should.

    And, when it doesn't, just rebooting the radio and the router fix just above everything else.

    There is an option in most routers (at least those that let you look under the covers) to make sure that uPNP ports are cleared on Router reboot. Some routers do that, some don't.

    When we do have problems, they can be very similar to what you ran into and then we have to poke around for awhile (as you saw).

    Next time, I will ask... unplug the LAN cable from the radio and see if you can ping it. If you can, then that will show a duplicate IP address.

    Anyway, glad you figured it out. 73

  • PaulB
    PaulB Member ✭✭

    Haha...yeah sometimes the most obvious and simple problems are hardest to find. With my network experience you think I would have figured that out instantly, instead I wanted to blame the software...face palm. Thanks again for everyone racking my brain with all the potential problems.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.