Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FT8 Transmit Timeout/WSJT X Radio Connection

Jeff W7NEE
Jeff W7NEE Member ✭✭
edited April 2022 in Third-Party Software

This is a 2 part Question and issue!

1st Question- I have WSJT X/FT8 working with my Flex 6600. I am able to fully function WSJT X. If I have not transmitted for a bit of time (???) WSJT X will still key the radio but there will be no RF out! The only way to rectify this is to restart WSJT X. Once I restart the software all is back to normal. I have looked thru the setup both in SmartSDR and WSJT X. Am I missing something? Is there a timeout feature I have missed?

2nd Question- In setting up WSJT X I followed Mike's (VA3MW) setting up WSJT X youtube video.

Radio Rig Control

Rig - FlexRadio 6xxx, Network Server -, PTT Method-RTS and Com 9. I test CAT and PTT and all is good. I also have created in SmartSDR CAT a TCP port using Port 5003, Slice A, Auto-switch is Enabled. EVERYTHING works GREAT! HOWEVER when relaunching the WSJT X program it switches my settings on the WSJT end to - Ham Radio Deluxe, Network Server -, PTT Method CAT. Everything WORKS here Great as well.

I am just not understanding why this is switching. I have nothing setup in my SmartSDR CAT for Port 7831 or Ham Radio Deluxe. (I have in the past used Ham Radio Deluxe)

I thought that possibly my issue was using Slice Master to Launch WSJT X, but it does not matter whether I use Slice Master or just Launch WSJT X manually it still does this. Like I said all still works GREAT! Except my TX timeout issue (1st Question). These programs are also all working greatly with Log4OM logging software and Grid Tracker.

I have searched the community and did not locate any info on this topics... I hope I am not repeating something already posted!

Any suggestions or fixes would be appreciated!

Jeff Neely



  • Erika - KØDD
    Erika - KØDD Member ✭✭✭

    Its wsjtx after hitting the halt button. Hit tune quick and unkey the audio will come back. Mine does it every si often DD

  • Jeff W7NEE
    Jeff W7NEE Member ✭✭

    UPDATE: Just found my answer to my 2nd Question. The answer was in the Slice Master Documentation. SlicerMaster uses the Ham Radio Deluxe protocol for Rig Control. It is a normal thing to happen!

    Erika, I will try what you have suggested about using the tune button quickly to see if that will resolve my issue after using the Halt TX feature. Not sure I have used that every time this happens, so I will test it out!

  • Jeff W7NEE
    Jeff W7NEE Member ✭✭
    edited March 2022

    After more testing and trying the suggestions from Erika my problem is still there. If WSJT X sits idle for a little while it will not create RF. The PTT will work just fine, but no RF. Reboot WSJT X and we are back on line. Any other suggestions?

  • KT5N  Jeff
    KT5N Jeff Member ✭✭

    I am having the same problem. WSTJ-X keys the relay on my 6500, but no RF out. This started happening after the system sat idle for about an hour, but now it happens after sitting idle for as little as ten minutes. I also tried Erika's suggestion of nudging WSTJ-X by momentarily hitting the TUNE button on WSTJ-X, but it just keys the relays in the 6500 without any RF output. IF I shut down WSTJ-X and restart it, it works fine - for a while. Annoying, but such a first world problem to have!

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    If you get TX but no Audio to the radio, does SmartSDR DAX show Audio in the TX Stream?

    You might try turning the TX Stream Off and back On to see if it solves it.

  • Jeff W7NEE
    Jeff W7NEE Member ✭✭

    Thank you Mike! I have tried this and it makes no difference. It shows no signal in the stream even with the TX stream connected. I am still looking for the answer to this issue, mean while i am rebooting WSJT X multiple times a day when I loose my transmit stream. Any other suggestions anyone??

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Can you show your WSJTx Audio Settings?

  • Jeff W7NEE
    Jeff W7NEE Member ✭✭

    Not sure how to capture screen...


    Input- DAX Audio RX 1 (Flexradio Systems DAX Audio)

    Output- DAX Audio TX (FlexRadio Systems DAX TX)

    Save Directory

    Location: C;/Users/Jeff/AppData/Local/WSJT-X/save

    AzEl Directory: C;/Users/Jeff/AppData/Local/WSJT-X

    Remember Power setting is not enabled for either transmit or tune

  • John KB4DU
    John KB4DU Member ✭✭✭✭


    most recent versions of windoz include a snipping tool. Click in the snipping tool, select “ new”, use the mouse to select the area of the screen to save, save it, and drop it into the chat window here.

  • Brian_W9HLQ
    Brian_W9HLQ Member ✭✭

    I am having the same problem where WSJTX keys the rig but fails to send audio. In the next cycle, I will get audio and everything is fine. I get a failure once in 50 to 100 key-ups. Quickly hitting the tune twice, will clear the failure and I can complete the cycle. It seems to happen when I am most anxious to snag a DX station. Perhaps sitting idle as others had indicated is what is occurring. I look at the screen and see the DX and double click on the colored bar and the relays click but when I look up there is no RF.

    The system is Flex 6500, Windoze 10, and the latest version of WSJTx.

    Brian, W9HLQ

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    I have seen the same symptoms as your Brian. That happens is that the audio path between WSJTx and DAX fails for one cycle on TX. Then, it seems to re-establish.

    Is it a DAX issue? WSJTx issue? Who knows. I have some guesses but no facts to back it up at the minute.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.