Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

TGXL takes network down

Well... I did a power cycle of my gear and somehow in the process my TGXL (new in Dec 2021) now completely takes the network down whenever it is plugged into the switch and powered on.

Unfortunately I cannot be in front of the device due to my knee injury so I cannot see what the front panel display shows. But something is seriously wrong.

For now, I had a friend, unplug it and power it down. I will open a help desk ticket on it but probably not until next week as I cannot get to the device to trouble shoot it.

Mark WS7M


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin


    To debug this further, we are going to recommend trying this on a different switch and also trying a new CAT5E cable as they are part of the network.

    Also, we will need more of a description of what you mean by take down the network. What works? What doesn't?

    When this happens, is it just one other device that is failing? Does Ping work at all? Could it be a duplicate IP address? And, yes, we will need to know what the front panel shows.

    Also, we would want to know how your network is set up. Do you have any range extenders, bridges, etc.

    Have you tried updating the TGXL to the latest firmware which came out last week? V1.8?

    I know you feel that the root cause is the TGXL, but at the moment there are a few things that need to be reviewed and further isolation done.

    I would hate for you to send it back only to see that there is no trouble found and we can't recreate your problem which might incur a no trouble found charge.

  • Mark_WS7M
    Mark_WS7M Member ✭✭✭

    Hi Mike,

    It will be a short while before I can get down to the device due to my injury. But here are initial answers:

    1) The TGXL is on DHCP. It arrived in early/mid December and to get it in place before my operation I just installed it in DHCP mode and I did not do any DHCP reservation for it. It had been showing up at

    2) With the TGXL powered on and plugged into the switch, all other devices on that switch become unavailable. IE cameras, Flex Radio, etc all cannot be communicated with.

    3) Today we replaced the switch with a known good Netgear 16 switch and the same behavior was observed.

    4) With the new Netgear 16 switch in place, my friend began unplugging network cables. When the TGXL cable was disconnected all other devices on the network suddenly could be found.

    5) We tried a power cycle of the TGXL and when plugged into the switch the network went down. Unfortunately my friend did not make note of any display errors or messages so I cannot tell you want those are/were. When I can get down to the shed (probably a few days to a week) or I can get my friend over again we can look at the display.

    6) The TGXL was on 1.18 firmware as I've been working on a project with 4o3a directly.

    7) Prior to the problem no network changes have occurred to my knowledge. I know that switches and cables can fail so that is why I had my friend swap the switch. We also power cycles some other switches that were in the feed path to this switch.

    8) As of early this morning the TGXL was operating fine. I decided to power cycle all of the components using my remote control stuff and the problem occurred when everything was brought back up. Suddenly I could not access the Flex or PGXL or cameras.

    So I will need to get down there and debug things but I cannot do so for a few days or a week. I agree I'd like to try some debugging before sending it back for sure. Once I can get in front of it I will either communicate with you here or open help desk ticket. I also am in contact with 4o3a and they may have ideas as well. Either way I will keep you posted.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Hi Mark

    • With the TGXL in DHCP, then there should never be an IP address conflict.
    • Did you try a new cable? It seems that is the only thing left as you have changed out everything else. Possibly you did.

    Something is strange. I would open a support ticket for this when you are able to pursue it. Tim and Ken are great at debugging such things.

  • Mark_WS7M
    Mark_WS7M Member ✭✭✭

    Did not try a new cable yet. No chance. Again, I cannot get to the device due to my knee injury and my friend who helped did not have time for lots of troubleshooting.

    So two things I don't know:

    1) Will new cable help?

    2) What is on screen on the TGXL when it powers up? If it powers up normally but still kills the network then will try new cable. If there is nothing on display or some error message then that could be a h/w issue.

    I have seen network chips fry in devices and take network off line. This is acting like a data line is shorted to ground which would compromise the switch.

    But when I can I will debug and hopefully not need a help desk ticket but if so will not hesitate to open one.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Hi Mark

    I have 2 or 3 bad cables, one of them on a NAS device took down an entire switch as well. So, yes, a cable issue is possible.

    Does the switch fail if the unit is powered off? Did it every work?

    On the display, what is important is what the IP address is on the bottom left and the firmware version. If you could communicate with it, we would ask you to upgrade to v1.1.8 and see if the problem still happens. We want to know the IP address and we want to make sure that it matches your network.

    There could be a hardware issue with the NIC card or some sort of broadcast storm. Not very likely as we have never seen one, but not impossible.

    A high quality pro-sumer switch should partition the port and not allow a 'user' to take the entire switch down.

    This is an old screen shot that I have, but it should help with the data we need in the bottom left.

  • Mike Steventon
    Mike Steventon Member ✭✭✭

    Maybe try some of these?


    Or, I have read that someone had success with converting all his LAN cables to Fibre

    …..Just my 2 cents’ worth

    Good luck. Mike, G4GWH

  • Mark_WS7M
    Mark_WS7M Member ✭✭✭

    Hi Mike,

    The TGXL was on 1.1.8 but the version from 4o3a, not from flex. I suspect they are the same.

    Like I said I could not get down to the display to see it and because my friend was short on time I did not ask him to do extensive testing.

    I got my cast off so I'm hopeful that next week I can struggle downstairs to check on it.

    The switch is a cheap netgear switch. After this experience I'm probably going to invest in managed switches that can partition ports.

    When I can power it up I will take a pic of the front panel.

  • Mark_WS7M
    Mark_WS7M Member ✭✭✭

    Hi Mike, G4GWH,

    It does not appear to be an RFI issue. The switch/TGXL was working fine until a power reset, then it failed. But ya maybe those are a very good idea.

  • John K3MA
    John K3MA Member ✭✭

    Was there any resolution or cause associated with this issue?

    I ask because I recently installed a TGXL with SO2R and a AG2x8. I previously had the TGXL 1x3. I was updating and checking that my SmartiOS setup was working with the new equipment prior to going on a trip and while it was attached to the Flex 6600 on my LAN I noticed the panadapter on SmartiOS would freeze after a couple minutes. I disconnected SmartiOS and restarted without thinking much about it but then it did it again and I noticed that my main PC and other devices connected on the LAN were no longer connected to the internet. Thinking that my ORBI router might have just had a glitch I reboot it. Once it came up I started turning on the other devices only to find that they were again disconnected. After rebooting again and turning and confirming connection one device at a time I found that the TGXL was causing the Network to be taken down. When it would be powered up the splash screen would start and then other devices on the LAN would lose connection. When it did this the screen on the TGXL showed the startup splash screen and was frozen on this screen. The TGXL is setup to get its IP address via DHCP. In order to fix things I had to do a factory reset on the TGXL and then restart from scratch. I don't have the time right now to go thru a long process of trying this and then another thing to try to isolate the problem and that is why I am asking if this past issue was resolved.

    My next step will be to utilize the ipad while off the LAN and see if the problem reoccurs. If so then I know it will be localized to the ipad while on the LAN otherwise, it would have nothing to do with the LAN but rather something that has the LAN and WAN in common.

  • John K3MA
    John K3MA Member ✭✭

    Here is a screenshot of the TGXL utility screen after doing the factory reset and getting back online with SmartSDR on the PC.

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Hi John

    in TG XL setup, did you enter AG IP in the AG tab? In SO2R setup that is needed. That will allow TG XL to pull in AG configuration.


    Dave wo2x

  • John K3MA
    John K3MA Member ✭✭

    Dave, yes that was done and all was working as expected with SmartSDR on PC and SmartControl Mode. THe above situation happened when I tried to test out the SmartiOS on the iPad while on the LAN.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.