Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

How do I get N1MM+ to send F key messages to my 6600m?

Gfitch
Gfitch Member ✭✭
edited January 31 in Third-Party Software
How do I get N1MM+ to send F key messages to my 6600m? When hit an fkey it says cw port not configured even though I have configured one. Do I have download the Fkey function files? or.....?

Answers

  • Gfitch
    Gfitch Member ✭✭
    Mode is CW
  • Rich M5RIC
    Rich M5RIC Member ✭✭

    Make sure you have configured a corresponding port in Smart CAT including one for winkey if you are also using that.

  • Gfitch
    Gfitch Member ✭✭
    Thanks answer. I am not using winkey, but I did try that route as well, wih similar result: no joy.

    When I look at the "details" panel on the cat port I setup for CW, I think I have tried every combination of

    DTR and DTS that can be done. I have not been able to find any documentation of how those details

    should be set for CW. I must be doing something ****, but I can't figure out what it is.

    Any help will be very much appreciated!
  • Gfitch
    Gfitch Member ✭✭
    I probably should have clarified that I am having this problem while using N1MM+ for the K1USN SST contest.
  • Craig_KØCF
    Craig_KØCF Member ✭✭✭

    Keying for the Flex may be either with the WinKeyer emulator defined in SDR CAT as a virtual Com port, OR with an external WinKeyer, connected to either the "Key" jack on the back panel or via the Accessory connector. If you use the Key jack, disable the "Iambic" control and enable "Dot/Dash Swap" in the Phone/CW control panel in the Main Menu. With the WinKeyer connected to the radio via one of these jacks, connect the WinKeyer to the computer via its USB connector.

    I would suggest reviewing CW operation on pages 88-93 in the 6400/6600 User Guide, which includes connection info for the 3.5mm stereo plug for the "Key" jack.

    By far the easiest is to define a WinKeyer port in SDR CAT. Note the port number, then set the N1MM WinKeyer Com port to that port. The built-in emulator works nicely.

    Note: DTR and DTS cannot be used to key the Flex without a hardware interface, negating the advantages of the Flex architecture.

    73,, Craig KØCF

  • Gfitch
    Gfitch Member ✭✭
    Thanks, Craig. I am not having a problem keying the radio from my paddles. The problem is I cannot get N1MM+ to send F key messages to the radio. Any ideas?
  • Gfitch
    Gfitch Member ✭✭

    This is to Rich: I have configured one comport for the flex and a second one which I designate CW/other, using the configurer in N1MM+. When I examine CAT in the radio, it shows the Flex on the port I configured,

    and on the second port I configured for CW, it shows no process, AIR.

    But I still get the no CW port configured message from N1MM. If I redo it and change some of the details, I no longer get the no CW port defined, but then, hitting F1 in the N1MM+ entry window simply keys the radio which I then have to unkey by hitting the MOX button on the radio.

    I am totally buffaloed, Any ideas ?

  • Craig_KØCF
    Craig_KØCF Member ✭✭✭

    Yes. Make a new Comport in SDR CAT with protocol type "Winkeyer". You must do this to use the virtual Winkeyer in the Flex with N1MM. Note the "Client COM:" port that is assigned.

    Now, in N1MM, open the "Config" menu, select the first choice "Configure ports, Mode..." In the window that opens, the first port should be assigned to the Flex-6000 Series radio. In the second one (or next available) you select the port number noted in the previous paragraph. Radio should say "None". Select the check box in the "CW/Other" column in this row.

    That's it. Now N1MM will use the virtual Winkeyer in the Flex radio as the keyer. When you send a CW message it will go through this connection. Speed of the Winkeyer may be controlled as usual from the N1MM entry window.

    73, Craig KØCF

  • Gfitch
    Gfitch Member ✭✭

    Craig, thank you. I tried to follow your instructions, but in the first step, "make a new comport with protocol type winkeyer", there is no option to specify a protocol type, that I can see. I followed the rest of the instructions anyway, using the new comport I had configured per your instructions. You don't say whether I should push the " set" button after designating "CW/other", so I tried both not hitting the set button, then, exiting as well as hitting the "set" button, where there IS a checkbox for winkeyer, which I checked.

    None of these worked. FYI I am using version 3.2.39.3374 of the SDR software.

    Any idea why this didn't work?

  • Craig_KØCF
    Craig_KØCF Member ✭✭✭

    Yes, there is a selection for Protocol. Follow these steps to create (Add) a new port:

    When you open the SmartSDR CAT window on your computer, at the bottom left click "Add..." and the small window to the right will open. The first line, "Name:" lets you specify a name for this port to make it easy for you to identify it later; the second line is a drop-down labeled "Port Protocol". Click to drop down the list and select the "Winkeyer" choice. After this, you can either accept the proposed COM port # or select a number of your preference. There are no other choices to be made, so click "Save" or "OK" to complete the process to create this port. It should then appear on the list in the first window. On my computer, this is port COM10 at the bottom of the list...

    73, Craig KØCF

  • Gfitch
    Gfitch Member ✭✭

    Craig, thank you. I tried to follow your instructions, but in the first step, "make a new comport with protocol type winkeyer", there is no option to specify a protocol type, that I can see. I followed the rest of the instructions anyway, using the new comport I had configured per your instructions. You don't say whether I should push the " set" button after designating "CW/other", so I tried both not hitting the set button, then, exiting as well as hitting the "set" button, where there IS a checkbox for winkeyer, which I checked.

    None of these worked. FYI I am using version 3.2.39.3374 of the SDR software.

    Any idea why this didn't work?

  • Gfitch
    Gfitch Member ✭✭

    Craig, thanks once again. I missed that there was a drop down on type of port. I followed your instructions, but once again, no joy. I again got the "no CW port enabled" below the entry window in N1MM. So I tried creating a CW port using configurer, making a total of three ports: one for flex, one for Winkeyer , and one for CW, but again, no joy.

    I really appreciate your help, and if nothing else, I am learning a lot more about comports, but they are still very confusing to this 82 yr. old.

    If you have any more thoughts, I'm all ears, as you are the one who has gotten me the closest so far.

    If you are willing to continue, email or text might be easier if that would work for you. I'm good in QRZ.

    Another question: Could DAX be a part of this problem in any way? The DAX panel has a yellow button that says DAX not enabled, but if I push that it just grays out and says off. I apologize in advance for my ignorance.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
  • Gfitch
    Gfitch Member ✭✭

    No help. I don't want SO2R, and I don't want to setup the hardware Winkeyer, rather the emulator built in to


    flex 6600m

  • Craig_KØCF
    Craig_KØCF Member ✭✭✭

    Gordon, I sent you an email...

    73, Craig KØCF

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Even if you don't want SO2R the setup is the same, just don't activate the 2nd receiver in N1MM.

    If you want to use an external Winkey, you set that up in N1MM on its own Com port and then plug the output of that into the Keyer jack and turn off Iambic.

    The radio considers the keyer a straight key connection, not a set of paddles.

    Essentially, you set up your winkeyer like you wound for any other HF radio. This is critical.

  • Gfitch
    Gfitch Member ✭✭

    Thank you, Mike. I think I have it sorted now for the internal winkeyer emulation. Ken Wells was very helpful. Your instructions for the external winkeyer will be useful when I set that up (later).

    It would be good if more of this info could be included in the user manual. And maybe one of your excellent videos, but focused just on CW connection between N1MM+ and the Flex. Also, for a Flex neophyte like me, some explanation of comports, DAX (what it is and what setups it is required for , e.g. SSB, CW, digital etx. Then a separate one focused on SSB only, then on Digital only, etc.

    For someone new to the whole Flex world, a lot of this is new, confusing and intimidating. I'm sure most of the Flex community is far more knowledgable than I, but there must be others like me wondering around in the Flex wilderness as well.

    Gordon, N0AB

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.