Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Com Ports Missing yet again

James Del Principe
James Del Principe Member ✭✭
edited January 2022 in SmartSDR for Windows

I have had issues with com ports in the past and using Tim's procedures, I managed to resolve them. This time, however, I can't seem to fix them.

This morning my Windows 10 computer failed to turn on. it seemed dead. Unplugging and replugging power corrected that. the green pwr supply came on and it booted normally. SSDR works fine. However, all my comports were corrupted. This time I cannot resolve it.

I first right clicked 'remove' in CAT and reset Flex VSP Ports. All the ports were then gone from CAT. I used Tim's procedure to remove ports from Windows and ran Tim's "Resetting the CAT.settings file. I removed the Cat.settings file. I also rebooted after every action. CAT came up with COM4 and Port 5002 as expected. However, I cannot add ports nor save or edit Port 4. I get the message "The virtual serial port (VSP) failed to create. Double check the serial port settings".

I have tried this at least six times now, removing ports in Windows, removing the CAT.settings file. I cannot get CAT to properly create com ports. Even the Flex Control knob is not working. I tried looking at 'log' for com4 and it is blank. In Windows Dev mgr, only com port 3 shows up.

Second question, Under "other devices", Fabula_Tech_VirtualPort 3, 5, 6, 103, 105 and 106 are present. What are these for? Previously, this Fabula showed up as port 3 under ports when all was working well.

Sorry this is so long. I am at wits end. Many Thanks, Jim KD1I


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    @James Del Principe

    Sorry to hear about this. We have had a few people report similar experiences, some of them friends of mine.

    The answer you don't want to hear is that rebuilding your computer and reinstalling Windows, seems to resolve it. We have not found a root cause as to why other than something that Windows is doing in a cleanup.

    I wish I had a better answer, but this one seems to work.

  • VE3HG
    VE3HG Member
    Hi Jim: I had the same issues and went through the same fixes including having Tim redo my audio ports remotely. Over the months I got real good at doing a factory reboot and then importing my profiles from the computer. That wasn't the most elegant solution (and I didn't want to leave the computer and Flex 6600 on 100% of the time although that works too) so I started thinking about was my issue with the Flex or with the computer? To complicate matters I use a KX-2 occasionally and it takes port 4 sometimes with some effort but using the Elecraft utility I can get it to work. Then of course going back to the Flex startup often failed and I do a factory restart again. I got curious and had a look using device manager at my ports and there were a lot of them. And then I got thinking since the Flex is an IP radio it should fire up without the computer being on. Now I am not a computer nerd but I like to think of myself as a practical guy so I turned off the computer and I did another factory reset on the rig and then turned off the Flex. Then with the computer not on I let the Flex sit for a minute or so then turned on the 12-v power supply and let it sit for a minute (an abundance of caution) and then I hit the on button and sure enough the rig fired up a minute or so later. Okay it appears there's nothing wrong with the rig (and yes I had the new micro-SD card installed). So I went back to the computer which is an I7 PC tower with 16-gigs of RAM that's got to be getting on to 10 years old and this time I did a hard reinstall of Windows 10 (this computer won't upgrade to Windows 11). I did a complete install and that cleared up the multiple audio ports of course and the computer seems to have returned to acting like new but best of all the Flex fires up nearly 100% of the time without issue and the port assignments are holding and I've only got a handful of them. I can't prove this but I have a suspicion that some PCs don't work well with the Flex. I can't prove that but the majority of guys don't seem to have this failure to start issue and the proliferation of audio ports so I am assuming not all computer / Flex setups are not the same. After doing a hard reinstall of Windows 10 my Flex start up is close to 100% okay. Also the Flex restart without the computer appears so far to be 100%. One more major issue and it's going to be new computer time here as my 6600 is by far the best rig I've ever used. Hope this helps.
  • Thank you both for your replies. I just now tried a factory reset. I again checked the ports and deleted them along with the CAT.settings file. rebooted all and same thing, Com4 and port 5002 are present but I cannot create new ports and com 4 does not respond. Can't edit or save it.

    When you did a "hard reinstall" of Windows 10, did you first delete anything or did you install Windows 10 over your existing OS? And did that wipe out all your other apps? If so, that would be a very big job. I suppose I should have written down all my config settings for those other apps in one place, not to mention all those DVDs for some applications and the missing data for them like all the EZNEC antenna files.

    In the past, I was able to at lease restore the com ports after a bit of work. This time seems impossible. I do not have a startup issue any longer since going to rel 3.2.39. However, CAT takes a very long time to launch. It worked for years OK on this Win 10 computer. If some computers won't work well then a replacement might also not work.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Hi Jim

    There should be no need to factory reset the radio for this, and as you are finding out, it isn't really helping since you still have the same issue.

    I'll let Peter answer your questions.


  • Mike, you are correct. I did a factory reset and it did not help. Live and learn. Can I just go to the Microsoft site and download Windows 10? Any advice on this?

    Also, "Under "other devices", Fabula_Tech_VirtualPort 3, 5, 6, 103, 105 and 106 are present. What are these for? Previously, this Fabula showed up as port 3 under ports when all was working well."

    Are these Fabula devices related to SSDR?

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    I am a bit fuzzy on those devices, but I believe they are the core device driver for SmartSDR CAT.

    As for a Windows rebuild, if you bought a computer with Windows already installed on it, there will be a procedure to rebuild it from scratch. It will be in the documentation that came with the computer.

  • Thanks, Mike. I bought this computer long ago but don't remember any documentation coming with it or any other computer I had purchased. Honestly, do computers or any modern devices come with documentation? Everything is on line these days just like my favorite radio..... must be downloaded.

    In a moment, I am going to try my laptop that I use for remote operation all the way from my kitchen. If it works then the issue is really with the computer in my downstairs shack.

    Thanks again, Jim

  • OK, I fired up SSDR, Winlink and FLDIGI on my laptop. It worked fine. All CAT ports were present and the frequency of each app tracked with the Flex. So the VSP com ports are not corrupted on the laptop. To my knowledge, they have never failed on this laptop.

    An important question for you. Is it worth reloading SSDR and DAX and CAT ? Might this get me back on?

    Restoring all those other programs is a monumental effort. Best 73, Jim

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    I can't reliably answer that and give you a 100% for sure answer as we have watched Windows do all sorts of things.

    It may be Antivirus Software as well as we have not found the root cause as to why this happens.

  • Thanks again, Mike. Both computers run Windows Defender. They have never complained about any threats.

    Tonight, I will slick off and reload SSDR, DAX and CAT. Will report back 73, Jim

  • Well, I removed SSDR, DAX and CAT using Windows add/remove. Rebooted and downloaded 3.2.39.

    With the 6500 off, I downloaded and installed the SW. Then I switched on the Flex, confirmed it was working and rebooted both Flex and PC just for good measure. SSDR connected right away as did both DAX and CAT. Note: CAT had previously always been slow to boot up. This time it booted almost as fast as DAX.

    I was able to configure a com port for each of my apps, using the same port numbers. It came up with Port4 and com 5002 as it should. So all is working for now.

    I will figure a method to accurately back up my computer such as a cloud drive but this leaves me with a thought. I have MMSSTV, VARA, REA Mod Monitor, Logger32, TQSL, nano-saver, SWR plotter, SDR Monitor, FLDIGI, digi-Pan, RSP-SAS Spectrum ****, SDR Console, SDR Uno, Winlink Express, G4FON Trainer, EZNEC 6.0, Acrobat, MS Word and many more programs on this computer. Windows has NEVER corrupted them with updates. They just keep working. So when SmartSDR Cat gets corrupted, why do we blame Windows 10 ?

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.