Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartLink works perfectly for over two years, but now cannot connect

Given: Flex 6400, purchased summer 2019 and SmartLink'ed. Used regularly for CW, SSB, FT8, most of the time using a Maestro as the front end. Running 3.2.39. I have remote power on/off capability.

I'm currently remote and the connection to the radio fails. Here's the symptoms. It was working one day and just stopped working.
1) I see my radio in the "Select Radio" list on the Maestro
2) I select it and hit the "Connect" button
3) I select "v3.2.39" and hit the "Run" button
4) "Loading"
5) Meters show up, but no
5) "Client connected from IP" with my IP
6) "Radio disconnected. Waiting for radio/network." with countdown
7) I get another "Select Radio" list, this time without the radio I want.
8) After a minute or so, the radio shows up again.

Other clues:
1) There is another radio in my "Select Radio" list that belongs to a friend. I can connect successfully to it.
2) When on the "Select Radio" panel with my radio selected, there is no "Disconnect" button. When I select my friend's radio, I do see the "Disconnect" button.
3) When on the "Select Radio" panel with my radio selected, the "Info" button does not include the line that includes TCP Port and UDP Port. If I have my friend's radio selected, the "Info" button does include TCP Port and UDP Port.

What I've tried:
1) Power down, unplug supply, reapply supply, power up.
2) Restart cable modem.

I'm 1000 miles away from my radio and would really like to get it back on the air. I do have a willing non-ham that has access to the shack and network. Anybody have any suggestions?
Tagged:

Comments

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Do you have a PC at radio site you can remote into (should be a requirement for serious, permanent remote operation.

    Sounds to me like a network issue that has changed the TCP and UDP port forwarding. Either IP of the radio changed or router changed. Another possibility is your ISP changed to carrier grade NAT, meaning your router does not have its own public IP address.

    If you do have access to a PC on the radio network it should be easy to check.

    73

    Dave wo2x

  • WX7Y
    WX7Y Eastern Utah, USAMember ✭✭✭

    This hasn't happened here for a while but I have had to Re-resister the radio itself on SmartLink, this also requires someone to hit the CW Key or PTT on at Radio.

    This is why I have a VPN running and extra remote relay contact connected to my PTT line at the radio so I can re-register SmartLink .

  • Greg W8XY
    Greg W8XY Member
    Thanks Dave and Bret. Yes, I have a PC there with RDP enabled, but for some reason that is not working either. I'm betting that the two issues are related. I'll have my neighbor (who also happens to be my son) go over and walk him through some tests and either rework the port forwarding or just re-register SmartLink.
  • Greg W8XY
    Greg W8XY Member
    Good news -
    Rebooted the PC at the remote end. Looked up the TCP and UDP port forwarding settings that were in the router. Used these values to reconfigure the SmartLink config. Works!

    Don't know why I lost the settings. Hmmmm.

    Thanks again for the advice and encouragement. 73.
  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Glad you got it working and had someone local to the radio available to reset the PC.

    73

    Dave wo2x

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    For others reading this, this is a great video to help you debug such things.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.