Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

DAX TX will not enable v. 3.2.39

Running version 3.2.39 with Flex 6400M. Everything has been working fine for months, but when I fired up the rig this weekend DAX shows the TX Stream as either "off" or "yellow" but will not toggle to blue. Of course this means that I cannot transmit using WSJT. I have tried the DAX button in SDR, and tried enabling both "1" and "2" but neither will get me to an enabled DAX. Can someone help me out? Everything else seems to be working fine.

Answers

  • jlyonmn
    jlyonmn Member ✭✭
    I had a similar experience with my 6500. One day, None of my virtual com ports would work. I solved the problem, for the time being at least, by deleting and re-adding the virtual com ports in Windows device manager. I don't know why this happened, but the fix worked for me. Good luck!
  • WX7Y
    WX7Y Member ✭✭✭
    edited December 2021

    I Backup my DAX and CAT setting files, do this "AT YOUR OWN RISK" A bit of Windows knowledge of Windows Explorer operation is required for this.

    To get started make a Directory say on your Desktop named "Flex Files Backup", Doesn't really matter what you name it.

    Next you need to make sure you can see your hidden System Files, Using Windows Explorer by clicking on View and enable the "Hidden Items" box in order to see all the files you need to find in the next step. 

    Then on your windows hard drive which is usually drive (C:) go to the following directory "Users" then find and click on YOUR "UsernName" then click on the "AppData" Directory and then click on the "Roaming" Directory then "FlexRadio Systems" Directory and then copy the "CAT.Settings" and the "DAX.Settings" files to the Directory you previously made on your Desktop.

    NOW to re-secure your computer, from your root C: drive be sure to click on "View" again and turn off the "View System Files" option, then the next time something corrupts those files you can re-run the procedure and copy your backup files of the CAT.Settings and DAX.Settings files to there original locations.

    AGAIN DO THIS AT YOUR OWN RISK, This works on all versions of Windows Pro I have used including Windows 11, If you delete the wrong files you can crater your windows or other software programs.

    This method ALSO works for moving to a new computer but you FIRST need to load SmartSDR of the same version as these files came from to reduce chance of corruption.

    If you upgrade to another version of SmartSDR I would recommend you re-copy the NEW CAT.Settings and DAX.Settings Files that are built by the new version as they may be different format.

  • Roger_W6VZV
    Roger_W6VZV Member ✭✭

    Is there any way to deal with this problem without delving into the innards of Windows? I am completely **** right now. SDR transmits a carrier using Tune or XMIT just fine. But DAX will not turn on. It's maddening.

  • jlyonmn
    jlyonmn Member ✭✭
    Well, if you don't want to delve into the innards of Windows, I think if you uninstalled SmartSDR and its components and then re-installed SmartSDR, it should fix your problem. I'm not sure, but I think doing this would create a double set of virtual com ports (it wouldn't delete the ones that aren't working for you now).
  • WX7Y
    WX7Y Member ✭✭✭

    using the Uninstall routine will do little to fix your issue unless you go much deeper into Windows you have to delete a bunch of stuff manually.

    The best thing is to do a Trouble ticket and get FLEX to have a look at it if your not up on Windows stuff.

  • Roger_W6VZV
    Roger_W6VZV Member ✭✭

    Yes, I have tried uninstalling and reinstalling SDR. Put me right back where I was before. This is truly maddening. Guess I'll have to open my first ever trouble ticket.

  • Roger_W6VZV
    Roger_W6VZV Member ✭✭

    OK, I uninstalled and reinstalled SDR, and then went through every single step of installing WSJT-X, configuring CAT and DAX, etc. Got it to work. I have no idea what happened or how I fixed it (I am embarrassed to say). Oh well, at least it was a good refresher on how to set up CAT and DAX (and WSJT-X). Thanks to all who responded to this hapless thread of mine.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Next Roger, post some screen shots. Often it is a setting that is wrong. It saves the pain of doing an uninstall/reinstall.

    Mike

  • va7qi
    va7qi Member ✭✭

    Well, I have a similar problem. I re-installed the entire SmartSDR suite and got my receive audio working, but the TX button is grey. Windows (11) seems to think there is output on the DAX TX device, but DAX seems to think otherwise.

    Settings have not changed other than it is a different 6600M since the old one has gone back to the factory.

    I am using DAX v. 3.2.39.3374 and Windows 11 Home. The DAX TX device is enabled and shows 50% audio level. I can key the transmitter and WSJT-X will also key the tx, but no audio goes out, of course.

    73 de va7qi, ....Erik.

  • Alan
    Alan Member ✭✭✭

    Erik

    Check that your TX DAX is on.

    Alan. WA9WUD


  • va7qi
    va7qi Member ✭✭

    Yes, DAX is on and I am receiving OK. This is a 6600M, so I am not using SmartSDR.

    I tried uninstalling SmartSDR completely, deleted the Flex directory under AppData, re-installed SmartSDR and re-booted Windows. No joy. The TX button in DAX is still grey.

    It is likely something that can be set in Windows. The question is what?

    73 de va7qi, ....Erik.

  • va7qi
    va7qi Member ✭✭

    So I set up another Windows computer (this one 10 Home) and configured it to look at Slice B. I then enabled TX on that slice and tried to enable TX on DAX. Same issue. I can receive, but no TX on either computer.

    This is a new radio replacing one that had a faulty display. I used the saved profile from the returned radio, but have also tried the default profile.

    I'm back thinking it is the radio.

    73 de va7qi, ....Erik.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Erik

    Screen shot please of SmartSDR and SmartSDR DAX.

    M

  • Alan
    Alan Member ✭✭✭

    Erik

    Below is a screenshot showing the TX (transmit) DAX on my Maestro. Push the TX button (center, far right) to get this page.

    Just checking to be sure. You refer to selecting the DAX on the slice.....? That would be the RX (receive) DAX. Since you cannot see an RF out when you transmit from WSJT-X, that would indicate your TX (transmit) DAX is not enable on the Flex Radio Page.

    Alan. WA9WUD


  • va7qi
    va7qi Member ✭✭

    Hi Alan,

    Again, this is a 6600M. I do not have a Maestro and the screen on the 6600M is a little different.

    Anyway, the issue is solved. I started SmartSDR to see if it could enable TX. It did. I closed down SmartSDR and started CAT and DAX. Now it works.

    Conclusion: the interface on the 6600M is not as independent as one would expect. You need to fire up the full SmartSDR to kickstart things. A bug fix or documentation upgrade may be in order.

    Thanks for all the suggestions. I am back on the air.

    73 de va7qi, ....Erik.

  • Alan
    Alan Member ✭✭✭

    Erik

    Here is a link to download the Flex 6600M manual.

    Here is a screenshot of section 37.6, "TX Menu" from the Flex 6600M Manual, with the TX DAX button circled.

    There are no "bugs" in the 6600M software. You do not need to run Smart SDR to deploy TX DAX.

    Alan. WA9WUD


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.