Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6600M loses login and SmartLink

AC8XO_Vin Member
edited December 2021 in Networking
This seems like a familiar topic that I don't see a real conclusive solution.
1. More often than I like, the 6600M requires me to re-login and reconnect to SmartLink
2. More than once I have to cycle power for the 6600M to realize that there is in fact an internet connection.
3. From CAT or DAX I see a complaint of no Internet... the internet is NOT DOWN!
4 on the 6600M it says I have an Ethernet Connection but no Internet, Again the internet is NOT DOWN!
I've set up as automatic port forwarding - doesn't improve things. It's set up now as Manual port forwarding, seems to behave a bit better.

If I am on the road, and this happens, I can't get back on the air. I can use Team Viewer to talk to my connected desktop, But how do I login to the 6600M screen when I am physically not present!

Is there anyway to have a keyboard connected to the 6600M, the touch screen doesn't thrill me one bit!


Vince AC8XO :(


  • Ted  VE3TRQ
    Ted VE3TRQ Member ✭✭✭
    edited December 2021

    [Edited for spelling error / typo]

    I had some cases of the 6600M mysteriously disconnecting, leaving my digital apps, xDax and xCat (on a Mac, yes) complaining about a lost connection - radio was up, Mac was functioning fine with other running programs. This usually happened while I was not present, i.e. away from the house, or elsewhere in the house. Happened to be right there one day when it happened, and I could see zero problems reported on the radio or digital apps other than the network "went away"!

    On spec, I replaced a cheap Ethernet switch I had been using (don't even remember what it was, other than it was not a Netgear switch. I replace the switch with a Netgear ProSafe smart switch I happened to have on hand, and "Presto" - no more disconnects.

    It may not be so in your case, Vince, but in mine it was a defective or inadequate Ethernet switch. Streaming audio for DAX has higher demands than "normal" inexpensive, retail Ethernet switches are designed for. Try looking at your Ethernet hardware. Of course your hardware may be just fine and your problem is entirely different, but this is once place to look.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin


    This shouldn't happen and we need more details to figure out how to fix it. Odds are, it isn't the radio, but possible the router.

    In order to make sure, we need more details. When it fails is there any chance you can review the settings in your router to make sure that the port forwarding paths are still correct?

    As long as the router has not changed any rules, you should be able to run years without having to reboot the radio or the router.

    Also, you do not need to touch the screen after a power cycle to connect to the radio, ever. In fact, if the screen failed for some reason, the radio will still be available to use on the Ethernet or via Smartlink. I hope that helps clear up how the radio functions. In fact, we have 6600M's out there with the display totally unplugged and they work fine even after a power cycle.


  • This may bounce around a bit and I tend to ramble...

    I guess there's 2 logins here, the radio and SmartLink.

    First not a new issue. At least for me. But reading other posts led me to believe there was some SmartLink connection issue elsewhere. Note, I don't read all the posts cover to cover. TLDR syndrome.

    Prior to this weeks' incidents, I was running remote while traveling for about 2 weeks, off and on. I did have to remotely cycle the radio once to get it back on. On the iPad it showed no available radios, until after I performed a remote power cycle. Since I was away from the shack, I couldn't touch the radio.

    I've had to login to SmartLink twice this week and once to the radio itself. No storms or other weather anomalies in the neighborhood.

    At first I started to login to SmartLink on the 6600M screen, but stopped and then I tried to connect from the PC. I could run the radio from the PC, but SmartLink was not working. I was going to attempt to login from the PC to SmartLink and leave the radio alone, But as far as I can remember, things were't happy until I logged into SmartLink via the 6600M. The lower right corner showed my call AC8XO and my VB, initials.

    What I noticed on Tuesday was that I had to verify that the port forwarding settings on the router were still correct, and they were. I had to verify them because the PC showed manual, but -1 in both fields related to port forwarding. As soon as I set them to the correct values the PC worked. I still had to re-login to the radio on the front panel. I don't understand the -1 issue.

    Then again today, it was lost again. But this time was different. On the M there was an error indicator, I have never seen that before. When I got the touch area to respond I saw the message Ethernet but no Internet, I was surprised since I never noticed the flag indicator in the lower left corner. Also, the information on the lower right side was not present and it indicated Log In and no initials. When I tried to get going I was prompted to key the mic. I didn't expect that. I tried to login on the M screen again, which was still unsuccessful until I cycled the radio all the way to the power supply. I verified the router again today.

    It's not a new issue, I just lived with it. I wasn't traveling and if I couldn't get in I would go down to the basement and restart the radio. It was annoying, but not a show stopper, I was home and about 600' away. Of course I usually connected directly not through SmartLink but there were many times when things would not operate as expected.

    As far as I can recall, every time I have connection issues, I have to reboot the radio, all the way, or re-login to SmartLink on the radio. Or both. SmartLink will say that the there is no Internet, the test will fail. DAX or CAT will say that the radio is not online or connected. I can't remember the actual text. After a bit of coaxing I can get things back online.

    I really don't expect to be required to re-login, but SmartLink does. There was one instance where I went to the SmartLink Setup and had a blank screen with a Close button in the upper left. Reboot - fixed.

    The router is an Orbi with 2 mesh nodes. I had previously used a older style Netgear router with "repeaters" for remote connections. The switch to the Orbi was made because of the size of the house, it's a ranch and WiFi was hit and miss with the standard Netgear router.

    The rig is connected via wired Ethernet via 2 gigabit switches.

    When it happens I can collect as much data as necessary. I will begin to take better notes.

    I am one of those "propagation Hams" that you guys talk about on the podcast. So, I am not on the radio every day, sometimes I go for a week or 2 without operating. The only reason I saw the issue this week is that I was working on other stuff in my electronics shop.

    Let me know what specific things you would like to see collected from the radio or the router. So far I know that the router still has the right stuff in port forwarding. Trying to send image but I don't know if it's working.

    Mike, can you clarify... If the SmartLink connection is lost for whatever reason, and I can remotely connect to the PC next to it, can I get the connections reestablished without touching the 6600M screen? Did recycling power accomplish the same thing?

    Sorry for the length.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    There is only 1 Login. 1 for SmartLink. The radio does not require a login, so I am not sure where you are logging into the radio. On the initial setup, yes, you login in beside the radio as a security measure. It is a one time thing.

    There are communications issues that can cause you to login into SmartLink again from the Client software. I see this from time to time. It is pretty simple to log in again since you don't need to be at the radio to do it. You do it from the Maestro or PC you are operating from.

    When the radio fails to communicate, it is often (99% of the time) an issue with the router and using the 2 port forwards do not match up with the location of the radio. The next time it fails, you want to check and make sure the Router port forwards are correct and are referencing the IP address of the radio.

    When CAT or DAX can't see or hear the radio on the ethernet, something on the ethernet is blocking or slowing down the communication from the radio. I have no experience with your type of Mesh but if it was my network, I would make sure that all devices are on the same subnet and that the Mesh was in a bridge mode to make sure all devices hear information from all devices. Your Mesh may be limiting traffic (Layer 2 broadcasts) from the radio and they are not making it from the radio end to the user end.

    What you are doing is not so plug and play and may require the help of someone with good network experience and who understands the different communications layers to sort this out. While a Mesh is good enough for web surfing, it is harder to make work correctly when you have installed a 'Server-the radio' at the far end. You are trying to get the radio traffic to move uphill which is about the best explanation I can think of.


  • 1. Here's the network layout: CABLE Modem -> ORBI Router -> Emerson ES1016G Gigabit Switch -> TP Link TLSG1016D Gigabit Switch -> Flex 6600M AND -> local Windows PC.

    2. IP addresses for Flex and the Local Radio PC are "reserved", so that they obtain the same IP address each time.

    3. As posted in the image file before Port Forwarding - TCP 21000 <> 4994 and UDP 22000 <> 4993; both show IP address of the Flex

    4. ORBI Mesh and/or wireless is NOT involved in any communication to the Flex - so just ignore this part of the configuration. Unless the router has some idiotic need to route traffic around the house for the heck of it! All nodes are on the same subnet.

    I will start to log any further incidents and report back what happened. I have checked several times in the last 24 hours, just to make sure that nothing has changed. If I see any other strange items on the 6600M screen I will screen capture them.

    The internet is perfect until it's not. So, if the Flex can't phone home, i.e. SmartLink can't talk to the server, but I can still hit (ping) random sites on the internet like, Google, Github, MSN etc., I don't see how this is an internal issue (my network) if nothing else has changed (port forward, IP).

    As for the login, I guess I misunderstood or otherwise got confused. On page 44 of the manual I see that the lower right LOG IN button takes you to the SmartLink login.

    If the SmartLink connection drops out, who cares why, I should be able to login via CAT/DAX on the locally connected PC. Which is also on the wired network side.

    Unless I actively UNREGISTER from SmartLink there is no reason for me to have to RE-REGISTER again. Meaning that a network gremlin (glitch) cannot kick me out accidentally. Which also means I should never have to KEY the mic locally at any time in the future.

    Generally when these things happen I have to reboot/power cycle the radio to get it to recognize or connect to the internal Ethernet network. I didn't think that this would be considered normal.

    I will keep track and record the incident and my actions.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    I think what you are seeing is the Token expiring for some reason.

    Some weeks I have to login in several times and sometimes I am good for weeks. I do know I always have to log in after some soft-out internet outage all the time (on the remote client side, not the radio side).

    I still do not understand why you are logging into SmartLink on a local connection. You can totally log out of SmartLink and the radio will still work on a local Lan connection. SmartLink and Local LAN/Radio connections are not related at all.

    And, yes, there is no need to register ever again unless you log out. My 6600 has been logged into SmartLink for years without registering.

    It sounds like you have a lot of things going on. First, I want you to watch this video I have on youtube (even if it is painful). https://youtu.be/rmkejJWIQpc. It goes over how Smartlink works.

    On a Local LAN connection with the radio and the client on the same subnet, Smartlink is never ever required to function. If you can't see the radio on a local LAN, then something is limiting the layer 2 broadcasts. You may want to check and see if any router/switch has Green ethernet ports and disable this power-saving feature.

    If you can't see the radio from the Client's computer, can you ping the radio from the client's computer? Can you ping yourself? Can you ping the client's computer from another computer? Is something connected to the switch cause a port failure? Look at the lights.

    I took down my entire network on Friday when I plugged in a piece of NAS storage I hadn't used for months and went to lunch. I came back to a dead network in my ham shack. Turns out the NAS storage flapping so badly it dragged down a 1G network switch. I unplugged the NAS device and all was good.

    On a remote connection, SmartLink is required and you do need to (once) log into SmartLink and do the PTT registration. This is a once time thing unless you log out of SmartLink which is something you do from the radio chooser (Chapter 9 of the SmartSDR manual). That should take care of the Radio side ... forever.

    Next, to the client-side:

    The Client on a Local LAN/Subnet to the radio never needs SmartLink as it can hear the radio broadcast on the local subnet. If it doesn't then something (switch?) is blocking those Layer 2 broadcasts.

    When operating remote, if you don't see the radio on the Radio chooser, then something blocked the radio calling home to report its WAN (router side-address) and the 2 ports to use. In your case it is port 21000 and 22000. Is it the Router or the ISP? Who knows. Hard to tell.

    If you 100% confirmed that the Port Forwards are pointing to the radio IP address, then odds are, it isn't the router, so that leaves the ISP somehow.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.