Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartLink Connection Problem

Before submitting a ticket I thought I would ask the question here first.

Maybe I'm missing something, but I think this is very strange.

First background: I have 2 (TWO) ISP (actually WISP) providers at my remote. Each internet connection has it's own dedicated router. One router is on gateway 1, the other on gateway 2. This way I can switch any device to the other internet provider (WAN) but just changing the gateway in the iPv4 network adapter interface. (ie. either, or Yes, all my devices at the remote are set with static IPs for this reason. Except of course the FLEX which needs DHCP. This has never been a problem, because ONE of the two routers will be set to DHCP, the other toggled off. (This LAN system is VERY helpful at the remote, because even if I lose one ISP, I can switch any device I want over to the other ISP, but everything all remains on the same LAN)

This has worked fine in the past. If I want the FLEX on the "other" ISP, I just turn the DHCP on for the ISP I want, and turn DHCP off in the other. Check the assigned IP addy, and make sure the port forwards are good in the router GUI and everything works great.

Except today.

FLEX is working fine on ISP 1, but maybe a a few small dropouts, so I decide to try ISP 2. As described above, I switch the DHCP servers, check the assigned IP addy and confirm all port forwards are ok. But here is the VERY strange thing:

With the new ISP connection, I can see the radio over the WAN at home. When I hover over the "RADIO" the pop-up window shows the correct new ISP WAN addy, (ie, the radio is now on the new ISP) and shows that the UDP and TCP ports are forwarded. So it looks like everything switched ok. But it wont connect. It just locks up, and times out. Back at the remote station, I do a Smartlink TEST connection on the LAN, and it fails. I always manual set my port forwards and triple checked them, but Auto connect fails also. I switch the DHCP serves back, check the forwards, everything works on the "old" ISP and I can connect from home.

So...what is going on? I get a failed SmartLink test, but I can still "SEE" the radio at home, showing the correct ISP IP addy, but won't connect?? Obviously the radio is connected somehow, or else I wouldn't see it!

Any ideas anyone?

Steve, ve6wz


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin


    When it fails does the radio get the new Gateway address? What is the Lease time on your DHCP assignments as defined in your DHCP Servers?

    Did you reboot the radio as well so that it gets the new DHCP assignment? If the radio has the wrong gateway then it can't communicate with the outside world.

    Also, I assume you have matching port forwards in each router or are you using uPNP?

    Normally, for a solution like this, the Router is dynamic enough to handle the switch over to a 2nd ISP (pfsense can do this). That way the Gateway addresses never change and the router handles the routing correctly.

    As you are finding, running dual ISPs for failover does require some unique customization.


  • VE6WZ
    VE6WZ Member ✭✭

    Hi Mike,

    Thanks for the reply.

    Well you see that’s the strange thing, the radio IS communicating with the outside world! And it is on the correct gateway because the WAN IP addy is correct. After I switch DHCPs, when I open Smartlink at home, the connect button is green when I hover the mouse over the radio icon in the GUI it shows the NEW (changed) IP addy and shows the port forwards. But, the radio won’t connect. And as I said, the Smartlink test fails at the remote. I have rebooted the routers, rebooted the Flex (even done a hard restart because I can do that) and restart Smartlink at home.

    it almost seems like the Flex server is confused?

    I don’t think my setup is a dual ISP failover setup. I just have two independent ISPs and each on their own router. I can simply decide which device uses which ISP du changing the gateway. This lets me share the bandwidth as I desire. Usually the Flex gets all the bandwidth on one ISP.

    For the moment, if I put all this dual ISP stuff aside, the fact is I can’t connect to the radio on one ISP. But I can on the other if I switch it back.


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    It may be an issue with the SmartLink server that keeps track of your WAN address, but I am only guessing. I do not know what the TTL is on a WAN address change is. It may also be some smart switch routing in your own LAN (again, just a guess). It may also be confused if that is even possible.

    At this point, you may want to open a support ticket to have it properly tracked. Tim is the one that may have to work with you on collecting the data (screen shots and log files are greatly appreciated) but he is off on vacation for a week.

    No, your setup isn't a dual ISP failover, but you may consider configuring it as such.

    If you are only failing on 1 ISP, then you need to debug that path first. I gather you are saying that it has never worked correctly? If it was me, I would focus on that and make sure it can function. This is when running WireShark in your router might help to tell the entire story.

  • VE6WZ
    VE6WZ Member ✭✭

    Hi Mike,

    oh no, I have had this setup for three years and it has worked flawlessly for Flex ISP switchover as I describe. I first noticed this problem about 2 months ago, but ignored it because the ISP I’m on now is working ok. But, I want to be able to switch as desired like I used too.

    I’m not really sure I want a failover Mike. The setup I let’s ME choose how to distribute my bandwidth as desired.

    To be clear I have NO trouble switching any of the PCs or other devices back and forth between ISPs. In fact, it seems the Flex is actually switching onto the new ISP addy and I can see it at home…but something is goofy!!!


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.