Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR CAT Does Not Display After Launch

w1smc Member ✭✭

I launched SmartSDR Cat 3.2.39 for the first time and the program window was displayed on my desktop. However, I click on the window near the bottom by the Settings gear and the window disappeared. Now, it will not show at all. Even after I shutdown SmartSDR and restart CAT it does not display the CAT window. I have Autostart CAT with SmartSDR selected and it still does not display. DAX works fine. Any ideas?


  • w1smc
    w1smc Member ✭✭

    I shut everything down and rebooted.

    Started the rig, launched SmartSDR w/o CAT & DAX Autostart.

    I then launched CAT. It still did not display on my desktop.

    Then I checked Auto start for both CAT & DAX and cycled SmartSDR. DAX launched but CAT did not.

    I also checked the Task Manager. SmartSDR and DAX are listed but CAT is not.

    So, is there a way to uninstall SmartSDR CAT by itself or do I have to uninstall the entire product and go through the entire BSOD scenario again?

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    I would open a support ticket. Something is preventing them from starting. Maybe your antivirus?

  • w1smc
    w1smc Member ✭✭

    Mike, I don't believe it is antivirus as all three (SDR, DAX & CAT) did launch successfully.

    However, something occurred when I clicked the bottom of the CAT screen display and now it will not even launch.

    I will put in a ticket though .... once I figure out how to create one ...

  • Al K0VM
    Al K0VM Member ✭✭✭

    Could the CAT GUI be 'off screen' ?

    Does it have an icon in the task bar?

    Does it show up in the task manager ?

    Does the problems still exist after rebooting the PC ?

    You might try navigating to %appdata%\Roaming\Flexradio systems\ and rename CAT.settings then restart CAT

    AL, K0VM

  • w1smc
    w1smc Member ✭✭


    The CAT GUI is not showing at all. It did on the initial launch.

    No ICON in the Task Bar ... Only SmartSDR & DAX show on the Task Bar.

    CAT does NOT show in Task Manager. SmartSDR & DAX do show in Task Manager.

    I still have the issue after re-boot.

    I just checked and I do not have CAT.settings only DAX & SSDR.

  • K0FLY
    K0FLY Member ✭✭✭

    Maybe your CAT is launching but it is being placed off the screen or right at the edge of the screen so you cant see it. Try "TASK VIEW" ( its an ICON on my task bar) to show all of the open apps on your PC.

    Win 10 has done the above to me several times, usually at the most opportune moment like 6 meters opening to JA.

    Gayle K0FLY

  • w1smc
    w1smc Member ✭✭

    Gayle, Yes I checked that too. I have two 32" monitors and two desktops and I use Task View a lot.


  • Les Brown
    Les Brown Member ✭✭

    I just resolved a similar problem with CAT that suddenly appeared a while back. CAT would launch and sometimes took a long time for the GUI to appear and when it did, it was missing the usual CAT ports for the radio and I could not add a new port ... just got an error message about failure to create port. Sometimes the CAT GUI would not show up at all but it showed in task manager as running. I tried a full uninstall of SmartSDR and the FLEX VSP drivers and new reinstall with no resolution to the problem. Then the other day I found the posting about repairing the FLEX VSP drivers and that solved the problem, so if I were you I would try to do the repair FLEX VSP driver to see if it helps.

    Does anyone know why a repair of the VSP driver would fix a problem whilst a complete uninstall/re-install doesn't fix it?

  • w1smc
    w1smc Member ✭✭

    Les, Thanks for the response on this.

    I opened a Help Desk Ticket on my issue and in less than an hour my issue was resolved.

    All Ken had me do was run the Repair on the FlexVSPInstaller msi.

    It took all but 2 seconds for the Repair to run. I rebooted and things ran fine after that.

    I'm very impressed with the support from Flex.

  • NJ5N
    NJ5N Member
    Glad there is a fix but why does the happen to begin with? I have lost cat multiple times and have to go through this repair of the FlexVSPInstaller msi.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin


    That is an excellent question, and no, we don't have an answer. Most of the install base, it runs perfectly, but with some others-a very very small percentage, they see what you do. I have a close friend. Same problem as Windows keeps deleting stuff.

    Our code is the same code on all computers and the computer is a dumb box of silicon. :) Something on the Windows side keeps deciding to clean the house.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.