Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Receive Audio Stuttering at about 4-5Hz rate

My remote Flex-6500 worked fine a few days ago. Today, on all bands and modes, including digital, the audio is chopped up in a very regular fashion at about 4-5 per second and the radio is unusable. The up and download speeds have not changed - about 20Mbps down and 8 Mbps up and the latency is OK, about 45msec. I have no trouble running the remote software, like TightVNC and SoftEther. I cycled the Flex and the power supply several times without any difference. Then I installed an audio generator and used TeamViewer to listen to the audio at my location and it is fine - no choppiness at all. That only leaves the Flex or the Ethernet connection through a switch, I think, to the router. Any ideas folks before I race out there?

Comments

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    @johnk0tg

    I think you answered your own question. Since the problem is not there on a local connection, you need to look into the network transportation.

    What version of SmartSDR are you using? PC or MAC? Is any WiFi involved?

    BTW, network speed doesn't much mater sadly, Network latency is critical and that is hard to measure. I would run a DSLReports speedtest from inside your network if you can.

    73

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Yes, the www.dslreports.com speed test will show three results. The buffer bloat is the most critical. A C or worse means you are getting packets buffering at a pretty high rate and since the audio isUDP packets, they get dropped resulting in audio dropouts.


    Dave wo2x

  • JohnK2CIB
    JohnK2CIB Member ✭✭
    edited August 14

    Thanks, guys. Yes, today the problem has disappeared, so it almost certainly is something in the internet transport that was failing. Every day, another way.

    We are running the latest v3 version, there is no wi-fi at the site at all. We use a PC just to control the peripherals. Our Internet is 4G on 800 MHz through two external antennas and a Cradlepoint modem/router.


  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    I’d check the Cradlepoint settings and also see if there is a firmware update for it.

    Some Cradlepoints are set up for multiple wan connections, either for bonding or redundant connections. Maybe the router is checking periodically if the other connection is available. See if you can disable any of those features.

    Dave wo2x

  • JohnK2CIB
    JohnK2CIB Member ✭✭

    Thank you, Dave. Originally the Cradlepoint was set up for Verizon, but we discovered that they throttled us down to unacceptable as soon as we uploaded a few day's worth of receive data. Then, we switched to a third party that buys time from AT&T and gives us unlimited data, so put that card in the second slot. I think I disabled the first slot but will have to sign in and look. In the meantime, a few months ago, the tech from Cradlepoint reconfigured the modem and moved the second card up to the first in the firmware. I do not remember actually moving the cards, but we continue to be on AT&T.

    I'll make sure that we don't have the backup feature enable. Thanks for the thoughts.

    John, K2CIB

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.