Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Setting up JTDX

I’ve used WSJT-X for years and it is great. No issues at all with it. However, as a comparison I’d like to try JTDX and I’m having difficulties setting it up.

Decodes properly and CAT working OK but under Settings/Radio/ I selected:  

Rig: FlexRadioxxx

Network Server: (I created a TCP port 5004 in SmartCat)

The PTT Method box is greyed out as is the Test PTT button. 

Tried changing Rig to Kenwood TS2000 but still nothing in PTT Method box. 

6600M. SmartSDR 3.2.39 and v2.2.156 JTDX.

I’m out of my depth here but I tried creating a PTT port in SmartCAT but that did nothing. What am I missing?

Jeff – G4IUA

Best Answer

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    Answer ✓


    Make sure you have PTT via CAT selected and then you can do a PTT test after you do a CAT test.

    Screen shots of your configuration screens really help.

    You are close.



  • G4IUA
    G4IUA Member ✭✭

    Problem solved! I use 2 monitors side by side. When I put the JTDX Settings/Radio box on monitor 1 (top Picture) the PTT Method box magically becomes visible. When on the other monitor (lower picture) it disappears. The good news is that it all seems to be working nicely now; the Test PTT and Test CAT both work and I've just successfully had an FT8 QSO.

    Goodness knows why! Anyway now that I am aware it's easy to work around this 'feature'. Strangely enough I have never had any other app behave like this. The monitors are running in different resolutions; the one on which it works is 4K, the other monitor (where it doesn't work) 2560 x 1440 (its max display resolution) and maybe that's relevant to the problem.

    Many thanks for your support Mike.

    Jeff - G4IUA

  • G4IUA
    G4IUA Member ✭✭

    Sort of a question I’m not sure best on a JTDX or Flex forum.

    6600M, latest software on Flex and JTDX. As I said earlier I'm very new to JTDX having migrated over from WSJT-X recently. All seemed 100% fine but now I’m seeing JTDX ‘drop’ stations; shows country but nothing else. No time, report…nothing else at all. 

    As an experiment I ran both JTDX and WSJT simultaneously (didn’t know you could do that). WSJT always shows a full report on everything it decodes whereas JTDX leaves the gaps I mentioned. It’s interesting too seeing how the received reports vary between the 2 programs and that JTDX takes a good second or two longer to decode. Audio levels 40-50 and sensible DAX RS gain levels. DT averages 0.5 or so (GPS reference). JTDX didn’t do this a few days ago, so presumably I’ve modified a setting somewhere. Anyone else experienced this?

    Jeff – G4IUA

  • Erik Carling EI4KF
    Erik Carling EI4KF Member ✭✭✭

    Long shot: you haven't by chance modified colours so that something defined in Notifications is white on white background?

  • G4IUA
    G4IUA Member ✭✭

    That's it! Thanks Erik. Your hunch paid off. I recently changed some of the colours and didn't realise that this would be the consequence. Well spotted! Thanks again.; I've changed the settings back to their previous ones.

    Jeff - G4IUA

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.