Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Direct connect the 6400m to SteppIR UrbanBeam

I have a new UrbanBeam and I am trying to get the 6400m to control the antenna using the USB ports. I have the proper interface cable from SteppIR and I am using a null cable from the interface to the radio.

I do not want to have to use a computer interface. It seems that the 6400m should identify the new USB cable upon connecting to the port. I will appreciate any suggestions on a stand alone configuration for this connection.

I am temporarily using my K3 to control the UrbanBeam. I received the proper interface cable for that radio at the same time I ordered the one for the 6400m. It worked on the first try.

Leo NK8L

Best Answer

  • Leo Nessing
    Leo Nessing Member ✭✭
    Accepted Answer

    Thanks to all who replied to my post.

    It took 3 USB/serial adapters with the FTDI chip set, but we now have the radio and the SDA100 talking to each other. I purchased all three of the adapters from Amazon and to have two of them not work is discouraging.

    I also took one of my 4 port USB hubs and used that on the rear of the 6400m.

    Leo NK8L

Answers

  • Alan
    Alan Member ✭✭✭
    edited May 15

    In my case, I used the SteppIR SDA100 with a S12 cable and a FTDI chip serial to USB converter / cable. The Flex Radio will recognize the FTDI cable number.

    A Flex S12 to Null Modem cable will not work, no FTDI chip and the S12 cable does the input/output pin crossing, so no additional null cable necessary.


    Here is he description from the SteppIR web site;


    Alan WA9WUD

  • Leo Nessing
    Leo Nessing Member ✭✭

    Thanks for the input. The cable from the radio to the interface is a USB-serial FTDI.

    I was using the two USB ports on the back of the radio for amplifier and other controls. I used a Y cable and joined these into one port on the radio and I used the open port for the SteppIR controller. The two original cables on the Y connecter still operated their function without a problem.

    The SteppIR controller is not seen by the 6400m.

    Leo NK8L

  • Alan
    Alan Member ✭✭✭

    Leo

    I am not clear on your use of a "Y" cable. I know for sure the SDA100 or 2000 cannot be commanded by two sources (SteppIR uses the Y cable on the Data Out port (lower DB9) to send data out (no commands in) to two sources, but that is not the same as the upper DB9, "Transceiver Control" DB9 connector.

    Or, are you using the "Y" cable to connect two USB ports on the Flex to one? I do not see that working and may in fact cause the Flex to trip off line.

    Back to basics. You can "define" multiple cables on the Flex within the Flex USB cable settings. Plug in a cable, see it "pop up" and define that cable's use / and configure it (one cable defined for each for the amp, the SteppIR, etc"

    No "Y" cables!

    Alan

  • Alan
    Alan Member ✭✭✭

    Also, on the SteppIR controller settings, be sure to have the "Transceiver Setup" set to 9600 baud and "Kenwood" transceiver.

    Baud rate is the same as you used on the Flex USB cable configuration.

    Alan

    WA9WUD

  • Leo Nessing
    Leo Nessing Member ✭✭

    Thanks for the input.

    The baud rate of the two existing USB cables is 38400. As in the previous explanation the two USB ports were in use on the back of the 6400m and I connected them together with a Y cable to one port with no problems encountered. I used the now empty port to connect the new cable for the controller. The FTDI cable is not recognized by the radio.

    If the problem is that only two USB devices can be connected directly to 6400m then there is no fix and a poor design.

    I will rely on my K3.

    Leo NK8L

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    @Leo Nessing

    The 6400M can support as many cables as you require. If it is not seeing an FTDI cable, it may be a fraud cable or there isn't enough power available on that port to drive it. You may want to try using a quality powered USB Hub.

    Y Cables in the RS232 world are questionable at best and I speak as someone who has worked with RS232 devices for about 40 years. I would do all I can to avoid them.

    There should be no reason to use your K3 to have the Urban Beam track the radio. We have LOTS of customers driving their Steppir (and other equipment) directly from the radio.

    Here is the USB device guide


  • Alan
    Alan Member ✭✭✭

    Leo

    As Mike said, if you need more than two USB Cables (ports) from the Flex, rather than using a "Y" cable, use a USB hub plugged into one of the Flex USB ports.

    Then, define each cable's protocol, baud and use in the Flex USB Settings, as per the guide in Mike's message.

    One serial cable, one device.

    I found the SteppIR controllers work best at 9600 baud.

    Alan. WA9WUD

  • Alan
    Alan Member ✭✭✭

    Leo

    Good go hear about getting you configuration working..

    Here is a link to the official FTDI branded cable that Flex recomends, from Mouser Electronics:

    Or, you can buy the cable from Flex.

    Alan. WA9WUD

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.