Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

New release of SSDR & CW

W2ECK
W2ECK Member ✭✭
edited May 2021 in SmartSDR for Windows

I have waited to install the new SSDR release to see what others have had to say about it. Most of the that discussion seems to have died down now. I operate mostly CW and am wondering what other CW ops think of this new release, both Pro & Con ??

tnx in advance & 73

Paul w2eck

Comments

  • Chris DL5NAM
    Chris DL5NAM Member ✭✭✭

    What new release?


    Chris

  • W2ECK
    W2ECK Member ✭✭

    v3.2.31, I guess a month or so old, "new" to me in that I haven't installed it yet.


    73 Paul w2eck

  • N5NHJ
    N5NHJ Member ✭✭

    Do not install, wait for the maintenance release which should be out soon.

  • Erika - KØDD
    Erika - KØDD Member ✭✭✭

    Follow the install procedure to the letter that Tim has laid out.. Do every step and skip none. The tuner will then function properly. The radio plays smoothly here with zero complaints and I'm mighty picky. I knew the icom ic 7800 was trash ans sold mine.. There were supposed to be other small bug fixes.. its always good to get rid of those if you can do it without introducing new bugs.... Haven't noticed any changes under cw, but i haven't cw contested since updates.. the windows one was two updates in the last week. Even after this 3.2.31 update and the latest win 10 beta Channel release. No more blue screens of death due to start up page faults in windows.. So life is now good. Have fun. Let us know how yours goes.

  • W2ECK
    W2ECK Member ✭✭

    N5NHJ

    I’d be interested in hearing your reasons for saying “Do not install,Wait”

    73 Paul W2ECK

  • N5NHJ
    N5NHJ Member ✭✭

    Paul,

    As you see, there are reports about losing control of the radio, corrupted configuration files (not SD card related), lost profiles. It looks like some of those issues are directly related to CW operations. I have some of those problems, not solved yet.

    I can't tell for sure if some of those problems are radio specific (6400, 6600, M models) and/or installation specific (local/remote). What I can tell is that I'm still struggling in having a stable system even if I now know how to regain control of the radio after a crash.

  • WX7Y
    WX7Y Eastern Utah, USAMember ✭✭✭

    If you always look at EVERYONES REPORTED negative experiences and issues with a NEW upgraded version you will never upgrade a version because a lot of people just have a HARD time reading, understanding and applying the Release notes and get in a hurry. This is nothing more then human nature so not saying anything bad about those folks.

    Just think of all the people who have done the upgrade and followed the release notes to the letter and have had NO issues that we don't hear from.

    This version seems pretty stable other then the existing bugs in the software, one of which is for 3.2.31 the worse one being that Static IP addressing is broken and you have to use DHCP on the radio's networking settings until the next version is released and fixed.

  • N5NHJ
    N5NHJ Member ✭✭

    @wx7y Bret

    I'm reporting MY experience and answering a request for advice.

    I can't share what the Flex support answered to my 'still' open ticket, it is not my scope.

    I'll not reply anymore.

  • Lionel
    Lionel Member ✭✭✭

    Paul,

    I’m a CW op and typically QSK. This qualitative, but breakin seems to be faster and smoother.

  • Lasse SM5GLC
    Lasse SM5GLC Member ✭✭

    Paul, I am a CW operator and I'm stuck at 2.4.10 due to defect G7759 i.e. spurious power drop-out. Loss of out-put power for no reason, and only way to restore is to cycle back to RX and then TX. Those who run full-QSK will not likely notice as it means only part of a char or a char beeing lost. Me, running semi-break-in had to watch power meter all the time. Rest assure I am NOT the only one suffering. A friend who are running Flex 6600 and 3.1 reported that the problem was gone if one were running smart control mode, but noticed that after upgrading to 3.2 it was back, saving me the agony of spending $250 on s/w that turns out to be non-working for me.

    Others have reported odd timing,, shortening dashes. This may have been seen by me using 2.51 way back...

    So far for the dedicated CW-op 2.4.10 does work, but I would love to upgrade, if only Flex would fix G7759. BTW I asked Flex if it had been fixed in the latest release and answer was "NO"! I was told to do drop back from 2.6.2 to 2.4.10 by Flex!

    Cheers

    Lasse SM5GLC

  • W2ECK
    W2ECK Member ✭✭

    I want to thank all for their inputs. Very helpful. I am planning on going ahead and do the update this coming week and will let you know how it goes.


    73 Paul w2ecj

  • Steven Lott Smith
    Steven Lott Smith Member ✭✭

    Don't do the update IF you use your Radio Remotely and Locally

    Uninstall of the update is a giant PITA

    It appears version 3.2.31 was never tested by anyone using their radio remotely

    I speak with experience trying the update and using a 6600 (non-M)


    Flex has openly stated version 3.2.31 has Bugs esp related to remote use

    your mileage may vary :)

    Steve

    KG5VK

  • W2ECK
    W2ECK Member ✭✭

    Thanks Steve

    73 Paul

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    All

    Steve hasn't told the entire story on the issue with SmartLink and some of the facts are not accurate.

    The update ONLY to 3.2.31 ONLY affects users who have a FIXED or STATIC IP address on their radio and are using SmartLink. It was something not caught in QA testing, unfortunately. If you had this situation then the fix was to go back to DHCP or a DHCP reservation on the radio and you do not have the issue.

    Using DHCP (and UPNP) is the recommended network setup for your FlexRadio as this then ensures the router is correctly configured and it will also repair itself by a simple power cycle of the radio and router. This works for almost all of you but it can be an issue if you are in some sort of a commercial network or advanced network that are using different features.

    There is no need to go back to 3.1.12 unless you are in a situation where a DHCP configuration is not possible. For most, it is a simple issue to resolve. This avoids having to roll back your VSP drivers.

    I would highly recommend that if you have questions regarding specific scenarios such as this, that you contact us directly and do not depend on 3rd party information. You want to make sure you have the fact correctly explained so that you can make an informed decision.

    Going back to 3.1 from 3.2 is problematic as we had to upgrade the VSP drivers in 3.2. If you need to go back to 3.1, contact us first so that we can work with you with the approved process.

    Regarding this problem, the fix for 3.2 and SmartLink should be out in the coming days.

    In case you are someone that doesn't read release notes the highlights are:

    • Back up your profiles
    • Download the new version of SmartSDR
    • Install the new version
    • Update the radio to the new version
    • Reset the Radio database - 
    • Reload your profiles
    • Work DX

    73 all

  • N5NHJ
    N5NHJ Member ✭✭

    Mike,

    I'm sorry but I have to point out that even you are not telling the entire story. Please look at my still open ticket #43040.

    I'm patiently waiting.

  • N5NHJ
    N5NHJ Member ✭✭
    edited May 2021

    The skeptics about the bugs introduced in 3.2.31 are served.

  • Dave KC9EI
    Dave KC9EI Member ✭✭

    I agree with N5NHJ. I MUST use a fixed IP with my firewall and have lost remote operation of my 6600M because of the fixed IP issue. Further since I was told the "reserved" IP address would fix the issue and it did not... now I can't return to a fixed IP with the .34 upgrade because that capability has been removed.

    I am awaiting a resolution to this problem as are a couple other local users. We are NOT happy and have been faithful Flex customers. Our patience is wearing very thin.

  • N5NHJ
    N5NHJ Member ✭✭

    I didn't notice the Fixed IP configuration was removed tout-court (I'm the SysAdm of my office network and I worked that problem around, so I didn't look at it) .

    It is a shame!

    It is not acceptable that a network device can't be configured manually.

    Dave, let me know if I can be of any help.

  • Alan
    Alan Member ✭✭✭
    edited May 2021

    I have installed 3.2.34. I looked on both my Maestro and Smart SDR: Settings>Network>Advance, and the option to set up a static IP is shown on both, although I am using DHCP.

    Is yours not showing the static IP option, or is it not working?

    Alan

    WA9WUD

  • N5NHJ
    N5NHJ Member ✭✭

    Alan,

    I'm running SSDR remotely, it doesn't show up. The only option is MTU.

    I can't check locally.

  • W2ECK
    W2ECK Member ✭✭

    I did the upgrade to 3.3.34 and it went as advertised. So far the radio is operating quite normally. Thanks for all the advice.

    ** However one question. I backed up my Profiles before starting including, then re-imported after the upgrade. But the SSDR Memories did not get imported. I have the SSDR_Memorories saved as an Execel file but haven't been able to import them. Anyone have and hints or advice on how to get them imported?


    73 Paul w2eck

  • Roger G3LDI
    Roger G3LDI Member ✭✭

    CW Power Drop to Zero.

    After upgrading to the new version, I was hoping that this problem would have been solved. However, it it still there so it looks like I shall have to revert to 2.4.10 AGAIN! I did some tests locally with Malcolm G3PDH who has seen the problem in the new version 3 but not as frequent as me.

    I use a 50A linear power supply, so there are no problems with that. I have reduced power to 25w and it happens at that level too. We proved this last evening with tests HF/2m. Apparently the problem is "known" to Flex so hopefully it will be addressed soon. I was just wondering if there are any other CW ops affected by this. We don't see many reports from others. It would be nice to know that there are others suffering this problem too.

    I have raised another ticket just to keep this aired.

    73 de Roger, G3LDI

  • W2ECK
    W2ECK Member ✭✭

    Roger

    Could you further explain "CW Power Drop to Zero", not sure I understand what's you are experiencing, in order for me to comment on whether I am seeing it.


    73 Paul w2eck

  • Dear Roger,

    You are right. I have the same issue here, with G7759.

    How long do we have to wait until this will be resolved.

    73 de Cris,

    YO3LW

  • I too am experiencing random TX power “drop-out” on my 6600 with the N1MM internal Winkey and an external Winkey. With and without PGXL engaged. I was hoping the latest V3 of SSDR would correct it but the problem persists. Happened several times yesterday during a CWT session. I operate mostly CW so I have not noticed it on SSB.

    - Hunter K3IE

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.