Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Issue with 3.2 on 2nd day start up

I almost waited on doing the upgrade from 3.1.12 after seeing a few issues popping up. Didn't look like a major thing so I decided to give it a go... even used the release notes (sometimes skip?) so I was pretty organized this time around. Most upgrades have been a non event. Well, this time was no exception. I did the first desktop load then the radio did its upgrade and after cold restart on radio and a restart on the PC I started 3.2.31 and with a couple of clicks and a whirr SSDR was running like a champ. I uploaded Profiles and started playing. All was well. I then did the second desktop and that was just a download of new software and install and that was happy too. I then decided I had to try the antenna tuner fix and that worked perfect on the antenna that was the problem with the last upgrade. Happy camper! Did the Maesto... No problem, Did the iPad same thing.. stuff ran fine yesterday all day. Did my normal shut down last night.

this morning.... Did my normal start up and things went all haywire. SSDR wouldn't come all the way up, unhandled exceptions messages on CAT. Being a busy weekend and I am presently on 1 radio (6500) while waiting to make my upgrade choice I decided to bail and go back to 3.1.12. I am still in trouble with the CAT thing but the radio is running fine. I did do a factory reset but now I imagine I should have done a fresh install of 3.1.12 rather than just run the installed software? I just want to be back where I was till everyone regroups.. I also tested remote use on the 3.2.31 and that was fine too?

Comments

  • KD0RC
    KD0RC Broomfield, COMember ✭✭✭✭

    Hi Mike, I would suggest submitting a help desk ticket to Flex. The more data points of problems that they get, the more likely they will be able to track down bugs.

  • I agree on the ticket Len. I just didn't want to tie anyone up for this over the weekend. I just did a fresh install of 3.1.12 after deleting the old install and did a factory refresh on the radio before running it... same thing, unhandled exceptions and CAT wont run. Radio comes up fine as well as Dax.. something I am missing. Wife is tapping her toe... guess I had better tend to business, :-) Mike W1BFA

  • me again... last ditch effort, I tossed out 3.1.12, did another factory reset on the radio, reinstalled 3.2.31 on the desktops, reloaded profiles and I'm back up and running with no CAT failures. I even started up all my WSJT and logging etc. on the one I use for digital stuff and thats happy. So am I... gonna just let it run for the holiday weekend and revisit next week. Hope you all had a Great Friday and have a wonderful Easter. Mike

  • Al K0VM
    Al K0VM Retired Member ✭✭✭
    edited April 3

    3.2.31 should have installed a new CAT driver. (new driver Ver 2.0.5)

    The new CAT driver should run with either 3.1.12 or 3.2.31 firmware in the radio.

    However, in order to make use of the new driver you must use the 3.2.31 CAT GUI. If you attempt to use the 3.1.12 CAT GUI with the new driver you will get CAT failures. Attempting to use the new GUI with the old driver will also fail.

    You may wish to manually start the CAT GUI rather than auto start it with the SSDR software.

    AL, K0VM

  • James Del Principe
    James Del Principe Member ✭✭

    I installed 3.2.31 the other day at the load went fine. This morning it would lot load the new SW completely. Each time I tried it hung up part way. Sometimes loaded part of the screen but not the panadapter or the waterfall. Sometimes it loaded but no audio. After a dozen tries it loaded and worked for a while but froze in a QSO and then made a loud tone about 800 HZ. it was NOT a fan noise.

    I am still at 3.2.31 and just now it loaded. I hope Flex has a quick fix for this. Jim KD1I

  • Patrick
    Patrick WH6HI KauaiMember ✭✭✭

    Sorry to hear about the problems, here it is so far so good, no problems. Since in the PC world, it seems, things are different from one computer to another. So for as a rule, I do a complete deletion of the older version. Including SmartVSP. Load the new software, and the new radio firm ware auto load. Cold start. First time around it will error because of VSP. Do another SmarSDR load and the loader now will load a new version of SmartVSP. I do not know why it does this, but it works and the radio is running fine. In fact so far, knock on wood, I do not get the radio freezes I used to get in the last two versions. Time will tell if this version has solved that problem. Good luck to all.....

  • Al, I think you hit the nail right on the head. I don't have time to step through things today but somehow in the process of the install I ended up with 3.2 trying to load the 3.1 CAT GUI.. :-) Just a quick experiment with unchecking the autoload box and a startup with selecting the 3.2 app makes things a lot smoother! No more whining about illegal (or unethical, can't remember) API calls...

    Life is good. antenna tuner works like buttah! gotta figure out how to do this zoom thing now before my wife catches me.

  • So... Fired up the station this morning with the desktop I use normally for digital work and the radio started up a little more slowly than the norm but came up clean. I started all my normal FT8 and logging programs and I was normal operation. A little while later I started my second desktop on 3.2.31 and that may have done an extra click or so but that came up running in multi fine. I went to 20 meters and was listening to a qso or two and chatted with a friend for a bit. Everything still fine. Then I decided I would see how the new load liked CW. I switched up to 15 mt and switched mode to cw and the radio immediately froze and both sessions on the desktops crashed in a heap. I ended up having to do a reset on the router, factory reset on the radio and reboot the first PC just to get things back to life. This after many attempts at a normal shutdown/startup. I'm going to clean out the second PC and do a fresh load of 3.2.31 on that this afternoon and try that process again. Something is a little hokey. I had been at 3.1.12 for several months and bounced sessions of all modes between PC's and Maestro and iPad with not so much as a hickup. Now, things seem pretty fragile. If I crash again this afternoon I will have to open a ticket.

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    @Mike W1BFA in Maine

    There is something strange there going on your network to cause the house of cards to fall down. It is pretty hard to diagnose further when everything is reset. In the support world, it is called 'easter egging :)' where you change a bunch of things and see if it works.

    If you run into this again, work to isolate things to a simple failure point. It 'screams' of a LAN configuration issue or an IP stack issue in windows. The radio failures are just the symptoms, not the actual cause of the problem it seems. It could be AV software or Firewall software too.

    In order to diagnose further, we need to know all the parts that touch the LAN communications and the network topology helps too. Who are all the players in this setup?

    73, Mike

  • and the saga continues Mike. I thought I had all my ducks in a row and everything operating and playing well yesterday. Well, came in to shut down the station last night and my primary desktop I use for the radio had a notice that I had a new Windows 10 necessary update that was loaded and ready to install. No apparent option to bypass. I have had many updates and had no conflicts as others had so I thought I remembered in the release notes that there were parts of 3.2 making it more resilient so I shut down the radio and its related programs in an orderly manner and let Windows have its way. This morning I came in and started the PC and the radio up. The PC came up fine, looking a little different but booted quickly and cleanly. I loaded a browser and internet accessed fine. I figured no time like the present and started SSDR 3.2.31 and it came up with a try at the radio screen and window messages that it couldn't talk to the radio and try to reconnect. I shut everything back down and rebooted the router restarted the PC and did a cold restart of the 6500 and waited for everything to come back. Everything returned to service so I went ahead and started 3.2 again on the PC... same thing, no communication with the radio. My next thought was... this is going to be a hassle. I will just start up the other desktop that I was also using 3.2.31 with yesterday and sort out what went wrong with the one that did the Windows upgrade at my leisure. Same exact messages. I did another cold restart on the 6500 and tried again with the same results. Then I just had the idea to try the Maestro that is on wifi here on the desk... That refuses to connect also. All things are seem to be pointing at the radio. I imagine I would be told to to a factory reset on the radio and try over and open a ticket but I am pretty discouraged at this point.

    My gut is telling me to back out of the Windows update, make sure that is clean and then remove all traces of SSDR and download a fresh install of 3.1.12 and pull everything back as well. For the last many months since 3.1.12 was released I have been running smooth and trouble free (except for my antenna tuner and some odd persistence habits). All day yesterday I was running on 3.2 that started clean yesterday morning. I even took the iPad over to our camp and tested remote. I had the second Windows 10 desktop running a multi session most of the day and didn't have any crash when I switched to CW this time.

    Great running station until I decided to give 3.2.31 a try. The station involved is a Dell I5 running now Windows 10 Home 19042.867 and second desktop is a Dell I5 running 19041.867. The network here is a Linksys 6350 router with a Netgear 10 port switch. The two desktops are on ethernet. The Maestro A is usually on wifi as is the iPad Pro. Again, everything was **** dumb and happy till the upgrade. I would estimate I have 8 hours of wading through reloads, deletions, reboots and cold starts and now I am right back where I started. I'm going to see if I can back out of a couple of things today to see if I can get this mess sorted and back to a normal operation. I enjoy puzzles and don't mind tinkering a bit but this is starting to get beyond that. Mike

  • been working with Tim and may have found out where I was hosing up the works... On doing the factory (white button) reset process I likely wasn't waiting long enough after reapplying power to the radio before starting. The internal processor needs 2 minutes to get spun up completely. Everything is tested and back to running nicely. I am in hopes when I start things up in the morning tomorrow it will be just the same. Life is good! Mike

  • It's starting to look like we're closing in on the puzzle.. It seems as if something in the Profile that I was reloading that was saved under 3.1.12 didn't play well with CAT under 3.2.31 and CAT was causing SSDR to freeze and time out. I'm running 3.2 now with the old Profile I had tweaked a little to get a new image and then re-saved under 3.2.31 and so far things are smooth through 4-5 restarts. Mike

    dunno whether this computer stuff is as much fun as chasing bad caps and leaky tubes with the old gear, but it's still fun!

  • W3FRG
    W3FRG Member
    I have submitted a ticket and its being worked by Flex.

    I have not however, seen the above mentioned issues; Yet.

    My issues, from first installing 3.2.31 have been it will not operate on CW or Tune.

    In brief, the Pitch setting comes up at 100 Hz vs the default of 600HZ. I have to do a Factory reboot and then all's well, sometimes, until I attempt a new start up after the radio has been off.

    The PC's in use, an ASUS laptop and desktop, were both tried, both are running Win10 64bit; Same results using 3.2.31.

    Both machines were professionally cleaned using REVO and CCCleaner. A lot of duplicates, registry and Firewall errors were found. Once the machines were cleaned of all the duplicate files found, a new 3.2.31 file was reloaded and a new search for issues was performed. Same findings, lots of duplicates, registry and Firewall errors appeared again.

    So, every time I attempt to use SSDR I hope it comes up correctly, if not, I perform the Factory reboot; ON switch led turns white. If I try to use it and the pitch setting is not at least 600Hz, the radio will shut down and disconnect.

    I've done some 6 upgrades on the 6600M since '18 and this is the first upgrade that has given me any problems.

    Hopefully, FRS will find a solution to this troubling issue.

    Tom W3FRG
  • IZ1OQT
    IZ1OQT Member ✭✭

    I also confirm I have performed a lot of updates the only one that gave me problems and forced me to reset the radio was this.

    73... all

  • Andrea Vernice
    Andrea Vernice Member ✭✭

    having the same problems. one one computer is working. on the remote one only if i don;t change band or mode.

    then the flex get frozen. and i need restart.

    never restarted my flex so many time in last 5years.

  • At this point what we identified was causing my issue was when reloading old 3.1 profile. On your next reset do not reload profile, just go through and manually input your preferred settings. That brought me back to nice stable operation. I sent Tim a copy of my profiles and they are analyzing them to see what there was that would cause CAT to freeze and lock up SSDR. At some point I am going to remove all trace of the old profiles I had built and try creating new ones. For right now I’m leaving things alone till I hear from Flex and have some time to play. 3.2.31 running like a champ. I was doing CW on one PC yesterday while the other in multi was on FT8 with no glitches. Maestro A and iPad working well with it as well. Mike

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.