Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR is compatible to iOS 14

Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

SmartSDR is compatible to iOS 14 (moving to the correct category)

However, due to a bug in iOS 14 it might happen that you can’t use SmartSDR to connect to your local Radio.

But there is a simple solutions. Just change the App to use a fixed IP Address of your Radio. For this, just go to Settings -> Show Extended Settings and select “Fixed” for “LAN mode”. Then, enter the IP Address of your Radio in the field below named “Network”. (No change on your Radio is required for this)

Now, you should be able to connect to your Radio again.

Once you do that, you may get asked by iOS for permission to access your local network by the App. Once you confirm this and gave the App permission, you can even turn back off the fixed IP LAN mode and change it back to “Discover” which is the recommended setting.

You will now also find a new Setting in the iOS Settings under Privacy -> Local Network.

Here, you should see an entry for SmartSDR which should be enabled. If you don’t see this entry, continue to use the fixed IP until you get the permission question from iOS.

On this screen, you can also re-enable Local Network access if you accidentally dismissed the permission question.

I expect this but to be fixed in the next iOS version but in the meantime, the aforementioned procedure will solve this problem.73,



  • David_NK5G
    David_NK5G Member ✭✭

    Yes, Mike that worked for the local connect. Thanks. However, it did not resolve it for using SmartLink.

  • KI4P
    KI4P Member ✭✭

    well, hope that works, i guess in my post the other day i didnt note i was using IOS 14, hope this helps! will try when i get home. Thanks Mike!

  • KI4P
    KI4P Member ✭✭
    edited September 2020

    yep, well i tried it on mine, local worked but like David smartlink didnt. Smartlink does show in the available radios but when you click it it goes back to connect screen, oh well half better than nothing! Thanks

  • K7QDX
    K7QDX Member ✭✭

    Well there was a second software release for IOS.. So the newest and greatest is now 14.0.1 and as you can guess it didnt solve or help this problem...

  • Patrick
    Patrick Member ✭✭✭

    When I try to connect I get an empty “Available Radios” window.....any idea what’s going on running iOS 14.0.1....

  • K7QDX
    K7QDX Member ✭✭

    I'm still having the same issue off network... Still waiting for this "magic Apple update" that will fix this.

  • K7QDX
    K7QDX Member ✭✭

    I found the errors of my ways.... Looks like SmartLink got an over haul recently, or since I have played remotely. Logging out and back in resolved my issue. Its great to have a radio again on my ipad and iphone.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.