Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Radio Dropping off line -- solutions

Mike-VA3MW
Mike-VA3MW FlexRadio Employee, Community Manager admin
edited June 2020 in New Ideas
Hi All

Occasionally I have had some issues where the radio will drop offline and personally, here is what I have done to isolate it.  This is on a local connection, but it could happen on a remote connection as well.

Today was a great example.  Since I totally rebuilt the Win 10Pro box from scratch about a month ago on an SSD drive, it works solidly.  

But, about 1 pm today, it started to drop off every 30 minutes are so and SmartSDR would lose connection.  I knew it wasn't the radio, or well, that wasn't the first place I was going to look.  

After the 3rd, I had some command prompt ping windows opened on the SSDR computer and another computer so I could keep a look at multiple paths.  

The next 2 times it happened (I didn't have to wait long) it was clear that it was related to the Win10 Computer, so I focused on the NIC card in that computer.  Or it could have been the port on the network switch.

 I had 2 computers pinging the radio.  When it failed, only 1 computer could not reach the radio.  This confirmed the problem was not the 6600 or its path to the switch.  Remember, you have to consider the data path between the radio and the client using it.

I did 3 things at once (I know, I should have done 1, but I was watching for 6M DX and I wanted to fix it quickly).

  1. Changed the LAN cable - yes they go bad
  2. Moved the LAN cable in the switch to another port
  3. Change the NIC Adapter settings for Speed on the PC from AutoNegotiate to 100M Full Duplex.  
Why did I do #3?  I remember from my days in doing backups for a company I worked for where we backed up a LOT of data, that AutoNegotiate on NIC cards seemed to cause us issues for some customers.  Locking down the speed seemed to help.  A lot.  So, I fell back to this.

So far, it has been 7 hours or so and rock solid again.  

Hopefully, these are a few clues you can try if you keep dropping a network connection.  

Remember, streaming HF data is harder on your network than surfing the web or watching NetFlix.

73, Mike va3mw


2 votes

Open for Comments · Last Updated

«1

Comments

  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    I would like to ask how to change to from AutoNegotiate to 100M Full Duplex.  My dropouts are not as often as yours but I've had as many as 3 in one day . I bought the IQRouter but that didn't help . The past 2 days , I've rebooted the computer at noon . No dropout yet but it's to soon to know... I'm trying anything I can . 
    Ed
  • Dudley  WA5QPZ
    Dudley WA5QPZ Member ✭✭
    edited June 2020
    Mike, 

    Something else is to "disable"  the "Green Ethernet"   and the "Power Saver"   in the NIC properties both of these will cause the NIC to pause .   

    Dudley
    WA5QPZ
  • Patrick
    Patrick WH6HI KauaiMember ✭✭✭
    edited June 2020
    Dudley, is correct, many months ago, had same problem.  Going into the advanced setting on the the ethernet and looking for anything that would turn the port off or put it to sleep.  Now the ethernet is happy.  One thing that would help us none PC admins.  Would be to create a library of settings for various PC functions that are used in our everyday use of SmarSDR and maybe some of the third party apps we most commonly use.  
  • Bob Gerzoff, WK2Y
    Bob Gerzoff, WK2Y Member ✭✭
    edited June 2020
    I presume there are folks like me who have never messed with their ethernet card or settings. There are a host of settings.  I turned off the energy efficient ethernet and the green ethernet  but I'm wondering if anything else should be tweaked to optimize use with the Flex?  Besides the advanced options  there was also a save power setting under the power management tab I turned off. 

  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    Tnx Dudley , The iqRouter is new , I'll have to do some noising around to see if it's Green plus find AutoNegotiate . 
    The dropout only happens on 1 of my 2 computers . I have a 6500 on the #2  computer and it never drops out but if I load it on the #1 computer it too drops out  
  • bahillen
    bahillen Member ✭✭
    edited June 2020
    Mike and Bob

    I was not sure where to look to change the settings. I had to decipher the what was written. 

    So for the rest of us. The NIC card is a device in the computer and can be changed by going to the Computer Control Panel and selecting Device Manager. Expand Device manager and click on the Controller (for Ethernet) Not Bluetooth or Wireless Adapter. Double click on the adapter and the properties will come up. Pick the Advanced Tab and you will see the applet that Bob shows above. When you click on the various parameters it will show you the various choices.

    I changed the 3 properties that have been suggested. I have not seen the problems that have been stated but I have had behaviors in the past that I didn't see a root cause especially when running LatencyMon testing. (identified at times as NIC driver issue. Who knows. 

    Mike, I have been working on reliability and stability of the system for using remote as well as day to day. This may be something that would be suggested for all Flex users as a manual appendix. 

    Now if someone could fix the memory leak in the DAX Driver that caused the TX audio get corrupted every 2-4 days and required cycling the TX DAX button off and on to clear the problem.

    Mike, Thank you for raising this setup recommendation.
    73
    Bill W9JJB
  • KD0RC
    KD0RC Broomfield, COMember ✭✭✭
    edited June 2020
    Hi Ed, do you have a screen saver active on computer #1? If so, that might be the issue. 73, Len, KD0RC
  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited June 2020
    I do have occasional radio disconnect, maybe 1-2 times per month.

    My 6600 runs 24h and also have DAX issues every 2-3 days and have to be restarted.
    Checked above settings and I cannot find these settings on my card - "Green Ethernet"   and the "Power Saver".



    I did turn off "Allow the computer to turn off this device to save power" function.

    Sergey, KN7K
  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited June 2020
    I  actually would like to see the settings for each line from the hams who does not have interrupts.
    Sergey, KN7K
  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    Len no sir I do not , I have  things set to were the hard drive or monitor never sleep 
    Ed N5DG
  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    Thanks to everyones post I found AutoNegotiate and changed to 100M Full Duplex.  Now I'll let it run a few days to see 

    Ed N5DG


  • bahillen
    bahillen Member ✭✭
    edited June 2020
    Did you change Speed & Duplex to 100m and duplex. This was a key change from Mike. 73 Bill
  • Dudley  WA5QPZ
    Dudley WA5QPZ Member ✭✭
    edited June 2020
    Sergey,

    Not all NIC LAN chips have a Green but most do have a Power Saver..   Seems that Microsoft has updated some of their drivers,   and over wrote previously changed options..   I still have my "Realtek PCIe GBE "  motherboard NIC doing "Auto Negotiate "    for the speed settings and it seems to be running fine..    If you have a manageable switch,  check for Green settings there too,   made a difference on a Cisco switch that I had connected to the radio and computer..   Mine is working much better..   

    Dudley
    WA5QPZ
  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    Bill just checked to be sure , yes Speed & Duplex to 100m and duplex.
    Ed N5DG
  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    Tnx Dudley , I'm not using a switch , I have two 6xxx and 2 computers going directly to the IQRouter . The tech support person with IQRouter tells me I should have a switch with everything connected to the switch and only one cat cable from router to switch . If these changes I've made today don't help , I will try that .
     What ever  radio is on Computer #2 never drops out so I'm thinking it's computer #1 that is my problem and not the  router. I'm still rebooting the computer computer #1 each day at noon and no dropouts now for 3 days

    Ed N5DG    
  • Wayne VK4ACN
    Wayne VK4ACN Member ✭✭
    edited June 2020
    Ive been having intermittent connection dropouts. I checked nic. Turned off windows power saving on nic. Funny thing is, i thought i'd already done that in the past. Maybe windows had changed it back with update. Dont know. I dont seem to have any of the green power settings. Set it to 100m full duplex. Ran it all night with 4 slices and 4 instances of wsjt-x. So far so good. No dropouts. Maybe that fixed problem.


    Thanks for help

    Wayne

    VK4ACN
  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    Wayne I hope that's the fix too . I can't find the power savings either 

  • Mike-VA3MW
    Mike-VA3MW FlexRadio Employee, Community Manager admin
    edited June 2020
    30 hours now.  No disconnect 
  • Wayne VK4ACN
    Wayne VK4ACN Member ✭✭
    edited June 2020
    Ed. Im assuming some cards dont do Green. But unticking the Windows power saving box might fix the issue. Mines been on 13 hrs with no dropout. But it was intermittent so fingers crossed
  • bahillen
    bahillen Member ✭✭
    edited June 2020
    Ed
    I was using my Comcast/Router with all connection .
    Tim from customer support suggested a switch for the Flex related equipment including computer to reduce network traffic and latency. If was a good improvement with virtually no data errors and 1 me latency. I just looked and had 20 errors in 10 million packets. 0.00%. It was a unmanaged 1 Gb switch no programming GS108v4. 8 ports Others may have other choices but it works for me and was suggested by Tim. It was $30-40. Nethgear

    73 Bill W9JJB
  • Bob Gerzoff, WK2Y
    Bob Gerzoff, WK2Y Member ✭✭
    edited June 2020
    I went and changed all the possible settings, rebooted and had no internet.  I put everything back and got on no problem. I'm going to have to try changing things one at a time, but if someone has any idea why that happened to me, I'm all ears.
    Thanks and Happy Father's Day to all the Dads.
    73, Bob
  • Mike-VA3MW
    Mike-VA3MW FlexRadio Employee, Community Manager admin
    edited June 2020
    Bob

    Try just the speed setting and have it match your Switch you are connected to and see how that works for you.

    73
  • Bob Gerzoff, WK2Y
    Bob Gerzoff, WK2Y Member ✭✭
    edited June 2020
    My PC and Flex-6500 are optically connected directly to an IQ Router.  One other satellite connection direct to the router. No switch.  Should I get one in the upstairs shack?  The router is in the basement.   I have been able to disable energy efficient ethernet and green ethernet without any problems.  I should mention drop outs are not very common but do happen on a rare occasion.    Thanks for the help.  Bob
  • Mike-VA3MW
    Mike-VA3MW FlexRadio Employee, Community Manager admin
    edited June 2020
    Hi Bob

    The IQ Router actually has a 4 Port Switch in it, so you have to consider that device as well since it is a multifunction device.  

    You can give the speed lock down and try.  Make note of it so you don't forget. 

    Mike

  • Bob Gerzoff, WK2Y
    Bob Gerzoff, WK2Y Member ✭✭
    edited June 2020
    I am able to lock down the speed.  One strangeness, however.   There is a Power Management tab.  If I turn off "Allow the computer to turn off this device to save power" and also the "Allow this device to wake the computer."  ,  I can get to some internet sites but not others and my Outlook email has no connection. I guess that's what caused my problems yesterday.   I'm not going to worry about it.   Just letting others know in case they run into something similar.   73, Bob 
  • Bob G   W1GLV
    Bob G W1GLV Member ✭✭
    edited June 2020
    Dudley, where do you find "Green Ethernet"?
  • Bob Gerzoff, WK2Y
    Bob Gerzoff, WK2Y Member ✭✭
    edited June 2020
    If you go to device manager, choose your ethernet adapter, right click, choose properties, go to the advanced tab, you may find it listed.  Apparently, not every computer will have it.image
  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    I'm going from bad to worse , Now the radio lost connection and nothing I can do to get it to connect . Turning it off , removing the +12 for a few minutes , add the +12v back , turn on the radio , reboot the computer and when I click on thr SSDR icon the radio pops up and go's away ... Light on the front flashes RED for about 15 seconds and then blinks green .. What A  PITA . I just got this radio back from FRS last Tue for this problem image
  • Ed Stallman
    Ed Stallman Member ✭✭
    edited June 2020
    I just did a factory reset and the radio came back up .. I had to do the same thing 14 hours ago ... Also I'm not reloading profiles , I'm building new .

    Ed N5DG
  • Hunter - K3IE
    Hunter - K3IE Member
    edited June 2020
    Thank you all for these most valuable tips regarding the Speed/Autonegotiate/ and NIC Power Saving settings.  I had been experiencing multiple dropouts per day.  I changed all of my ethernet cables and tried several LAN settings to no avail. 

    Since implementing these suggested settings, I have had no dropouts for the past 48 hours.

    As mentioned, these tips should be included with a SmartSDR "Getting Started" Guide.

    All the best - Hunter K3IE

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.