Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6600M transmitter stops intermittently on CW

James CharltonJames Charlton Member ✭✭
My 6600M running the latest version of V 3.x software started exhibiting intermittent transmit failures during the SKCC WES CW contest yesterday.  Specifically, I would be sending and during a dash (key down, transmitter transmitting) the RF output from the 6600M would drop to zero.  Letting the key up and then pressing it down again to sent the next character caused the transmitter to come back on.  However, as long as I held the key down, the RF would stay off.

My setup is a 6600M driving an Ameritron ALS 1306 amp driving a dipole.  I have a tuner between the amp and the antenna but it is usually in bypass.  

There is an EA4TX remote antenna switch and a logging PC connected to the 6600M via  USB cables.  Neither the switch nor the PC seem to be doing anything when the problem occurs. 

The 6600M is limited to 50 watts output and I have measured that with a separate meter. It's built-in ATU is in bypass, no ALC connection or other feedback to the 6600M is present, the SWR between the 6600M and the amp is about 1.1:1.  SWR to the antenna is 1.3:1.  No measurable common mode current in the shack.  The ambient temp in the shack is about 68F and the 6600M air vents are completely clear and power is steady.  No alarms, lights or error messages appear.

The problem is hard to trap because it occurs only every several hundred characters and the 6600M keeps the amp keyed on so its "transmit light" stays on, just no RF comes out of the 6600M.  It does not matter whether or not the amp is on.  I observed the problem on 20m and 40m bands.  Others weren't tested.

Although it is not very new, the last thing added to the shack is the EA4TX switch and it connects to the 6600M via a USB cable.

I would like some help fixing this because people say I'm missing the occasional letter.
Jaimie "Jim" Charlton   AD0AB

Active · Last Updated


  • Michael PitreMichael Pitre Member
    edited February 2020
    I am having the exact same problem with my Flex6500. Has this been resolved?
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited February 2020
    Is the radio running all by itself or is there any other software being used with the radio.?
  • Tom W3FRGTom W3FRG Member
    edited February 2020
    I am also having a similar problem, happens very intermittently, when using SSB with my 6600M, or 6300, running V 3.1.8 SSDR.
    RF power out will just shut down with no errors from 6600M, LP-700 or RF Kit Amp.
    I have to re-click the VOX, or MOX, buttons to get back to normal operation.

    Tom W3FRG
  • James CharltonJames Charlton Member ✭✭
    edited February 2020
    In my case with a 6600m, the radio is running all by itself with no other software involved except an N3FJP logger that reads the freq from the radio. It does not key the radio, but it can change the radio's set frequency and mode by clicking on the spotter.

    I normally use a paddle with a Winkeyer, but the problem seems to occur even when I'm using a straight key plugged directly into the radio.

    The radio drives an Ameritron ALS 1306 amp which drives a tuner that goes through an antenna selector to finally get to the antenna. 

    I mention the setup, but I don't think it has anything to do with the problem.

    It is almost impossible to trap the problem as it is very rare, but here's what seems to happen.

    I am sending CW when on a key down, there is no RF output.  I do know that there is no RF out of the 6600m because its meter indicates that and an external meter also indicates zero output.

    The SWR as measured by the transceiver is about 1.2:1 and that is the same as measured on an external meter so, the 6600m is well matched to the amplifier.  The Transceiver's output is set at about 50 watts.

    Nothing is hot and the transceiver's fan is not running at full speed.

    The RF output from the transceiver will stay at zero as long as the key is held down, but letting it up and pressing it down again - even extremely quickly - will restore normal operation.

    That's all I have been able to discover except there is no equivalent issue when operating on SSB.

    Jim Charlton   AD0AB

  • Michael PitreMichael Pitre Member
    edited February 2020
    I am experiencing the exact same problem with or without logger running or other software, the only difference being my radio is a Flex6500 running same version of SmartSDR. It is much less noticeable or non-existent with cw QSK delay set to zero. This happens with or without amplifier running, or whether using internal or external keyer.  I have tried going back to SmartSDR 2.0 with no improvement. 
  • Tom W3FRGTom W3FRG Member
    edited February 2020
    I neglected to comment during this anomaly, that the Receive signal also dropped down in level significantly during this RF Power drop out.
    However, both Tx & Rx returned when either the VOX or MOX buttons were clicked.
  • Lasse MoellLasse Moell Member ✭✭
    edited February 2020
    Open a ticket so Flex understand the severity of this issue! A number of us have reported this already.
    I noticed this more than 7 months ago....
    " This issue has been logged as defect number: G7759
    At this time the only workaround is to stop sending and allow the radio to transition to RX and then start resending "
    See threads:

  • Lasse MoellLasse Moell Member ✭✭
    edited February 2020
    I have yet to see this happen when using  CWX or letting logging program send. Only when I key using a paddle attached to the radio.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited February 2020
    This is defect G7759 and it is currently being investigated by the software team.  At this time the workaround is to stop sending and allow the radio to transition to RX and then start resending.
  • Mal G3PDHMal G3PDH Member ✭✭
    edited February 2020
    Yes,  I have also experienced this intermittently over many months.  It gets tedious constantly watching the power meter to check that power is still going out.  I have had instances in a CW QSO where the other station has started to reply thinking that I have passed it over to him after an abrupt halt to my transmission.  t has nothing to do with antennas, SWR's etc.  I am currently trying to check if it happen whilst operating with the Maestro rather than the PC.  
    Using 6500 and PC with Windows 10.
  • Tom -WA2TPTom -WA2TP Member
    edited February 2020
    Prospective 6600M buyer. Following.
  • Joe N3HEEJoe N3HEE Member ✭✭
    edited April 2020
    I can confirm that this issue is far worse when hand sending CW with a mechanical key.  I was operating SKCC WES this past weekend with a bug and side swiper and the transmitter dropped out at least a dozen times over my relatively short period of operation.  It made operating more difficult as I had to constantly watch the meters for RF drop outs.

    This issue rarely happens when using N1MM to send CW.  It happens occasionally when using the electronic keyer built into the radio.

    Looking forward to the next release to fix this defect !
  • Doug HallDoug Hall Member ✭✭

    I've had my Flex-6300 for a number of years. Running SSDR 2.6.2 on Windows 10. I often use a different rig on CW, but tonight I spent some time on 80M CW with the Flex. I noticed the issue that people have reported on this thread, namely that the RF output would occasionally drop to zero while sending CW. Allowing the radio to revert to RX seems to fix the issue, at least momentarily. During a 30 minute CW QSO it happened to me more than half a dozen times.

    If this is the same defect (G7759) as mentioned previously then Flex has known about it for quite some time. I consider this a fairly serious issue for CW operation. It sounds like it's related to contact bounce.


    Doug K4DSP

  • Erik CarlingErik Carling Member ✭✭

    It is so disappointing that critical faults like this exist. It is what puts people off buying a Flex. It was logged as a defect in January and we are now in November with no resolution.

  • Roger CookeRoger Cooke Member ✭✭

    Like Lasse, I have had this problem for months. So, the only way to get over it at the moment is to revert to version 2.4.10. I have been running that for a few months now.

    73 de Roger, G3LDI

  • g7sozg7soz Member, Unconfirmed
    Ah, so I'm not the only person to suffer from this. I am having exactly the same problem on all modes - one second RF out, the next none. Highly embarassing.

    I was loving my Flex 6400 until this started, but I'm afraid that now I'm getting to the stage where I might send it back to the supplier and ask for a refund.


    Simon G7SOZ
  • Doug HallDoug Hall Member ✭✭


    If getting a refund is an option for you I'd seriously consider it. I don't understand Flex's reluctance to address this issue. By now they have had more than sufficient time to investigate the problem, so they should have 1) figured out the problem and devised a fix, or 2) determined that they can't fix the problem. But like the Flex CW, they have gone "radio silent."

    Incidentally I have also experienced this problem on SSB. Once in a great while keying the mic results in no RF out, and releasing the PTT and keying again restores TX. Others have reported this as well.

    Admittedly It may be that there are only a very few of us experiencing the issue. But in that case Flex could at least say so. They have assigned a defect number, but that's about all we know.


    Doug K4DSP

  • M0UNNM0UNN Member
    Got same issue here as well on my flex-6300. TX stops intermittently , when sending cw with the paddle. It happens once in a while and very annoying, when in qso you notice, that you have no power out and the other station is already replying to your half sent message . Happens also , when operating remote using Maestro, but Maestro is also down at the moment and Flex is working on the issue....grrrrr......
  • Doug HallDoug Hall Member ✭✭

    OK, I spent some time looking at this issue in depth, and now I am reasonably sure that it is due to paddle or key contact bounce. To recap, some Flex 6000 users have seen the TX stop intermittently on CW, and when it happens the rig won't transmit until you stop sending and let the rig return to receive mode. The CW Delay setting will have some impact on how likely you are to see it happen. With low delay values the problem might happen and you'd never notice, but with longer delay values if it happens and the TX doesn't drop out between characters you are more likely to observe the issue. N3HEE observed that it was worse with a bug or side swiper, and I can confirm that. I hooked up my old 1954 vintage Vibroplex and it was nearly useless. A Nye straight key was better, and it took a while before I observed the problem with that key, but it still exhibited itself. I cleaned the contacts on my Jones paddle and the problem got better but was not eliminated.

    Then I switched to an external keyer and the problem was never observed over a number of QSOs.

    Using my oscilloscope I can see contact bounce on all of my keys and paddles. Some are worse than others. The Vibroplex bug is terrible. But all mechanical switches (and hence ALL straight keys and paddles) have some contact bounce. It appears that the Flex firmware is not handling contact bounce properly. My external keyer does handle the debounce from my paddle correctly and I think that's why the problem goes away with an external keyer.

    This same issue exists on SSB, and if you have a PTT switch that exhibits a lot of contact bounce you may occasionally key the radio only to find that you aren't transmitting any RF. Releasing the PTT button and pressing it again generally solves the problem. I experimented with a number of switches, looking at their contact bounce on the 'scope before selecting one for my PTT footswitch and now I rarely see the issue on SSB. But it does occur.

    As stated in a previous post, this is not a new issue. It was reported some time ago. Given that it apparently showed up in later releases of firmware one must assume that it's a firmware issue and not a hardware issue. And maybe it's not a contact bounce issue at all, but it sure seems like it. In any event I wish Flex would fix it. But rather than holding your breath you might consider dusting off that external keyer and seeing if it solves the problem.


    Doug K4DSP

  • Mal G3PDHMal G3PDH Member ✭✭

    Doug, All very interesting but I don't think its is contact bounce. I use an external logikeyer feeding into pin 4 on the accessory socket and I see the problem. I never use a key straight into the key socket. It never does it when the CW is keyed by a macro on such as N1MM+ only when using the key sockets. Admittedly mine seems to be very infrequent at the moment but very annoying when it happens as I prefer to keep the delay higher. I am on version 3.1.12 software.

    Malcolm G3PDH

  • Mauro HB9FBGMauro HB9FBG Member ✭✭

    I also had the same problem, in a very severe and persistent way. It didn't happen with the internal keyer and in the digital ways. With Flex USA I also tried old software but the problem remained. The attempts of technical interventions have been useless.

    I am not a technician but I remain of the opinion that FlexRadio USA should retire ALL THESE RADIO and understand where is the problem which is not software. It is a hidden problem in the car, most likely a nonsense but embarrassing for the unfortunate who cannot use the radio as I did.

    I hope you understand quickly why FlexRadio is, as I expected, a great radio.

    Mauro HB9FBG

  • Doug HallDoug Hall Member ✭✭

    Thanks, Malcolm. I have only used the front panel key jack for CW, but I assumed it's the same connection as the pin on the accessory socket. So far I have not seen the problem when using an external keyer, but I have only had it hooked up for a few days now. In any event using the external keyer seems more reliable than when I was using the paddle with the Flex internal keyer, so I'll stick with that for now.


    Doug K4DSP

  • Doug HallDoug Hall Member ✭✭

    Update to my previous post. Malcolm G3PDH, after using my external keyer for a few days the problem showed up once during a QSO on 20M this afternoon. Up to this point I had declared the problem "fixed" or at least "worked around" but apparently not so. I was sending with the CW delay set to around 300 mS when I realized that there was no RF coming out of the radio. Pretty disappointing. So I don't know if contact bounce plays into it or not, but like you, I have seen the problem with an external keyer as well as the internal one.

    I'm out of theories.


    Doug K4DSP

  • Lasse SM5GLCLasse SM5GLC Member ✭✭


    I reported this in summer 2019 and was issued a defect number G7759. The only remedie right now is to fall back to SSDR 2.4.10

    I did revert back to 2.4.10 a few months ago and so far, I have yet to see this issue. Comparing with 2.6.2 my gut tells me there is slighlty different keying timing, i.e. I find it easier to send fast CW with the 2.4.10 vs s.6.2. Not sure if this part of the issue though. A shame that we CW operators are forced to use old software and not beeing able to enjoy all the new features. But hey... guess FT8 is where the action is, right? :( My bet is that noone at Flex is using CW.

  • Lasse SM5GLCLasse SM5GLC Member ✭✭

    Just one more comment, I use the built-in winkeyer and have my paddel attached to the front of the radio. Have tried to use an external keyer and yes, it seems there are less occurance but not all good. Also (as I have posted in a separate thread) it seems 2.4.10 do behave a bit different regarding speed setting, as I am unable to change speed when transmitting CW from my logging s/w (tried a few other s/w too). This was no problem earlier on.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.