Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

PGXL Won't Connect

Ian1 Member ✭✭
PGXL 1st use not showing up on PGXL Utility.
On PGXL front Panel no Band Data showing.
Running 6700 version 3.18 Smart Link running or local same issue.
Submitted a Help Desk ticket but was hoping for any ideas you might have?

Tried several new Cables for Cat 5,6 not changes. Numerous reboots etc.



  • Mack
    Mack Member ✭✭✭
    edited November 2019
    Ian, This doesn’t occur often. Here are things to check: 1. What IP address is the amp picking up from your DHCP server?. Look at the amp front panel. What is the IP address of your computer and radio? 2. Are you sure the amp and computer running the PGXL utility are on the same LAN subnet? 3. If 1 or 2 don’t yield information then I suggest a reset of the amp. A. Power off the amp. Press and hold the front panel standby button on the amp while powering it on using the switch on the rear of the power supply. You’ll need to calibrate the amp screen using a small pointed object to hit the + marks. B. That will reset the amp and cause it to clear any stored fixed IP address and revert to using DHCP. C. Once you can see the amp in the PGXL utility then be certain to enter YOUR radio serial number in the app. Let me know your result and I’ll try to help more. 73, Mack W4AX Alpha Team
  • Sergey KN7K
    Sergey KN7K Member ✭✭✭
    edited March 2020
    Enter your radio Serial Number in PGXL setup utility.
    radio coming from flex with serial number of the radio they used for testing, you have to enter your SN
    Sergey, KN7K 
  • Ian1
    Ian1 Member ✭✭
    edited May 2020
    Mack I tried all you suggested no Luck.

    Nothing is showing up in the Utility all Flex products are on my LAN verified this all have a different IP Address.

    Here is what I see on the Utility.
  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020
    The IP address looks good on the PGXL.   Provided your PC is on the same subnet, I suspect a Windows firewall issue. 

    When the PGXL Windows Utility is installed, it adds two entries to the private profile (by default), allowing inbound UDP and TCP traffic to the utility.  Those ports are required for the utility to see and communicate with the PGXL on your network.

    When Windows updates it can change the "network status" (domain, private or public) on your PC,  activating a different firewall profile.   Most of the time simply changing the status back to private cures this problem.

    If your PC is on a different subnet, that will need to be corrected. 


  • AC9S
    AC9S Member ✭✭
    edited November 2019
    I just went through the same issue - it turned out that I was using the radio serial # that showed up on the utility. It was not correct, as Sergey mentioned that was the serial # of the radio the amp had been tested with at the factory.  Once I entered the serial # of my amp it worked fine, both in the utility and in tracking the 6700.

    Keith - AC9S
  • Ian1
    Ian1 Member ✭✭
    edited May 2020
    Dan That was it made the Network Public causing the issue.

    I can now see the AMP and have added my Radio serial number thanks going to give her a try.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.