Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Software for Mac with v3

Dan TrainorDan Trainor Member ✭✭
edited May 25 in SmartSDR for Windows

I have a friend on another state who will be sharing my 6400 radio with me.  I run Window Laptop and he runs Mac.  I need to set him up. What is the best SmartSDR Flex SW to run on Macintosh for the new version 3?  Thanks in advance. dan

Answers

  • Dwayne_AB6ADwayne_AB6A Member ✭✭
    edited May 2019
    dogparkSDR is the "best" Mac client available today... Not sure if its been updated to support multilink yet... If not, real soon I guess. Alternatively run a windows VM and use the standard SDR software. I have a Mac and prefer using a VM/Windows.
  • Burch - K4QXXBurch - K4QXX Member
    edited May 25
    DogparkSDR is great on the Mac.  Unfortunately, it is not supported yet on V3.  Until it is, I will not be purchasing V3.
  • Dan TrainorDan Trainor Member ✭✭
    edited April 2019

    Ut Oh, We purchased the 6400 specifically for v3 Multi-Flex capability.  He has Mac OS.  Oh boy.
  • Jean_Luc F5JRCJean_Luc F5JRC Member ✭✭
    edited April 2019
    Parallels, W10Pro and SmartSDR 2.4.9 work very well together, having not yet switched to the V3, but nothing prevents it works with the V3! Here I use a 27 "iMac with 2 additional screens in Capture mode under Parallels Desktop. 73's :-)
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited April 2019
    He can run DogParkSDR on V2, but it does mean that the radio has to be on V2 and only 1 person can use the radio at 1 time.  With V3, you can both share the radio, but he will have to be using SmartSDR V3 on a PC.  

    You can check with DogParkSDR and see what their plans/timeline might be.  

    Mike

  • Dan TrainorDan Trainor Member ✭✭
    edited March 20

    Thanks for the information guys.  This screws us.  He only runs on Mac OS.  How can a major 3rd party software provider not be ready for a major v3 release?  That is almost impossible.  Someone dropped the ball somewhere.  Ridiculous.  I am ****.  dan
  • Dwayne_AB6ADwayne_AB6A Member ✭✭
    edited April 2019
    Flex has never offered a Mac client. 3rd parties are in the process of upgrading their clients and likely soon. Did you reach out to dogparksoftware?
  • Dan TrainorDan Trainor Member ✭✭
    edited April 2019

    Yes, we will be speaking with the DogPark folks. Find out when they are planning to be v3 compatible.  Why they would not be upon the v3 release is puzzling. Are they not a partner of Flex???  dan
  • Dwayne_AB6ADwayne_AB6A Member ✭✭
    edited April 2019
    Just an independent developer like me and many others.
  • Dan TrainorDan Trainor Member ✭✭
    edited April 2019
    Dwayne, you developers don't get access to APIs prior to the release?  There is no co-development partnerships or even coordination?  dan
  • Dwayne_AB6ADwayne_AB6A Member ✭✭
    edited April 2019
    I do api development on other platforms and the answer is “it depends” and is based on the legal relationship which can include mutual “non disclosure” and “non compete” agreements. I just started with the Flex API and as such, only available at release for “us” regular people.
  • K3SFK3SF Member ✭✭
    edited April 2019
    Dan
    the whole 3rd party s/w whether be windows or mac has been extensively discussed here..

    The best i understand it,  Flex made major incompatible API changes that require some major re-work/redesign of 3rd party s/w.  

    For  MAC, dpsdr by Don Agro was one and Don has indicated this on his website

    https://www.dogparksoftware.com/dogparkSDR.html

    i quote from the site

    The current release is limited to a maximum of 4 Pandapters and 4 VFO Slices. SmartSDR V3 not supported. You will still need the SmartSDR client running on a Windows PC or a Mac running Parallels, or a FlexRadio Maestro to install new radio firmware, or to setup USB cables connected to the radio.

    also
    mldx does not work
    https://www.dogparksoftware.com/MacLoggerDX.html

    Supported Radios

    • FlexRadio 6000 series LAN Interface, SmartSDR V3 not supported.
    and

    to add the 3rd party s/w impact,  xDax and xCat by Mario do not work with V3 and this means can not use WSJTX for FT8 or FLDIGI for rtty



    SO
    At this there is NO mac Native s/w that works with flex V3, that i am aware of.


    Your friend's best choice at this time is to run a virtual machine such as Parallels or VMware fusion and run windows SSDR.

    Paul K3SF






  • Dan TrainorDan Trainor Member ✭✭
    edited April 2019

    Thanks Paul for this most detailed explanation.  I appreciate it. It's unfortunate, but at least a work around.  But he does not like VM modes. I most probably will just buy him and ship to him a Windows 10 laptop for use with Flex v3 remote operation.  Or a maestro. Thanks, dan
  • Don AgroDon Agro Member
    edited April 2019
    Since the Flex SmartSDR V3 API (MultiFlex) is not upward compatible with the V2 API, third party applications like MacLoggerDX and dogparkSDR will not operate with SmartSDR V3 (MultiFlex) until they are re-written to support both the V2 and the V3 APIs at runtime or split into multiple versions for each API Version.

    MacLoggerDX Version 6.23 Beta introduces preliminary support for V3. No date right now for dogparkSDR completion but we are working on it.

  • Dan TrainorDan Trainor Member ✭✭
    edited April 2019

    Thanks Don for the additional information.  Good Luck with your efforts. dan
  • Burch - K4QXXBurch - K4QXX Member
    edited April 2019
    Thanks for the update Don.  Love dogparkSDR and looking forward to the future update.
  • K3SFK3SF Member ✭✭
    edited April 2019
    oops i forgot

    one other choice if he is an apple person like me is to use an ipad or even iphone...

    there is latest version of iosssdr that is suppose to work with V3.

    Paul K3SF
  • Dan TrainorDan Trainor Member ✭✭
    edited April 2019
    Oh Paul,  great suggestion.  He has a nice big iPad Pro so he can run the iOS version. That would work fine for him.  And I believe he might also be able to possibly mirror iPAd screen onto his large screen TV via Apple TV and AirPlay. In any case, this is a really good solution for him as he is Apple guy.  And my use the iOS version in the last few weeks, I know it is really good.  Thanks, dan
  • K3SFK3SF Member ✭✭
    edited April 2019
    awesome...

    i would be interested in how it all works out...

    i have used my iphone in pedestrian mobil using flex V2 right now.
    i find it great for when i walk the dog.

    After Don Agro update mldx and Mario update xdat and xcat,
    i will be buying V3.

    Paul K3SF


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.