Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Radio updates with smartlink are not supported at this time... What is wrong...???

2»

Answers

  • VE7ATJ_Don
    VE7ATJ_Don British ColumbiaMember ✭✭✭
    edited May 2018
    Actually, I think he did..."Important:  The PC will not connect or even see the Flex while trying both a  new Cat6 cable or a Cat6 crossover cable connected directly between the two devices."  Sounds to me like a bad Ethernet socket at either the Flex or the PC end...
  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator
    edited May 2018
    Almost sounds like the subnet mask or something was not set correctly when he set the static IP. I would factory reset radio which should return it to DHCP and set PC to DHCP, reboot both and try again. Reminds me of an issue I had at Eastman Kodak where IBM set the wrong mask in the router which changed the default gateway Ip. 6 hour ride for a 2 minute fix. Dave wo2x
  • David Livingston
    David Livingston Member ✭✭
    edited May 2018
    The factory reset has been tried along with fresh installs after all previous software was removed from the computer..  Neither a Cat6 cable or a Cat6 crossover cable have been able connected directly from PC to Flex.. Neither worked and neither saw the radio. Yes we can ping the radio.

    I moved the radio to my home and connected without error and did the upgrade without issue within minutes. When we returned the radio to Ronnie's it will only connect and run perfectly as a remote connections.

    The issue seems to be in the software as it will only come up as Remote connection. We never have an option to connect with SmartSDR even with the network disconnected from the router. After the software and radio were updated it should connect without the internet, but they do not see each other on the LAN.

    Please understand that I do large networks for a living and I have tripled checked this network. That is why he has new cables, switch and router. A complete new network with all new static IP addresses assigned to his computer and the Flex Radio. This static IP was put on the Flex at my home and it worked perfectly.  Everything in his home works perfectly but the connection to the Flex. I even went so far as to confirm that the Spectrum modem was in bridge mode with Spectrum.

    I have worked a many large complex networks for over 25 years, but this little one has me to the point that I now believe we have a software issue. Our next step will probably be a fresh reload of Windows 10 Pro. 

    Thanks to all for your suggestions and comments.

    K4CAE
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited May 2018
    David

    I have not read all the above posts,  however, if you connect the radio directly to the computer and the computer NIC card is set to DHCP, the computer will see the radio.  As I am sure you area aware, this will give both NIC cards (radio and computer) a 169.... address with a wide subnet mask.  Then, the radio and the computer should be able to communicate locally.

    We do this all the time a Ham Radio shows without issue.
      
    Then, start SmartSDR and you should see the radio in the chooser without it being a SmartLink connection.     

    Let us know the results of that setup.

    thanks
  • David Livingston
    David Livingston Member ✭✭
    edited May 2018
    Michael, this did not work.  We loaded SmartSDR on another workstation on the same network and it works perfectly.  We are going to do a fresh install to the regular Flex radio workstation. This should fix the issue. Since we are doing this Ronnie also wants to update to a SSD drive. This will make him much happier.... 73 K4CAE

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited May 2018
    Excellent.  Want to bet his NIC was set to Public or was it Private?
  • w5uok
    w5uok Member
    edited January 2019
    Not sure if this helps but I had the exact same problem. I found mine was the firewall in my antivirus was stopping mine. Once i disabled the firewall/antivirus software for a few minutes it let me install the update.  

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.