Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

WSJT-X Hamlib Error

ReggieReggie Member ✭✭
edited June 11 in SmartSDR for Windows

Hi,

I have SSDR 2.1.33 and WSJT-X 1.8 installed in the Win10 VM using Parallels 13; however, I am getting a Hamlib error when opening the connection to the Flex 6600.  I configured WSJT-X with the following setting:

Rig: Kenwood TS-2000

Serial Port: COM4

PTT Method: CAT

Mode: None

Data Bits: 81N  I also tried 82N

Split Operations: None

 

How do I correct this issue?

Thanks,

Reggie

Answers

  • David SalomonDavid Salomon Member ✭✭
    edited April 3
    Reggie -

    Not sure if this matters in your environment, but Kenwood serial interfaces are usually 4800 baud, 8N2.  You didn't mention the baud rate.

    73 - David, AG4F
  • ReggieReggie Member ✭✭
    edited April 2019

    David,

    I set those parameters, but I still get the error.

    73,

    Reggie

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    That really doesn't make a lot of difference.  The FlexVSP driver will dynamically configure the baud, parity and stop bits of the endpoint device (which is why you never set it in CAT)
  • David SalomonDavid Salomon Member ✭✭
    edited April 3
    OK, one more thought.  Look at this post: https://community.flexradio.com/flexradio/topics/time-to-update-the-recommended-wsjt-x-config.  It talks about using TCP instead of COM for communications, and gives some examples.  A few people mentioned that TCP worked for them where COM did not.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    It could be a configuration issue with running it in your VM
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    I endorse this option.  It eliminates the virtual serial port layer form the configuration.
  • David SalomonDavid Salomon Member ✭✭
    edited April 2018
    And, you wrote the book on it. :)
  • Jay  K8CJYJay K8CJY Member
    edited April 2018
    Use the FlexRadio  6xxx rig profile and enter  localhost:5002  into the Network Server box.  Set PTT to CAT.  It works very well and does not tie up a com port.

    73 Jay K8CJY
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited April 2018
    Try a speed of 19200. That worked for me.
  • ReggieReggie Member ✭✭
    edited April 2018

    Using TCP nor setting the baud rate to 19200 did not resolve the issue. 


    Reggie

  • RiaRia Member ✭✭
    edited April 2018
    I don’t use TCP. It crashes and causes WSJT-X to hang in memory after exit requiring you to **** the process to restart. I have no problems using the serial port option. Likely a WSJT/Hamlib issue and not Flex.
  • RiaRia Member ✭✭
    edited November 2019
    If you’re using a 6600 you need the new WSJT-X. It should work with 1.9-rc3, or the special build from WO2X. But I would really recommend 1.9 as it has the new DXpedition mode and you can take part in the tests.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    That's interesting.  I do not have those issues.  
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited June 11
    As Ria said, download the latest version of WSJT-x, currently 1.9 rc3. https://physics.princeton.edu/pulsar/k1jt/wsjtx.html Scroll down newr the bottom for the link to latest 1.9 release candidate for Windows. The 1.9 or higher versions support the 6400 and 6600 models. I suggest following the insteuctions on this thread, https://community.flexradio.com/flexradio/topics/i-am-trying-to-get-my-new-6600-working-with-wsjt-x-rx-works-cat-doest?topic-reply-list[settings][filter_by]=all I suggest creating a TCP port 5004 and in WSJT-X for radio IP use 127.0.0.1:5004 Reason is 5002 is reserved for DDUtil and if you use or plan to use DDUtil in the futurw you will have a conflict. Dave wo2x
  • ReggieReggie Member ✭✭
    edited April 2018

    All,

    Thanks for the assistance. WSJT-X 1.9 rc3 is working. I was reluctant to use this version since it was Beta, but it resolves the Hamlib error.

    Reggie




Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.